summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-21 08:23:01 +0100
committerRemi Collet <remi@php.net>2022-02-21 08:23:01 +0100
commit71da333ae521f57a6ef72fb82d1c390eb30a757d (patch)
treedd719a1d1673abe3019f1e6102a25e073ede9ae6
parentf1b21807bbfaefbc93b1da68cfd9b111ee84ef8c (diff)
update to 1.1.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION497
-rw-r--r--php-pecl-teds.spec5
3 files changed, 489 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 3e14ad0..774118b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 1.0.1
+teds version => 1.1.2
diff --git a/REFLECTION b/REFLECTION
index 3c464e9..b82a9dd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 1.0.1 ] {
+Extension [ <persistent> extension #99 teds version 1.1.2 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -97,9 +97,17 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
}
- Return [ array ]
}
+ Function [ <internal:teds> function Teds\is_same_array_handle ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $array1 ]
+ Parameter #1 [ <required> array $array2 ]
+ }
+ - Return [ bool ]
+ }
}
- - Classes [21] {
+ - Classes [22] {
Interface [ <internal:teds> interface Teds\Collection extends Traversable, Countable ] {
- Constants [0] {
@@ -564,7 +572,23 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [3] {
+ Method [ <internal:teds> static public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ Teds\BitSet ]
+ }
+
+ Method [ <internal:teds> static public method fromBinaryString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ Teds\BitSet ]
+ }
+
Method [ <internal:teds> static public method __set_state ] {
- Parameters [1] {
@@ -577,7 +601,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [27] {
+ - Methods [42] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -628,6 +652,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:teds> public method toBinaryString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method push ] {
- Parameters [1] {
@@ -652,6 +690,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method pop ] {
- Parameters [0] {
@@ -713,6 +765,98 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method getInt8 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method getUInt8 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method setInt8 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> int $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method getInt16 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method getUInt16 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method setInt16 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> int $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method getInt32 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method getUInt32 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method setInt32 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> int $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method getInt64 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method setInt64 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> int $value ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
@@ -788,6 +932,179 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\CachedIterable implements IteratorAggregate, Traversable, Teds\Collection, Countable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:teds> static public method fromPairs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $pairs ]
+ }
+ - Return [ Teds\CachedIterable ]
+ }
+
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\CachedIterable ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [19] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $iterator ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method toPairs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method keys ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method keyAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOfKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds> public method indexOfValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method containsValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Teds\Sequence, ArrayAccess, Countable, Teds\Collection, JsonSerializable ] {
- Constants [0] {
@@ -809,7 +1126,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [28] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -890,6 +1207,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
@@ -897,6 +1221,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method top ] {
- Parameters [0] {
@@ -1202,7 +1533,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [25] {
+ - Methods [27] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1307,6 +1638,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
- Parameters [0] {
@@ -1417,7 +1762,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [28] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1491,6 +1836,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:teds, prototype Teds\Collection> public method clear ] {
- Parameters [0] {
@@ -1869,7 +2228,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1920,6 +2279,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ void ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds, prototype Teds\Sequence> public method push ] {
- Parameters [1] {
@@ -2083,7 +2456,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [28] {
+ - Methods [32] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2162,6 +2535,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
@@ -2169,6 +2549,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method firstKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottomKey ] {
- Parameters [0] {
@@ -2176,6 +2563,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method top ] {
- Parameters [0] {
@@ -2183,6 +2577,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method lastKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method topKey ] {
- Parameters [0] {
@@ -2314,7 +2715,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [19] {
+ - Methods [21] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2379,6 +2780,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
@@ -2386,6 +2794,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method top ] {
- Parameters [0] {
@@ -2775,7 +3190,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [26] {
+ - Methods [30] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2854,6 +3269,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
@@ -2861,6 +3283,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method firstKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottomKey ] {
- Parameters [0] {
@@ -2868,6 +3297,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method top ] {
- Parameters [0] {
@@ -2875,6 +3311,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method lastKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method topKey ] {
- Parameters [0] {
@@ -2992,7 +3435,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [19] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -3057,6 +3500,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
@@ -3064,6 +3514,13 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds> public method top ] {
- Parameters [0] {
@@ -3441,7 +3898,7 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [31] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -3553,6 +4010,20 @@ Extension [ <persistent> extension #99 teds version 1.0.1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method first ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method last ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
- Parameters [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 61d9625..6a5ea23 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.0.1
+%global upstream_version 1.1.2
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Mon Feb 21 2022 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
* Thu Feb 17 2022 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1