summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-26 07:58:35 +0100
committerRemi Collet <remi@remirepo.net>2019-12-26 07:58:35 +0100
commitd5468cc99ab9fda8b5c895fe48c64caa2f78ed83 (patch)
tree94a3c4fb3d8c71f53e809e5414a3d03fc3de6e86
parentc1f85a2af87e30e415387ce9974242bfde11db2a (diff)
v2.0.6
-rw-r--r--64.patch31
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-taint.spec17
4 files changed, 8 insertions, 44 deletions
diff --git a/64.patch b/64.patch
deleted file mode 100644
index 4238991..0000000
--- a/64.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 389dfe16c97c0ba517fe94f49766cc74e6ed3327 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 27 Jun 2018 17:17:59 +0200
-Subject: [PATCH] fix -Wformat warning
-
----
- taint.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/taint.c b/taint.c
-index e4b0765..f404cc4 100644
---- a/taint.c
-+++ b/taint.c
-@@ -248,7 +248,7 @@ static zval *php_taint_fetch_dimension_address_inner(HashTable *ht, const zval *
- hval = zend_dval_to_lval(Z_DVAL_P(dim));
- goto num_index;
- case IS_RESOURCE:
-- zend_error(E_NOTICE, "Resource ID#%pd used as offset, casting to integer (%pd)", Z_RES_HANDLE_P(dim), Z_RES_HANDLE_P(dim));
-+ zend_error(E_NOTICE, "Resource ID#%d used as offset, casting to integer (%d)", Z_RES_HANDLE_P(dim), Z_RES_HANDLE_P(dim));
- hval = Z_RES_HANDLE_P(dim);
- goto num_index;
- case IS_FALSE:
-@@ -610,7 +610,7 @@ static void php_taint_error(const char *fname, const char *format, ...) /* {{{ *
- vspprintf(&buffer, 0, format, args);
- spprintf(&msg, 0, "%s() [%s]: %s", get_active_function_name(), fname, buffer);
- efree(buffer);
-- zend_error(TAINT_G(error_level), msg);
-+ zend_error(TAINT_G(error_level), "%s", msg);
- efree(msg);
- va_end(args);
- } /* }}} */
diff --git a/PHPINFO b/PHPINFO
index d5f5d06..22395e3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
taint
taint support => enabled
-Version => 2.0.5
+Version => 2.0.6
Directive => Local Value => Master Value
taint.enable => Off => Off
diff --git a/REFLECTION b/REFLECTION
index de6f8f0..168d67e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #152 taint version 2.0.5 ] {
+Extension [ <persistent> extension #108 taint version 2.0.6 ] {
- Dependencies {
Dependency [ xdebug (Conflicts) ]
diff --git a/php-pecl-taint.spec b/php-pecl-taint.spec
index 39e829e..c368857 100644
--- a/php-pecl-taint.spec
+++ b/php-pecl-taint.spec
@@ -22,18 +22,17 @@
Summary: XSS code sniffer
Name: %{?sub_prefix}php-pecl-taint
-Version: 2.0.5
+Version: 2.0.6
%if 0%{?gh_date:1}
Release: 0.3.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
-Patch0: https://patch-diff.githubusercontent.com/raw/laruence/taint/pull/64.patch
Patch1: https://patch-diff.githubusercontent.com/raw/laruence/taint/pull/68.patch
BuildRequires: %{?dtsprefix}gcc
@@ -48,12 +47,6 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
@@ -108,7 +101,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr64
%patch1 -p1 -b .pr68
# When this file will be removed, clean the description.
@@ -246,6 +238,9 @@ fi
%changelog
+* Thu Dec 26 2019 Remi Collet <remi@remirepo.net> - 2.0.6-1
+- update to 2.0.6
+
* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 2.0.5-2
- fix test suite