summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-04 16:09:41 +0200
committerRemi Collet <remi@remirepo.net>2019-06-04 16:09:41 +0200
commitc1f85a2af87e30e415387ce9974242bfde11db2a (patch)
tree6c6ab1eaee2ee0a6dcc92410425f96fe7c21cc36
parentb419007a79ef0ae5e27134190614380d27c690ae (diff)
fix test suite
-rw-r--r--php-pecl-taint.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/php-pecl-taint.spec b/php-pecl-taint.spec
index ba162bb..39e829e 100644
--- a/php-pecl-taint.spec
+++ b/php-pecl-taint.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-taint
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -27,7 +27,7 @@ Version: 2.0.5
Release: 0.3.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
@@ -59,9 +59,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -187,10 +191,9 @@ DEP="-d extension=pdo.so -d extension=pdo_sqlite.so -d extension=sqlite3.so"
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n $DEP -d %{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
+TEST_PHP_ARGS="-n $DEP -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || : ignore
+%{__php} -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -203,9 +206,8 @@ rm tests/004.phpt
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEP -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -244,6 +246,9 @@ fi
%changelog
+* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 2.0.5-2
+- fix test suite
+
* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 2.0.5-1
- Update to 2.0.5
- add patch for PHP 7.0 from