summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-missing-header.patch24
-rw-r--r--0002-fix-implicit-int.patch27
-rw-r--r--5239.patch34
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-swoole5.spec25
6 files changed, 77 insertions, 47 deletions
diff --git a/0001-missing-header.patch b/0001-missing-header.patch
new file mode 100644
index 0000000..58784aa
--- /dev/null
+++ b/0001-missing-header.patch
@@ -0,0 +1,24 @@
+From 10feb6a1ca1c396d323f4bf92acd67feae758a62 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 6 Jun 2024 10:08:05 +0200
+Subject: [PATCH] missing header
+
+---
+ thirdparty/php83/pdo_odbc/odbc_driver.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/thirdparty/php83/pdo_odbc/odbc_driver.c b/thirdparty/php83/pdo_odbc/odbc_driver.c
+index c83da646c..a5e3a8b4f 100644
+--- a/thirdparty/php83/pdo_odbc/odbc_driver.c
++++ b/thirdparty/php83/pdo_odbc/odbc_driver.c
+@@ -25,6 +25,7 @@
+ #include "pdo/php_pdo.h"
+ #include "pdo/php_pdo_driver.h"
+ #include "zend_exceptions.h"
++#include <php_odbc_utils.h>
+
+ static void pdo_odbc_fetch_error_func(pdo_dbh_t *dbh, pdo_stmt_t *stmt, zval *info) {
+ pdo_odbc_db_handle *H = (pdo_odbc_db_handle *) dbh->driver_data;
+--
+2.45.1
+
diff --git a/0002-fix-implicit-int.patch b/0002-fix-implicit-int.patch
new file mode 100644
index 0000000..728187d
--- /dev/null
+++ b/0002-fix-implicit-int.patch
@@ -0,0 +1,27 @@
+From c127c74ba12ffb62afa653710c574f28e469e7a7 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 6 Jun 2024 10:16:26 +0200
+Subject: [PATCH 2/2] fix implicit int
+
+---
+ ext-src/php_swoole_call_stack.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext-src/php_swoole_call_stack.h b/ext-src/php_swoole_call_stack.h
+index 8c89f8305..639a303d7 100644
+--- a/ext-src/php_swoole_call_stack.h
++++ b/ext-src/php_swoole_call_stack.h
+@@ -18,8 +18,8 @@
+
+ #ifdef ZEND_CHECK_STACK_LIMIT
+ #define HOOK_PHP_CALL_STACK(callback) \
+- auto __stack_limit = EG(stack_limit); \
+- auto __stack_base = EG(stack_base); \
++ void *__stack_limit = EG(stack_limit); \
++ void *__stack_base = EG(stack_base); \
+ EG(stack_base) = (void *) 0; \
+ EG(stack_limit) = (void *) 0; \
+ callback EG(stack_limit) = __stack_limit; \
+--
+2.45.1
+
diff --git a/5239.patch b/5239.patch
deleted file mode 100644
index 31a61c4..0000000
--- a/5239.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From e7c56d9842d17df0647d8e87251a2f70f06cde63 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 24 Jan 2024 09:56:17 +0100
-Subject: [PATCH] Fix out of sources tree build
-
----
- config.m4 | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/config.m4 b/config.m4
-index 2e8c166021..d68d06b6df 100644
---- a/config.m4
-+++ b/config.m4
-@@ -1009,14 +1009,19 @@ EOF
- AC_DEFINE(SW_USE_MYSQLND, 1, [use mysqlnd])
- fi
-
-- if test -f "ext-src/php_swoole.cc"; then
-+ AC_MSG_CHECKING([for sources])
-+ if test -f "$abs_srcdir/ext-src/php_swoole.cc"; then
-+ swoole_source_dir=$abs_srcdir
-+ elif test -f "ext-src/php_swoole.cc"; then
- swoole_source_dir=$(pwd)
- else
- swoole_source_dir="ext/swoole"
- fi
-+ AC_MSG_RESULT([$swoole_source_dir])
-
- ext_src_files=$(cd $swoole_source_dir && find ext-src/ -name *.cc)
- lib_src_files=$(cd $swoole_source_dir && find src/ -name *.cc)
-+
- swoole_source_file="${ext_src_files} ${lib_src_files}"
-
- swoole_source_file="$swoole_source_file \
diff --git a/PHPINFO b/PHPINFO
index 65f3d31..dbd76ac 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.1.2
-Built => Jan 24 2024 00:00:00
+Version => 5.1.3
+Built => Jun 6 2024 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -20,7 +20,7 @@ http2 => enabled
json => enabled
curl-native => enabled
pcre => enabled
-c-ares => 1.25.0
+c-ares => 1.28.1
zlib => 1.2.13
brotli => E16781312/D16781312
mutex_timedlock => enabled
diff --git a/REFLECTION b/REFLECTION
index 8d362ab..c3d8b64 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 swoole version 5.1.2 ] {
+Extension [ <persistent> extension #94 swoole version 5.1.3 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -33,11 +33,11 @@ Extension [ <persistent> extension #79 swoole version 5.1.2 ] {
}
- Constants [421] {
- Constant [ string SWOOLE_VERSION ] { 5.1.2 }
- Constant [ int SWOOLE_VERSION_ID ] { 50102 }
+ Constant [ string SWOOLE_VERSION ] { 5.1.3 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50103 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 3 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index 2191a6e..69e0d30 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -24,11 +24,11 @@
%bcond_with oracle
%ifarch aarch64
-%global oraclever 19.19
+%global oraclever 19.22
%global oraclelib 19.1
-%global oracledir 19.19
+%global oracledir 19.22
%else
-%global oraclever 21.11
+%global oraclever 21.13
%global oraclelib 21.1
%global oracledir 21
%endif
@@ -54,7 +54,7 @@
%bcond_without nghttpd2
-%global upstream_version 5.1.2
+%global upstream_version 5.1.3
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -70,7 +70,8 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/5239.patch
+Patch0: 0001-missing-header.patch
+Patch1: 0002-fix-implicit-int.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -191,7 +192,8 @@ sed \
cd %{sources}
-%patch -P0 -p1 -b .out
+%patch -P0 -p1
+%patch -P1 -p1
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
%if %{with nghttpd2}
@@ -252,6 +254,8 @@ peclbuild() {
%endif
%if %{with brotli}
--enable-brotli \
+%else
+ --disable-brotli \
%endif
%if %{with nghttpd2}
--with-nghttp2-dir=%{_root_prefix} \
@@ -385,6 +389,15 @@ cd ../ZTS
%changelog
+* Thu Jun 6 2024 Remi Collet <remi@remirepo.net> - 5.1.3-1
+- update to 5.1.3
+- fix build warnings (errors with GCC 14) using patch from
+ https://github.com/swoole/swoole-src/pull/5363
+
+* Mon May 13 2024 Remi Collet <remi@remirepo.net> - 5.1.2-2
+- refresh sources
+- drop patch merged upstream
+
* Wed Jan 24 2024 Remi Collet <remi@remirepo.net> - 5.1.2-1
- update to 5.1.2
- fix out of sources tree build using patch from