summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-24 10:35:46 +0100
committerRemi Collet <remi@php.net>2024-01-24 10:35:46 +0100
commit3df506b34935bae0bd649d6ba1862432e1ee68b1 (patch)
tree5003beffcd45c32f3056309c893bb0fe06abe94e
parent9ee6f211a53dc37641e25337af5b64aeb34011df (diff)
update to 5.1.2HEADmaster
fix out of sources tree build using patch from https://github.com/swoole/swoole-src/pull/5239
-rw-r--r--5239.patch34
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-swoole5.spec17
4 files changed, 61 insertions, 12 deletions
diff --git a/5239.patch b/5239.patch
new file mode 100644
index 0000000..31a61c4
--- /dev/null
+++ b/5239.patch
@@ -0,0 +1,34 @@
+From e7c56d9842d17df0647d8e87251a2f70f06cde63 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 24 Jan 2024 09:56:17 +0100
+Subject: [PATCH] Fix out of sources tree build
+
+---
+ config.m4 | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/config.m4 b/config.m4
+index 2e8c166021..d68d06b6df 100644
+--- a/config.m4
++++ b/config.m4
+@@ -1009,14 +1009,19 @@ EOF
+ AC_DEFINE(SW_USE_MYSQLND, 1, [use mysqlnd])
+ fi
+
+- if test -f "ext-src/php_swoole.cc"; then
++ AC_MSG_CHECKING([for sources])
++ if test -f "$abs_srcdir/ext-src/php_swoole.cc"; then
++ swoole_source_dir=$abs_srcdir
++ elif test -f "ext-src/php_swoole.cc"; then
+ swoole_source_dir=$(pwd)
+ else
+ swoole_source_dir="ext/swoole"
+ fi
++ AC_MSG_RESULT([$swoole_source_dir])
+
+ ext_src_files=$(cd $swoole_source_dir && find ext-src/ -name *.cc)
+ lib_src_files=$(cd $swoole_source_dir && find src/ -name *.cc)
++
+ swoole_source_file="${ext_src_files} ${lib_src_files}"
+
+ swoole_source_file="$swoole_source_file \
diff --git a/PHPINFO b/PHPINFO
index 1b3c8af..65f3d31 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.1.1
-Built => Nov 27 2023 00:00:00
+Version => 5.1.2
+Built => Jan 24 2024 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -20,7 +20,7 @@ http2 => enabled
json => enabled
curl-native => enabled
pcre => enabled
-c-ares => 1.21.0
+c-ares => 1.25.0
zlib => 1.2.13
brotli => E16781312/D16781312
mutex_timedlock => enabled
diff --git a/REFLECTION b/REFLECTION
index 20d5230..8d362ab 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #74 swoole version 5.1.1 ] {
+Extension [ <persistent> extension #79 swoole version 5.1.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -32,12 +32,12 @@ Extension [ <persistent> extension #74 swoole version 5.1.1 ] {
}
}
- - Constants [415] {
- Constant [ string SWOOLE_VERSION ] { 5.1.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 50101 }
+ - Constants [421] {
+ Constant [ string SWOOLE_VERSION ] { 5.1.2 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50102 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -421,6 +421,9 @@ Extension [ <persistent> extension #74 swoole version 5.1.1 ] {
Constant [ int SWOOLE_WEBSOCKET_CLOSE_MESSAGE_TOO_BIG ] { 1009 }
Constant [ int SWOOLE_WEBSOCKET_CLOSE_EXTENSION_MISSING ] { 1010 }
Constant [ int SWOOLE_WEBSOCKET_CLOSE_SERVER_ERROR ] { 1011 }
+ Constant [ int SWOOLE_WEBSOCKET_CLOSE_CLOSE_SERVICE_RESTART ] { 1012 }
+ Constant [ int SWOOLE_WEBSOCKET_CLOSE_TRY_AGAIN_LATER ] { 1013 }
+ Constant [ int SWOOLE_WEBSOCKET_CLOSE_BAD_GATEWAY ] { 1014 }
Constant [ int SWOOLE_WEBSOCKET_CLOSE_TLS ] { 1015 }
Constant [ int WEBSOCKET_STATUS_CONNECTION ] { 1 }
Constant [ int WEBSOCKET_STATUS_HANDSHAKE ] { 2 }
@@ -444,6 +447,9 @@ Extension [ <persistent> extension #74 swoole version 5.1.1 ] {
Constant [ int WEBSOCKET_CLOSE_MESSAGE_TOO_BIG ] { 1009 }
Constant [ int WEBSOCKET_CLOSE_EXTENSION_MISSING ] { 1010 }
Constant [ int WEBSOCKET_CLOSE_SERVER_ERROR ] { 1011 }
+ Constant [ int WEBSOCKET_CLOSE_CLOSE_SERVICE_RESTART ] { 1012 }
+ Constant [ int WEBSOCKET_CLOSE_TRY_AGAIN_LATER ] { 1013 }
+ Constant [ int WEBSOCKET_CLOSE_BAD_GATEWAY ] { 1014 }
Constant [ int WEBSOCKET_CLOSE_TLS ] { 1015 }
Constant [ int SW_PGSQL_ASSOC ] { 1 }
Constant [ int SW_PGSQL_NUM ] { 2 }
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index 9435dd9..2191a6e 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole5
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -54,7 +54,7 @@
%bcond_without nghttpd2
-%global upstream_version 5.1.1
+%global upstream_version 5.1.2
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -70,6 +70,8 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/5239.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -189,6 +191,8 @@ sed \
cd %{sources}
+%patch -P0 -p1 -b .out
+
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
%if %{with nghttpd2}
rm -r thirdparty/nghttp2
@@ -337,14 +341,14 @@ OPT="--no-php-ini"
cd NTS
: Minimal load test for NTS extension
%{__php} $OPT \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} $OPT \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%endif
@@ -381,6 +385,11 @@ cd ../ZTS
%changelog
+* Wed Jan 24 2024 Remi Collet <remi@remirepo.net> - 5.1.2-1
+- update to 5.1.2
+- fix out of sources tree build using patch from
+ https://github.com/swoole/swoole-src/pull/5239
+
* Mon Nov 27 2023 Remi Collet <remi@remirepo.net> - 5.1.1-1
- update to 5.1.1