summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-18 09:19:07 +0200
committerRemi Collet <remi@php.net>2022-04-18 09:19:07 +0200
commit51e6c7f23838c6c7aba19b19d4a53b233906588b (patch)
tree56bce1180a8a7bd48fa205736a761964fe729519 /php-pecl-swoole4.spec
parent162b4817fe31f5d2f624e11804cc00a4dc503668 (diff)
update to 4.8.9
add workaround to build failure reported as https://github.com/swoole/swoole-src/issues/4693
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec30
1 files changed, 18 insertions, 12 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 387e3a9..3d966b7 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.8
+%global upstream_version 4.8.9
#global upstream_prever RC2
@@ -42,6 +42,8 @@ License: ASL 2.0 and BSD and MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: %{pecl_name}-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -107,18 +109,15 @@ Obsoletes: php81-pecl-%{pecl_name} <= %{version}
Event-driven asynchronous and concurrent networking engine with
high performance for PHP.
- event-driven
+- coroutines
- asynchronous non-blocking
-- multi-thread reactor
-- multi-process worker
-- multi-protocol
-- millisecond timer
-- async mysql client
-- built-in http/websocket/http2 server
-- async http/websocket client
-- async redis client
-- async task
-- async read/write file system
-- async dns lookup
+- built-in tcp/http/websocket/http2 server
+- coroutine tcp/http/websocket client
+- coroutine mysql client
+- coroutine redis client
+- coroutine read/write file system
+- coroutine dns lookup
+- automatically replace blocking functions to non-blocking
- support IPv4/IPv6/UnixSocket/TCP/UDP
- support SSL/TLS encrypted transmission
@@ -152,6 +151,8 @@ sed \
cd NTS
+%patch0 -p1
+
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -321,6 +322,11 @@ cd ../ZTS
%changelog
+* Mon Apr 18 2022 Remi Collet <remi@remirepo.net> - 4.8.9-1
+- update to 4.8.9
+- add workaround to build failure reported as
+ https://github.com/swoole/swoole-src/issues/4693
+
* Wed Mar 16 2022 Remi Collet <remi@remirepo.net> - 4.8.8-1
- update to 4.8.8