summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-18 09:19:07 +0200
committerRemi Collet <remi@php.net>2022-04-18 09:19:07 +0200
commit51e6c7f23838c6c7aba19b19d4a53b233906588b (patch)
tree56bce1180a8a7bd48fa205736a761964fe729519
parent162b4817fe31f5d2f624e11804cc00a4dc503668 (diff)
update to 4.8.9
add workaround to build failure reported as https://github.com/swoole/swoole-src/issues/4693
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION27
-rw-r--r--php-pecl-swoole4.spec30
-rw-r--r--swoole-build.patch14
4 files changed, 49 insertions, 28 deletions
diff --git a/PHPINFO b/PHPINFO
index 30b2814..3505971 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.8.8
-Built => Mar 16 2022 00:00:00
+Version => 4.8.9
+Built => Apr 18 2022 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1l FIPS 24 Aug 2021
+openssl => OpenSSL 1.1.1n FIPS 15 Mar 2022
dtls => enabled
http2 => enabled
json => enabled
diff --git a/REFLECTION b/REFLECTION
index 4458fcb..041170f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
+Extension [ <persistent> extension #89 swoole version 4.8.9 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
}
}
- - Constants [394] {
- Constant [ string SWOOLE_VERSION ] { 4.8.8 }
- Constant [ int SWOOLE_VERSION_ID ] { 40808 }
+ - Constants [395] {
+ Constant [ string SWOOLE_VERSION ] { 4.8.9 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40809 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 8 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 9 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -140,6 +140,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_IGNORE ] { 3004 }
+ Constant [ int SWOOLE_ERROR_HTTP2_SEND_CONTROL_FRAME_FAILED ] { 3005 }
Constant [ int SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
Constant [ int SWOOLE_ERROR_AIO_CANCELED ] { 4002 }
Constant [ int SWOOLE_ERROR_AIO_TIMEOUT ] { 4003 }
@@ -6949,7 +6950,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $worker_id = <default> ]
+ Parameter #1 [ <optional> $task_worker_index = <default> ]
Parameter #2 [ <optional> ?callable $finish_callback = <default> ]
}
}
@@ -6959,7 +6960,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
Parameter #1 [ <optional> $timeout = <default> ]
- Parameter #2 [ <optional> $worker_id = <default> ]
+ Parameter #2 [ <optional> $task_worker_index = <default> ]
}
}
@@ -7962,7 +7963,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $worker_id = <default> ]
+ Parameter #1 [ <optional> $task_worker_index = <default> ]
Parameter #2 [ <optional> ?callable $finish_callback = <default> ]
}
}
@@ -7972,7 +7973,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
Parameter #1 [ <optional> $timeout = <default> ]
- Parameter #2 [ <optional> $worker_id = <default> ]
+ Parameter #2 [ <optional> $task_worker_index = <default> ]
}
}
@@ -8480,7 +8481,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $worker_id = <default> ]
+ Parameter #1 [ <optional> $task_worker_index = <default> ]
Parameter #2 [ <optional> ?callable $finish_callback = <default> ]
}
}
@@ -8490,7 +8491,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
Parameter #1 [ <optional> $timeout = <default> ]
- Parameter #2 [ <optional> $worker_id = <default> ]
+ Parameter #2 [ <optional> $task_worker_index = <default> ]
}
}
@@ -9003,7 +9004,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $worker_id = <default> ]
+ Parameter #1 [ <optional> $task_worker_index = <default> ]
Parameter #2 [ <optional> ?callable $finish_callback = <default> ]
}
}
@@ -9013,7 +9014,7 @@ Extension [ <persistent> extension #89 swoole version 4.8.8 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
Parameter #1 [ <optional> $timeout = <default> ]
- Parameter #2 [ <optional> $worker_id = <default> ]
+ Parameter #2 [ <optional> $task_worker_index = <default> ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 387e3a9..3d966b7 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.8
+%global upstream_version 4.8.9
#global upstream_prever RC2
@@ -42,6 +42,8 @@ License: ASL 2.0 and BSD and MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: %{pecl_name}-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -107,18 +109,15 @@ Obsoletes: php81-pecl-%{pecl_name} <= %{version}
Event-driven asynchronous and concurrent networking engine with
high performance for PHP.
- event-driven
+- coroutines
- asynchronous non-blocking
-- multi-thread reactor
-- multi-process worker
-- multi-protocol
-- millisecond timer
-- async mysql client
-- built-in http/websocket/http2 server
-- async http/websocket client
-- async redis client
-- async task
-- async read/write file system
-- async dns lookup
+- built-in tcp/http/websocket/http2 server
+- coroutine tcp/http/websocket client
+- coroutine mysql client
+- coroutine redis client
+- coroutine read/write file system
+- coroutine dns lookup
+- automatically replace blocking functions to non-blocking
- support IPv4/IPv6/UnixSocket/TCP/UDP
- support SSL/TLS encrypted transmission
@@ -152,6 +151,8 @@ sed \
cd NTS
+%patch0 -p1
+
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -321,6 +322,11 @@ cd ../ZTS
%changelog
+* Mon Apr 18 2022 Remi Collet <remi@remirepo.net> - 4.8.9-1
+- update to 4.8.9
+- add workaround to build failure reported as
+ https://github.com/swoole/swoole-src/issues/4693
+
* Wed Mar 16 2022 Remi Collet <remi@remirepo.net> - 4.8.8-1
- update to 4.8.8
diff --git a/swoole-build.patch b/swoole-build.patch
new file mode 100644
index 0000000..5ee6e39
--- /dev/null
+++ b/swoole-build.patch
@@ -0,0 +1,14 @@
+diff --git a/include/swoole_string.h b/include/swoole_string.h
+index 4affbac81..f80890c46 100644
+--- a/include/swoole_string.h
++++ b/include/swoole_string.h
+@@ -25,6 +25,9 @@
+ #define SW_STRINGS(s) s->str, s->size
+ #define SW_STRINGCVL(s) s->str + s->offset, s->length - s->offset
+
++/* see https://github.com/swoole/swoole-src/issues/4693 */
++#pragma GCC diagnostic ignored "-Wformat-security"
++
+ namespace swoole {
+
+ typedef std::function<bool(const char *, size_t)> StringExplodeHandler;