summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-15 09:26:39 +0200
committerRemi Collet <remi@php.net>2021-10-15 09:26:39 +0200
commit474ce85d6aea625aebcbcb102b5287b144db6af6 (patch)
tree1d31eaff7236f4f48faeee001c346ce313fd5884 /php-pecl-swoole4.spec
parente1f883e089947910c7f6dc1a2c477495666a6704 (diff)
update to 4.8.0
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec18
1 files changed, 10 insertions, 8 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 4eb8b39..45e1cd9 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -28,14 +28,14 @@
%bcond_with brotli
%endif
-%global upstream_version 4.7.1
+%global upstream_version 4.8.0
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
@@ -95,9 +95,6 @@ Conflicts: %{?sub_prefix}php-pecl-%{pecl_name}2 < 4
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -163,6 +160,9 @@ sed \
cd NTS
+cp -p thirdparty/hiredis/COPYING hiredis-COPYING
+cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -300,11 +300,10 @@ cd ../ZTS
%files
%{?_licensedir:%license NTS/LICENSE}
-%{?_licensedir:%license NTS/thirdparty/hiredis/COPYING}
-%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
+%{?_licensedir:%license NTS/*-COPYING}
%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
+%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/thirdparty/*/COPYING}
%doc %{pecl_docdir}/%{pecl_name}/*md
-%doc %{pecl_docdir}/%{pecl_name}/CREDITS
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -330,6 +329,9 @@ cd ../ZTS
%changelog
+* Fri Oct 15 2021 Remi Collet <remi@remirepo.net> - 4.8.0-1
+- update to 4.8.0
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 4.7.1-2
- rebuild for 8.1.0RC1