summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-15 09:26:39 +0200
committerRemi Collet <remi@php.net>2021-10-15 09:26:39 +0200
commit474ce85d6aea625aebcbcb102b5287b144db6af6 (patch)
tree1d31eaff7236f4f48faeee001c346ce313fd5884
parente1f883e089947910c7f6dc1a2c477495666a6704 (diff)
update to 4.8.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION360
-rw-r--r--php-pecl-swoole4.spec18
3 files changed, 343 insertions, 43 deletions
diff --git a/PHPINFO b/PHPINFO
index b7eacc3..fa75628 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.7.1
-Built => Aug 26 2021 00:00:00
+Version => 4.8.0
+Built => Oct 15 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,13 +14,13 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1k FIPS 25 Mar 2021
+openssl => OpenSSL 1.1.1l FIPS 24 Aug 2021
dtls => enabled
http2 => enabled
json => enabled
curl-native => enabled
pcre => enabled
-c-ares => 1.17.0
+c-ares => 1.17.2
zlib => 1.2.11
brotli => E16777225/D16777225
mutex_timedlock => enabled
diff --git a/REFLECTION b/REFLECTION
index 4d7b0d2..9eb3a6c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
+Extension [ <persistent> extension #106 swoole version 4.8.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
- - Constants [373] {
- Constant [ string SWOOLE_VERSION ] { 4.7.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 40701 }
+ - Constants [381] {
+ Constant [ string SWOOLE_VERSION ] { 4.8.0 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40800 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
- Constant [ int SWOOLE_MINOR_VERSION ] { 7 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -41,11 +41,6 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Constant [ bool SWOOLE_HAVE_BROTLI ] { 1 }
Constant [ bool SWOOLE_USE_HTTP2 ] { 1 }
Constant [ bool SWOOLE_USE_SHORTNAME ] { 1 }
- Constant [ int SWOOLE_BASE ] { 1 }
- Constant [ int SWOOLE_PROCESS ] { 2 }
- Constant [ int SWOOLE_IPC_UNSOCK ] { 1 }
- Constant [ int SWOOLE_IPC_MSGQUEUE ] { 2 }
- Constant [ int SWOOLE_IPC_PREEMPTIVE ] { 3 }
Constant [ int SWOOLE_SOCK_TCP ] { 1 }
Constant [ int SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ int SWOOLE_SOCK_UDP ] { 2 }
@@ -163,6 +158,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_OPCODE ] { 8502 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_UNCONNECTED ] { 8503 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_HANDSHAKE_FAILED ] { 8504 }
+ Constant [ int SWOOLE_ERROR_WEBSOCKET_PACK_FAILED ] { 8505 }
Constant [ int SWOOLE_ERROR_SERVER_MUST_CREATED_BEFORE_CLIENT ] { 9001 }
Constant [ int SWOOLE_ERROR_SERVER_TOO_MANY_SOCKET ] { 9002 }
Constant [ int SWOOLE_ERROR_SERVER_WORKER_TERMINATED ] { 9003 }
@@ -174,9 +170,10 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Constant [ int SWOOLE_ERROR_SERVER_SEND_IN_MASTER ] { 9009 }
Constant [ int SWOOLE_ERROR_SERVER_INVALID_REQUEST ] { 9010 }
Constant [ int SWOOLE_ERROR_SERVER_CONNECT_FAIL ] { 9011 }
- Constant [ int SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9012 }
- Constant [ int SWOOLE_ERROR_SERVER_WORKER_ABNORMAL_PIPE_DATA ] { 9013 }
- Constant [ int SWOOLE_ERROR_SERVER_WORKER_UNPROCESSED_DATA ] { 9014 }
+ Constant [ int SWOOLE_ERROR_SERVER_INVALID_COMMAND ] { 9012 }
+ Constant [ int SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9101 }
+ Constant [ int SWOOLE_ERROR_SERVER_WORKER_ABNORMAL_PIPE_DATA ] { 9102 }
+ Constant [ int SWOOLE_ERROR_SERVER_WORKER_UNPROCESSED_DATA ] { 9103 }
Constant [ int SWOOLE_ERROR_CO_OUT_OF_COROUTINE ] { 10001 }
Constant [ int SWOOLE_ERROR_CO_HAS_BEEN_BOUND ] { 10002 }
Constant [ int SWOOLE_ERROR_CO_HAS_BEEN_DISCARDED ] { 10003 }
@@ -248,9 +245,9 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Constant [ int SWOOLE_RWLOCK ] { 1 }
Constant [ int SWOOLE_SPINLOCK ] { 5 }
Constant [ int SWOOLE_TIMER_MIN_MS ] { 1 }
- Constant [ float SWOOLE_TIMER_MIN_SEC ] { 0.001 }
+ Constant [ float SWOOLE_TIMER_MIN_SEC ] { 0,001 }
Constant [ int SWOOLE_TIMER_MAX_MS ] { 9223372036854775807 }
- Constant [ float SWOOLE_TIMER_MAX_SEC ] { 9.2233720368548E+15 }
+ Constant [ float SWOOLE_TIMER_MAX_SEC ] { 9,2233720368548E+15 }
Constant [ int SWOOLE_DEFAULT_MAX_CORO_NUM ] { 100000 }
Constant [ int SWOOLE_CORO_MAX_NUM_LIMIT ] { 9223372036854775807 }
Constant [ int SWOOLE_CORO_INIT ] { 0 }
@@ -337,6 +334,17 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Constant [ int SWOOLE_HTTP2_ERROR_CONNECT_ERROR ] { 10 }
Constant [ int SWOOLE_HTTP2_ERROR_ENHANCE_YOUR_CALM ] { 11 }
Constant [ int SWOOLE_HTTP2_ERROR_INADEQUATE_SECURITY ] { 12 }
+ Constant [ int SWOOLE_BASE ] { 1 }
+ Constant [ int SWOOLE_PROCESS ] { 2 }
+ Constant [ int SWOOLE_IPC_UNSOCK ] { 1 }
+ Constant [ int SWOOLE_IPC_MSGQUEUE ] { 2 }
+ Constant [ int SWOOLE_IPC_PREEMPTIVE ] { 3 }
+ Constant [ int SWOOLE_SERVER_COMMAND_MASTER ] { 2 }
+ Constant [ int SWOOLE_SERVER_COMMAND_MANAGER ] { 32 }
+ Constant [ int SWOOLE_SERVER_COMMAND_REACTOR_THREAD ] { 4 }
+ Constant [ int SWOOLE_SERVER_COMMAND_EVENT_WORKER ] { 8 }
+ Constant [ int SWOOLE_SERVER_COMMAND_WORKER ] { 8 }
+ Constant [ int SWOOLE_SERVER_COMMAND_TASK_WORKER ] { 16 }
Constant [ int SWOOLE_DISPATCH_RESULT_DISCARD_PACKET ] { -1 }
Constant [ int SWOOLE_DISPATCH_RESULT_CLOSE_CONNECTION ] { -2 }
Constant [ int SWOOLE_DISPATCH_RESULT_USERFUNC_FALLBACK ] { -3 }
@@ -1490,7 +1498,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $memorySize ]
}
- - Methods [20] {
+ - Methods [21] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1600,6 +1608,12 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole> public method stats ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -1916,7 +1930,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
- Static properties [0] {
}
- - Static methods [37] {
+ - Static methods [39] {
Method [ <internal:swoole> static public method create ] {
- Parameters [2] {
@@ -1965,6 +1979,14 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole> static public method join ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $cid_array ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> static public method isCanceled ] {
- Parameters [0] {
@@ -2041,6 +2063,13 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole> static public method getStackUsage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $cid ]
+ }
+ }
+
Method [ <internal:swoole> static public method list ] {
- Parameters [0] {
@@ -4249,7 +4278,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $errMsg ]
}
- - Methods [165] {
+ - Methods [185] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -5553,6 +5582,186 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Parameter #1 [ <optional> $args ]
}
}
+
+ Method [ <internal:swoole> public method xLen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xAdd ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $id ]
+ Parameter #2 [ <required> $pairs ]
+ Parameter #3 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xRead ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $streams ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xDel ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $id ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xRange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $start ]
+ Parameter #2 [ <required> $end ]
+ Parameter #3 [ <optional> $count ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xRevRange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $start ]
+ Parameter #2 [ <required> $end ]
+ Parameter #3 [ <optional> $count ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xTrim ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xGroupCreate ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $id ]
+ Parameter #3 [ <optional> $mkstream ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xGroupSetId ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $id ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xGroupDestroy ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xGroupCreateConsumer ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $consumer_name ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xGroupDelConsumer ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $consumer_name ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xReadGroup ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $group_name ]
+ Parameter #1 [ <required> $consumer_name ]
+ Parameter #2 [ <required> $streams ]
+ Parameter #3 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xPending ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xAck ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $id ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xClaim ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $consumer_name ]
+ Parameter #3 [ <required> $min_idle_time ]
+ Parameter #4 [ <required> $id ]
+ Parameter #5 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xAutoClaim ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ Parameter #2 [ <required> $consumer_name ]
+ Parameter #3 [ <required> $min_idle_time ]
+ Parameter #4 [ <required> $start ]
+ Parameter #5 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xInfoConsumers ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $group_name ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xInfoGroups ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:swoole> public method xInfoStream ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
}
}
@@ -5792,8 +6001,9 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
- Static methods [0] {
}
- - Properties [26] {
+ - Properties [28] {
Property [ <default> private $onStart ]
+ Property [ <default> private $onBeforeShutdown ]
Property [ <default> private $onShutdown ]
Property [ <default> private $onWorkerStart ]
Property [ <default> private $onWorkerStop ]
@@ -5819,9 +6029,10 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
Property [ <default> public $stats_timer ]
+ Property [ <default> public $admin_server ]
}
- - Methods [47] {
+ - Methods [49] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -6069,7 +6280,8 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Method [ <internal:swoole> public method getWorkerPid ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $worker_id ]
}
}
@@ -6116,6 +6328,26 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole> public method command ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $process_id ]
+ Parameter #2 [ <required> $process_type ]
+ Parameter #3 [ <required> $data ]
+ Parameter #4 [ <optional> $json_encode ]
+ }
+ }
+
+ Method [ <internal:swoole> public method addCommand ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $accepted_process_types ]
+ Parameter #2 [ <required> callable $callback ]
+ }
+ }
+
Method [ <internal:swoole> public method addProcess ] {
- Parameters [1] {
@@ -6786,7 +7018,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
- Static methods [0] {
}
- - Properties [13] {
+ - Properties [14] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6800,9 +7032,10 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
Property [ <default> public $stats_timer ]
+ Property [ <default> public $admin_server ]
}
- - Methods [47] {
+ - Methods [49] {
Method [ <internal:swoole, inherits Swoole\Server, ctor> public method __construct ] {
- Parameters [4] {
@@ -7050,7 +7283,8 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Method [ <internal:swoole, inherits Swoole\Server> public method getWorkerPid ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $worker_id ]
}
}
@@ -7097,6 +7331,26 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method command ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $process_id ]
+ Parameter #2 [ <required> $process_type ]
+ Parameter #3 [ <required> $data ]
+ Parameter #4 [ <optional> $json_encode ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $accepted_process_types ]
+ Parameter #2 [ <required> callable $callback ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method addProcess ] {
- Parameters [1] {
@@ -7256,7 +7510,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
- - Properties [13] {
+ - Properties [14] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -7270,9 +7524,10 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
Property [ <default> public $stats_timer ]
+ Property [ <default> public $admin_server ]
}
- - Methods [50] {
+ - Methods [52] {
Method [ <internal:swoole> public method push ] {
- Parameters [4] {
@@ -7546,7 +7801,8 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Method [ <internal:swoole, inherits Swoole\Server> public method getWorkerPid ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $worker_id ]
}
}
@@ -7593,6 +7849,26 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method command ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $process_id ]
+ Parameter #2 [ <required> $process_type ]
+ Parameter #3 [ <required> $data ]
+ Parameter #4 [ <optional> $json_encode ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $accepted_process_types ]
+ Parameter #2 [ <required> callable $callback ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method addProcess ] {
- Parameters [1] {
@@ -7766,7 +8042,7 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
- - Properties [13] {
+ - Properties [14] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -7780,9 +8056,10 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
Property [ <default> public $stats_timer ]
+ Property [ <default> public $admin_server ]
}
- - Methods [49] {
+ - Methods [51] {
Method [ <internal:swoole> public method setHandler ] {
- Parameters [2] {
@@ -8045,7 +8322,8 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
Method [ <internal:swoole, inherits Swoole\Server> public method getWorkerPid ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $worker_id ]
}
}
@@ -8092,6 +8370,26 @@ Extension [ <persistent> extension #124 swoole version 4.7.1 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method command ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $process_id ]
+ Parameter #2 [ <required> $process_type ]
+ Parameter #3 [ <required> $data ]
+ Parameter #4 [ <optional> $json_encode ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $accepted_process_types ]
+ Parameter #2 [ <required> callable $callback ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method addProcess ] {
- Parameters [1] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 4eb8b39..45e1cd9 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -28,14 +28,14 @@
%bcond_with brotli
%endif
-%global upstream_version 4.7.1
+%global upstream_version 4.8.0
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
@@ -95,9 +95,6 @@ Conflicts: %{?sub_prefix}php-pecl-%{pecl_name}2 < 4
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -163,6 +160,9 @@ sed \
cd NTS
+cp -p thirdparty/hiredis/COPYING hiredis-COPYING
+cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -300,11 +300,10 @@ cd ../ZTS
%files
%{?_licensedir:%license NTS/LICENSE}
-%{?_licensedir:%license NTS/thirdparty/hiredis/COPYING}
-%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
+%{?_licensedir:%license NTS/*-COPYING}
%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
+%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/thirdparty/*/COPYING}
%doc %{pecl_docdir}/%{pecl_name}/*md
-%doc %{pecl_docdir}/%{pecl_name}/CREDITS
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -330,6 +329,9 @@ cd ../ZTS
%changelog
+* Fri Oct 15 2021 Remi Collet <remi@remirepo.net> - 4.8.0-1
+- update to 4.8.0
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 4.7.1-2
- rebuild for 8.1.0RC1