summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-19 12:12:59 +0100
committerRemi Collet <remi@remirepo.net>2018-11-19 12:12:59 +0100
commitea74626345809ce89433d563d3751ee1fe508bb8 (patch)
tree206b4b22c6298335da0f83fa55ed4745d49b1e2f
parent798c57118c8f1b3de9b76ea1d6ad908c00c84583 (diff)
v4.2.8
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-swoole4.spec6
3 files changed, 33 insertions, 13 deletions
diff --git a/PHPINFO b/PHPINFO
index fb75700..7b6b059 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.2.7
+Version => 4.2.8
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace_log => enabled
@@ -13,8 +13,8 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.0i-fips 14 Aug 2018
-http2 => 1.31.1
+openssl => OpenSSL 1.1.1 FIPS 11 Sep 2018
+http2 => 1.34.0
pcre => enabled
zlib => enabled
brotli => enabled
diff --git a/REFLECTION b/REFLECTION
index 2e5bb45..a2f16fb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
+Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -24,7 +24,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
}
}
- - Constants [222] {
+ - Constants [225] {
Constant [ integer SWOOLE_BASE ] { 1 }
Constant [ integer SWOOLE_PROCESS ] { 2 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
@@ -68,7 +68,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.2.7 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.8 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -221,6 +221,9 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
Constant [ integer WEBSOCKET_CLOSE_EXTENSION_MISSING ] { 1010 }
Constant [ integer WEBSOCKET_CLOSE_SERVER_ERROR ] { 1011 }
Constant [ integer WEBSOCKET_CLOSE_TLS ] { 1015 }
+ Constant [ integer SWOOLE_CHANNEL_OK ] { 0 }
+ Constant [ integer SWOOLE_CHANNEL_TIMEOUT ] { -1 }
+ Constant [ integer SWOOLE_CHANNEL_CLOSED ] { -2 }
Constant [ integer SWOOLE_HTTP2_TYPE_DATA ] { 0 }
Constant [ integer SWOOLE_HTTP2_TYPE_HEADERS ] { 1 }
Constant [ integer SWOOLE_HTTP2_TYPE_PRIORITY ] { 2 }
@@ -429,6 +432,12 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
Parameter #0 [ <required> $func ]
}
}
+ Function [ <internal:swoole> function defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
Function [ <internal:swoole> function swoole_client_select ] {
- Parameters [4] {
@@ -600,7 +609,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $reactor_id ]
+ Parameter #2 [ <optional> $server_socket ]
}
}
@@ -3052,7 +3061,8 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [1] {
+ Property [ <default> public $error ]
}
- Methods [12] {
@@ -3173,7 +3183,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
Property [ <default> public $errno ]
}
- - Methods [13] {
+ - Methods [14] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -3207,6 +3217,12 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
}
}
+ Method [ <internal:swoole> public method nextResult ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method escape ] {
- Parameters [2] {
@@ -4836,7 +4852,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $reactor_id ]
+ Parameter #2 [ <optional> $server_socket ]
}
}
@@ -5508,7 +5524,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $reactor_id ]
+ Parameter #2 [ <optional> $server_socket ]
}
}
@@ -6770,7 +6786,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.7 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $reactor_id ]
+ Parameter #2 [ <optional> $server_socket ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 72db5d7..868559f 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.7
+Version: 4.2.8
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -330,6 +330,7 @@ cd ../ZTS
%files devel
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
+%doc %{pecl_docdir}/%{pecl_name}/gdbinit
%doc %{pecl_docdir}/%{pecl_name}/include
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/travis
@@ -341,6 +342,9 @@ cd ../ZTS
%changelog
+* Mon Nov 19 2018 Remi Collet <remi@remirepo.net> - 4.2.8-1
+- update to 4.2.8
+
* Sat Nov 10 2018 Remi Collet <remi@remirepo.net> - 4.2.7-1
- update to 4.2.7