summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-30 08:34:32 +0200
committerRemi Collet <remi@remirepo.net>2020-08-30 08:34:32 +0200
commitd30ece76963f348e2158f4083e99ee75f6a70190 (patch)
tree4db7969f7046cf0024590094cfef3b5645760b24
parent235feb810407d942a446f78fd21acee3e055a764 (diff)
update to 4.5.3
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-swoole4.spec19
3 files changed, 26 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 6b759a8..b438cad 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.2
-Built => May 28 2020 00:00:00
+Version => 4.5.3
+Built => Aug 30 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 9fd1e88..ca6ad45 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
+Extension [ <persistent> extension #116 swoole version 4.5.3 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
}
}
- - Constants [336] {
- Constant [ string SWOOLE_VERSION ] { 4.5.2 }
- Constant [ int SWOOLE_VERSION_ID ] { 40502 }
+ - Constants [337] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.3 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40503 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 3 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -91,6 +91,7 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
Constant [ int SWOOLE_ERROR_QUEUE_FULL ] { 506 }
Constant [ int SWOOLE_ERROR_OPERATION_NOT_SUPPORT ] { 507 }
Constant [ int SWOOLE_ERROR_PROTOCOL_ERROR ] { 508 }
+ Constant [ int SWOOLE_ERROR_WRONG_OPERATION ] { 509 }
Constant [ int SWOOLE_ERROR_FILE_NOT_EXIST ] { 700 }
Constant [ int SWOOLE_ERROR_FILE_TOO_LARGE ] { 701 }
Constant [ int SWOOLE_ERROR_FILE_EMPTY ] { 702 }
@@ -493,6 +494,11 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
Parameter #0 [ <required> $filename ]
}
}
+ Function [ <internal:swoole> function swoole_mime_type_list ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:swoole> function swoole_clear_dns_cache ] {
- Parameters [0] {
@@ -1351,8 +1357,8 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
- Constants [3] {
Constant [ public int TYPE_INT ] { 1 }
- Constant [ public int TYPE_STRING ] { 7 }
- Constant [ public int TYPE_FLOAT ] { 6 }
+ Constant [ public int TYPE_STRING ] { 3 }
+ Constant [ public int TYPE_FLOAT ] { 2 }
}
- Static properties [0] {
@@ -6318,7 +6324,7 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
- Static methods [0] {
}
- - Properties [13] {
+ - Properties [12] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6331,7 +6337,6 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> private $onRequest ]
}
- Methods [47] {
@@ -6788,7 +6793,7 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
}
}
- - Properties [13] {
+ - Properties [12] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6801,7 +6806,6 @@ Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> private $onHandshake ]
}
- Methods [50] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 33661c6..96922f0 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,14 +27,14 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.2
+%global upstream_version 4.5.3
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
@@ -88,18 +88,15 @@ Conflicts: %{?sub_prefix}php-pecl-%{pecl_name} < 4
Conflicts: %{?sub_prefix}php-pecl-%{pecl_name}2 < 4
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name}4 <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name}4 <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name}4 <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -321,7 +318,6 @@ cd ../ZTS
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
%doc %{pecl_docdir}/%{pecl_name}/gdbinit
-%doc %{pecl_docdir}/%{pecl_name}/include
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/travis
%{php_incldir}/ext/%{pecl_name}
@@ -332,6 +328,9 @@ cd ../ZTS
%changelog
+* Sun Aug 30 2020 Remi Collet <remi@remirepo.net> - 4.5.3-1
+- update to 4.5.3
+
* Thu May 28 2020 Remi Collet <remi@remirepo.net> - 4.5.2-1
- update to 4.5.2