summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-28 14:22:14 +0200
committerRemi Collet <remi@remirepo.net>2020-05-28 14:22:14 +0200
commit235feb810407d942a446f78fd21acee3e055a764 (patch)
treea5a6de1c30854513784eac567f349ec81548b5a5
parent90f12cfda1810274f23d37c8ea6e6a52224a1a20 (diff)
v4.5.2
-rw-r--r--707a7ce38f97a782d0fc7fdbc033c16b146b9809.patch38
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION142
-rw-r--r--php-pecl-swoole4.spec12
4 files changed, 82 insertions, 116 deletions
diff --git a/707a7ce38f97a782d0fc7fdbc033c16b146b9809.patch b/707a7ce38f97a782d0fc7fdbc033c16b146b9809.patch
deleted file mode 100644
index 4297164..0000000
--- a/707a7ce38f97a782d0fc7fdbc033c16b146b9809.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 707a7ce38f97a782d0fc7fdbc033c16b146b9809 Mon Sep 17 00:00:00 2001
-From: twosee <twose@qq.com>
-Date: Mon, 27 Apr 2020 17:01:05 +0800
-Subject: [PATCH] Fix 32-bit build (#3276) (#3277)
-
----
- include/swoole.h | 4 ++++
- swoole_table.cc | 2 +-
- 2 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/include/swoole.h b/include/swoole.h
-index e6facb100..2dcef076e 100644
---- a/include/swoole.h
-+++ b/include/swoole.h
-@@ -104,6 +104,10 @@ int clock_gettime(clock_id_t which_clock, struct timespec *t);
- #endif
- typedef unsigned long ulong_t;
-
-+#ifndef PRId64
-+#define PRId64 "lld"
-+#endif
-+
- #ifndef PRIu64
- #define PRIu64 "llu"
- #endif
-diff --git a/swoole_table.cc b/swoole_table.cc
-index c3b055b35..d07818ee5 100644
---- a/swoole_table.cc
-+++ b/swoole_table.cc
-@@ -393,7 +393,7 @@ PHP_METHOD(swoole_table, __construct)
- zend_throw_exception(swoole_exception_ce, "global memory allocation failure", SW_ERROR_MALLOC_FAIL);
- RETURN_FALSE;
- }
-- table->hash_func = [](const char *key, size_t len) {
-+ table->hash_func = [](const char *key, size_t len) -> uint64_t {
- zend_string *string = (zend_string *) (key - offsetof(zend_string, val));
- return zend_string_hash_val(string);
- };
diff --git a/PHPINFO b/PHPINFO
index f1d6af5..6b759a8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.0
-Built => Apr 27 2020 00:00:00
+Version => 4.5.2
+Built => May 28 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1d FIPS 10 Sep 2019
+openssl => OpenSSL 1.1.1g FIPS 21 Apr 2020
http2 => enabled
pcre => enabled
zlib => 1.2.11
diff --git a/REFLECTION b/REFLECTION
index a4b6ead..9fd1e88 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
+Extension [ <persistent> extension #114 swoole version 4.5.2 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
- - Constants [334] {
- Constant [ string SWOOLE_VERSION ] { 4.5.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 40500 }
+ - Constants [336] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.2 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40502 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -199,6 +199,8 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
Constant [ int SWOOLE_LOG_WARNING ] { 4 }
Constant [ int SWOOLE_LOG_ERROR ] { 5 }
Constant [ int SWOOLE_LOG_NONE ] { 6 }
+ Constant [ int SWOOLE_LOG_ROTATION_SINGLE ] { 0 }
+ Constant [ int SWOOLE_LOG_ROTATION_DAILY ] { 1 }
Constant [ int SWOOLE_IPC_NONE ] { 0 }
Constant [ int SWOOLE_IPC_UNIXSOCK ] { 1 }
Constant [ int SWOOLE_IPC_SOCKET ] { 3 }
@@ -1992,27 +1994,22 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
- Method [ <internal:swoole> static public method fread ] {
+ Method [ <internal:swoole> static public method getaddrinfo ] {
- - Parameters [2] {
- Parameter #0 [ <required> $handle ]
- Parameter #1 [ <optional> $length ]
+ - Parameters [6] {
+ Parameter #0 [ <required> $hostname ]
+ Parameter #1 [ <optional> $family ]
+ Parameter #2 [ <optional> $socktype ]
+ Parameter #3 [ <optional> $protocol ]
+ Parameter #4 [ <optional> $service ]
+ Parameter #5 [ <optional> $timeout ]
}
}
- Method [ <internal:swoole> static public method fgets ] {
+ Method [ <internal:swoole> static public method statvfs ] {
- Parameters [1] {
- Parameter #0 [ <required> $handle ]
- }
- }
-
- Method [ <internal:swoole> static public method fwrite ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $handle ]
- Parameter #1 [ <required> $string ]
- Parameter #2 [ <optional> $length ]
+ Parameter #0 [ <required> $path ]
}
}
@@ -2032,25 +2029,6 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
- Method [ <internal:swoole> static public method getaddrinfo ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> $hostname ]
- Parameter #1 [ <optional> $family ]
- Parameter #2 [ <optional> $socktype ]
- Parameter #3 [ <optional> $protocol ]
- Parameter #4 [ <optional> $service ]
- Parameter #5 [ <optional> $timeout ]
- }
- }
-
- Method [ <internal:swoole> static public method statvfs ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $path ]
- }
- }
-
Method [ <internal:swoole> static public method wait ] {
- Parameters [1] {
@@ -2082,6 +2060,30 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
Parameter #2 [ <optional> $timeout ]
}
}
+
+ Method [ <internal, deprecated:swoole> static public method fread ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <optional> $length ]
+ }
+ }
+
+ Method [ <internal, deprecated:swoole> static public method fgets ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $handle ]
+ }
+ }
+
+ Method [ <internal, deprecated:swoole> static public method fwrite ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <optional> $length ]
+ }
+ }
}
- Properties [0] {
@@ -2545,30 +2547,6 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
- Method [ <internal:swoole> static public method fread ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $handle ]
- Parameter #1 [ <optional> $length ]
- }
- }
-
- Method [ <internal:swoole> static public method fwrite ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $handle ]
- Parameter #1 [ <required> $string ]
- Parameter #2 [ <optional> $length ]
- }
- }
-
- Method [ <internal:swoole> static public method fgets ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $handle ]
- }
- }
-
Method [ <internal:swoole> static public method getaddrinfo ] {
- Parameters [6] {
@@ -2581,6 +2559,13 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
+ Method [ <internal:swoole> static public method statvfs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $path ]
+ }
+ }
+
Method [ <internal:swoole> static public method readFile ] {
- Parameters [1] {
@@ -2597,13 +2582,6 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
}
}
- Method [ <internal:swoole> static public method statvfs ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $path ]
- }
- }
-
Method [ <internal:swoole> static public method wait ] {
- Parameters [1] {
@@ -2635,6 +2613,30 @@ Extension [ <persistent> extension #113 swoole version 4.5.0 ] {
Parameter #2 [ <optional> $timeout ]
}
}
+
+ Method [ <internal, deprecated:swoole> static public method fread ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <optional> $length ]
+ }
+ }
+
+ Method [ <internal, deprecated:swoole> static public method fwrite ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <optional> $length ]
+ }
+ }
+
+ Method [ <internal, deprecated:swoole> static public method fgets ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $handle ]
+ }
+ }
}
- Properties [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index fab73b3..33661c6 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.0
+%global upstream_version 4.5.2
#global upstream_prever RC2
@@ -41,8 +41,6 @@ License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/707a7ce38f97a782d0fc7fdbc033c16b146b9809.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -165,8 +163,6 @@ sed \
cd NTS
-%patch0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -336,6 +332,12 @@ cd ../ZTS
%changelog
+* Thu May 28 2020 Remi Collet <remi@remirepo.net> - 4.5.2-1
+- update to 4.5.2
+
+* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 4.5.1-1
+- update to 4.5.1
+
* Mon Apr 27 2020 Remi Collet <remi@remirepo.net> - 4.5.0-2
- add upstream patch to fix 32-bit and old GCC builds