summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-05 16:17:32 +0100
committerRemi Collet <remi@remirepo.net>2018-11-05 16:17:32 +0100
commit908b5a0ac15276dff258c4082466e2247060242e (patch)
treef58bd6b38d134d8b73d4c460967b7f3d954aa439
parent5de52fc54affe047ac1541b11cf83f61af0c5143 (diff)
v4.2.6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION54
-rw-r--r--php-pecl-swoole4.spec30
3 files changed, 68 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 2244b16..e8eb037 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.2.5
+Version => 4.2.6
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace_log => enabled
diff --git a/REFLECTION b/REFLECTION
index 04df7ae..721c79a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
+Extension [ <persistent> extension #149 swoole version 4.2.6 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -24,7 +24,7 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
}
}
- - Constants [202] {
+ - Constants [221] {
Constant [ integer SWOOLE_BASE ] { 1 }
Constant [ integer SWOOLE_PROCESS ] { 2 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
@@ -68,17 +68,19 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.2.5 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.6 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
Constant [ integer SWOOLE_ERROR_NAME_TOO_LONG ] { 504 }
Constant [ integer SWOOLE_ERROR_INVALID_PARAMS ] { 505 }
+ Constant [ integer SWOOLE_ERROR_QUEUE_FULL ] { 506 }
Constant [ integer SWOOLE_ERROR_FILE_NOT_EXIST ] { 700 }
Constant [ integer SWOOLE_ERROR_FILE_TOO_LARGE ] { 701 }
Constant [ integer SWOOLE_ERROR_FILE_EMPTY ] { 702 }
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_DUPLICATE_REQUEST ] { 703 }
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_RESOLVE_FAILED ] { 704 }
+ Constant [ integer SWOOLE_ERROR_BAD_IPV6_ADDRESS ] { 705 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_SERVER ] { 1001 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_CLIENT ] { 1002 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSING ] { 1003 }
@@ -97,10 +99,11 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
Constant [ integer SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1202 }
Constant [ integer SWOOLE_ERROR_TASK_PACKAGE_TOO_BIG ] { 2001 }
Constant [ integer SWOOLE_ERROR_TASK_DISPATCH_FAIL ] { 2002 }
- Constant [ integer SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
- Constant [ integer SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_ID_TOO_BIG ] { 3001 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
+ Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
+ Constant [ integer SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
+ Constant [ integer SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_METHOD ] { 7002 }
Constant [ integer SWOOLE_ERROR_SOCKS5_AUTH_FAILED ] { 7003 }
@@ -119,7 +122,21 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
Constant [ integer SWOOLE_ERROR_SERVER_PIPE_BUFFER_FULL ] { 9006 }
Constant [ integer SWOOLE_ERROR_SERVER_NO_IDLE_WORKER ] { 9007 }
Constant [ integer SWOOLE_ERROR_SERVER_ONLY_START_ONE ] { 9008 }
+ Constant [ integer SWOOLE_ERROR_SERVER_SEND_IN_MASTER ] { 9009 }
Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9010 }
+ Constant [ integer SWOOLE_ERROR_CO_OUT_OF_COROUTINE ] { 10001 }
+ Constant [ integer SWOOLE_ERROR_CO_HAS_BEEN_BOUND ] { 10002 }
+ Constant [ integer SWOOLE_ERROR_CO_MUTEX_DOUBLE_UNLOCK ] { 10003 }
+ Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_LOCKED ] { 10004 }
+ Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_WAITING ] { 10005 }
+ Constant [ integer SWOOLE_ERROR_CO_YIELD_FAILED ] { 10006 }
+ Constant [ integer SWOOLE_ERROR_CO_GETCONTEXT_FAILED ] { 10007 }
+ Constant [ integer SWOOLE_ERROR_CO_SWAPCONTEXT_FAILED ] { 10008 }
+ Constant [ integer SWOOLE_ERROR_CO_MAKECONTEXT_FAILED ] { 10009 }
+ Constant [ integer SWOOLE_ERROR_CO_IOCPINIT_FAILED ] { 10010 }
+ Constant [ integer SWOOLE_ERROR_CO_PROTECT_STACK_FAILED ] { 10011 }
+ Constant [ integer SWOOLE_ERROR_CO_STD_THREAD_LINK_ERROR ] { 10012 }
+ Constant [ integer SWOOLE_ERROR_CO_DISABLED_MULTI_THREAD ] { 10013 }
Constant [ integer SWOOLE_TRACE_SERVER ] { 2 }
Constant [ integer SWOOLE_TRACE_CLIENT ] { 4 }
Constant [ integer SWOOLE_TRACE_BUFFER ] { 8 }
@@ -137,6 +154,8 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
Constant [ integer SWOOLE_TRACE_REDIS_CLIENT ] { 65536 }
Constant [ integer SWOOLE_TRACE_MYSQL_CLIENT ] { 131072 }
Constant [ integer SWOOLE_TRACE_AIO ] { 262144 }
+ Constant [ integer SWOOLE_TRACE_SSL ] { 524288 }
+ Constant [ integer SWOOLE_TRACE_NORMAL ] { 1048576 }
Constant [ integer SWOOLE_TRACE_ALL ] { 4294967295 }
Constant [ integer SWOOLE_LOG_DEBUG ] { 0 }
Constant [ integer SWOOLE_LOG_TRACE ] { 1 }
@@ -1795,7 +1814,7 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
Property [ <default> public $errMsg ]
}
- - Methods [152] {
+ - Methods [155] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -2223,6 +2242,29 @@ Extension [ <persistent> extension #148 swoole version 4.2.5 ] {
}
}
+ Method [ <internal:swoole> public method pfadd ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $elements ]
+ }
+ }
+
+ Method [ <internal:swoole> public method pfcount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:swoole> public method pfmerge ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $dstkey ]
+ Parameter #1 [ <required> $keys ]
+ }
+ }
+
Method [ <internal:swoole> public method ping ] {
- Parameters [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 47c4814..e934c89 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -26,7 +26,6 @@
%global with_pgsql 0
%endif
%global with_nghttpd2 1
-%global with_hiredis 1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
%global with_brotli 1
%else
@@ -36,9 +35,11 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.5
+Version: 4.2.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+# Extension is ASL 2.0
+# Hiredis is BSD
+License: ASL 2.0 and BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -64,9 +65,6 @@ BuildRequires: libpq-devel > 9.5
BuildRequires: postgresql-devel > 9.5
%endif
%endif
-%if %{with_hiredis}
-BuildRequires: hiredis-devel
-%endif
%if %{with_brotli}
BuildRequires: brotli-devel
%endif
@@ -162,9 +160,13 @@ These are the files needed to compile programs using %{name}.
%setup -q -c
mv %{pecl_name}-%{version} NTS
-# Don't install/register tests, install examples as doc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+# Don't install/register tests, install examples as doc
+sed \
+ -e '/Makefile/s/role="doc"/role="src"/' \
+ %{?_licensedir: -e '/LICENSE/s/role="doc"/role="src"/' } \
+ %{?_licensedir: -e '/COPYING/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -209,9 +211,6 @@ peclbuild() {
--with-swoole \
--enable-sockets \
--enable-trace-log \
-%if %{with_hiredis}
- --enable-async-redis \
-%endif
--enable-openssl \
%if %{with_nghttpd2}
--enable-http2 \
@@ -312,6 +311,8 @@ cd ../ZTS
%files
%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license NTS/thirdparty/hiredis/COPYING}
+%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}/*md
%doc %{pecl_docdir}/%{pecl_name}/CREDITS
@@ -330,6 +331,7 @@ cd ../ZTS
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
%doc %{pecl_docdir}/%{pecl_name}/include/readme
+%doc %{pecl_docdir}/%{pecl_name}/thirdparty/hiredis
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -338,6 +340,12 @@ cd ../ZTS
%changelog
+* Mon Nov 5 2018 Remi Collet <remi@remirepo.net> - 4.2.6-1
+- update to 4.2.6
+- use hiredis bundled library
+- open https://github.com/swoole/swoole-src/issues/2089 borken with PHP 7.3
+- open https://github.com/php/php-src/pull/3652 fix for C++
+
* Sun Oct 28 2018 Remi Collet <remi@remirepo.net> - 4.2.5-1
- update to 4.2.5