summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 47c4814..e934c89 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -26,7 +26,6 @@
%global with_pgsql 0
%endif
%global with_nghttpd2 1
-%global with_hiredis 1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
%global with_brotli 1
%else
@@ -36,9 +35,11 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.5
+Version: 4.2.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+# Extension is ASL 2.0
+# Hiredis is BSD
+License: ASL 2.0 and BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -64,9 +65,6 @@ BuildRequires: libpq-devel > 9.5
BuildRequires: postgresql-devel > 9.5
%endif
%endif
-%if %{with_hiredis}
-BuildRequires: hiredis-devel
-%endif
%if %{with_brotli}
BuildRequires: brotli-devel
%endif
@@ -162,9 +160,13 @@ These are the files needed to compile programs using %{name}.
%setup -q -c
mv %{pecl_name}-%{version} NTS
-# Don't install/register tests, install examples as doc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+# Don't install/register tests, install examples as doc
+sed \
+ -e '/Makefile/s/role="doc"/role="src"/' \
+ %{?_licensedir: -e '/LICENSE/s/role="doc"/role="src"/' } \
+ %{?_licensedir: -e '/COPYING/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -209,9 +211,6 @@ peclbuild() {
--with-swoole \
--enable-sockets \
--enable-trace-log \
-%if %{with_hiredis}
- --enable-async-redis \
-%endif
--enable-openssl \
%if %{with_nghttpd2}
--enable-http2 \
@@ -312,6 +311,8 @@ cd ../ZTS
%files
%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license NTS/thirdparty/hiredis/COPYING}
+%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
%{!?_licensedir:%{pecl_docdir}/%{pecl_name}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}/*md
%doc %{pecl_docdir}/%{pecl_name}/CREDITS
@@ -330,6 +331,7 @@ cd ../ZTS
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
%doc %{pecl_docdir}/%{pecl_name}/include/readme
+%doc %{pecl_docdir}/%{pecl_name}/thirdparty/hiredis
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -338,6 +340,12 @@ cd ../ZTS
%changelog
+* Mon Nov 5 2018 Remi Collet <remi@remirepo.net> - 4.2.6-1
+- update to 4.2.6
+- use hiredis bundled library
+- open https://github.com/swoole/swoole-src/issues/2089 borken with PHP 7.3
+- open https://github.com/php/php-src/pull/3652 fix for C++
+
* Sun Oct 28 2018 Remi Collet <remi@remirepo.net> - 4.2.5-1
- update to 4.2.5