summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-06 08:24:32 +0100
committerRemi Collet <remi@remirepo.net>2019-01-06 08:24:32 +0100
commit8b9dea12f10e1437835b59c0b76332833ce5451c (patch)
tree11cda6d124b3ba9c9cbec24ba3190e4422205f42
parent2461185588291077fef81f6a81868a0f21f40574 (diff)
update to 4.2.12
use --enable-cares build option swoole.aio_thread_num configuration option removed
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION80
-rw-r--r--php-pecl-swoole4.spec11
3 files changed, 76 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 4d16042..5d42aad 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,9 +1,10 @@
swoole
-swoole support => enabled
-Version => 4.2.11
-Author => Swoole Group[email: team@swoole.com]
+Swoole => enabled
+Author => Swoole Team <team@swoole.com>
+Version => 4.2.12
+Built => Jan 6 2019 08:07:24
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -27,7 +28,6 @@ coroutine_postgresql => enabled
Directive => Local Value => Master Value
swoole.enable_coroutine => On => On
-swoole.aio_thread_num => 2 => 2
swoole.display_errors => On => On
swoole.use_shortname => On => On
swoole.fast_serialize => Off => Off
diff --git a/REFLECTION b/REFLECTION
index e6957bd..45236db 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,12 +1,9 @@
-Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
+Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
Current = 'On'
}
- Entry [ swoole.aio_thread_num <ALL> ]
- Current = '2'
- }
Entry [ swoole.display_errors <ALL> ]
Current = 'On'
}
@@ -22,11 +19,11 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
}
- Constants [253] {
- Constant [ string SWOOLE_VERSION ] { 4.2.11 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40211 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.12 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40212 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 2 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 11 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 12 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -83,8 +80,9 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Constant [ integer SWOOLE_ERROR_FILE_EMPTY ] { 702 }
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_DUPLICATE_REQUEST ] { 703 }
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_RESOLVE_FAILED ] { 704 }
- Constant [ integer SWOOLE_ERROR_BAD_IPV6_ADDRESS ] { 705 }
- Constant [ integer SWOOLE_ERROR_UNREGISTERED_SIGNAL ] { 706 }
+ Constant [ integer SWOOLE_ERROR_DNSLOOKUP_RESOLVE_TIMEOUT ] { 705 }
+ Constant [ integer SWOOLE_ERROR_BAD_IPV6_ADDRESS ] { 706 }
+ Constant [ integer SWOOLE_ERROR_UNREGISTERED_SIGNAL ] { 707 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_SERVER ] { 1001 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_CLIENT ] { 1002 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSING ] { 1003 }
@@ -107,6 +105,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
Constant [ integer SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
+ Constant [ integer SWOOLE_ERROR_AIO_CANCELED ] { 4002 }
Constant [ integer SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
Constant [ integer SWOOLE_ERROR_SOCKET_CLOSED ] { 5002 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
@@ -206,8 +205,6 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Constant [ integer SWOOLE_CORO_END ] { 3 }
Constant [ integer SWOOLE_EXIT_IN_COROUTINE ] { 2 }
Constant [ integer SWOOLE_EXIT_IN_SERVER ] { 4 }
- Constant [ integer SWOOLE_AIO_BASE ] { 0 }
- Constant [ integer SWOOLE_AIO_LINUX ] { 0 }
Constant [ integer SWOOLE_HOOK_FILE ] { 2 }
Constant [ integer SWOOLE_HOOK_SLEEP ] { 4 }
Constant [ integer SWOOLE_HOOK_TCP ] { 8 }
@@ -541,7 +538,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
}
}
- - Classes [51] {
+ - Classes [52] {
Class [ <internal:swoole> class Swoole\Timer ] {
- Constants [0] {
@@ -1166,6 +1163,34 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
}
}
+ Class [ <internal:swoole> final class Swoole\Server\Task ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $data ]
+ Property [ <default> public $id ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $flags ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:swoole> public method finish ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> <iterateable> class Swoole\Connection\Iterator implements Iterator, Traversable, ArrayAccess, Countable ] {
- Constants [0] {
@@ -1865,7 +1890,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Property [ <default> public $errMsg ]
}
- - Methods [156] {
+ - Methods [157] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1888,6 +1913,12 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
}
}
+ Method [ <internal:swoole> public method getOptions ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method setOptions ] {
- Parameters [1] {
@@ -3111,7 +3142,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Property [ <default> public $error ]
}
- - Methods [12] {
+ - Methods [14] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -3132,6 +3163,22 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
}
}
+ Method [ <internal:swoole> public method prepare ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $stmtname ]
+ Parameter #1 [ <required> $query ]
+ }
+ }
+
+ Method [ <internal:swoole> public method execute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $stmtname ]
+ Parameter #1 [ <required> $pv_param_arr ]
+ }
+ }
+
Method [ <internal:swoole> public method fetchAll ] {
- Parameters [2] {
@@ -3643,9 +3690,10 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
Method [ <internal:swoole> static public method gethostbyname ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $domain_name ]
Parameter #1 [ <optional> $family ]
+ Parameter #2 [ <optional> $timeout ]
}
}
@@ -6496,7 +6544,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
- Parameter #1 [ <optional> $args ]
+ Parameter #1 [ <optional> $flag ]
}
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 13faaa0..bc46fe8 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.11
+Version: 4.2.12
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -191,7 +191,6 @@ extension=%{pecl_name}.so
; Configuration
;swoole.enable_coroutine = On
-;swoole.aio_thread_num = 2
;swoole.display_errors = On
:swoole.use_shortname = On
;swoole.fast_serialize = Off
@@ -218,6 +217,7 @@ peclbuild() {
%if %{with_pgsql}
--enable-coroutine-postgresql \
%endif
+ --enable-cares \
--enable-thread \
--enable-mysqlnd \
--with-libdir=%{_lib} \
@@ -342,6 +342,11 @@ cd ../ZTS
%changelog
+* Sun Jan 6 2019 Remi Collet <remi@remirepo.net> - 4.2.12-1
+- update to 4.2.12
+- use --enable-cares build option
+- swoole.aio_thread_num configuration option removed
+
* Fri Dec 28 2018 Remi Collet <remi@remirepo.net> - 4.2.11-1
- update to 4.2.11