summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-28 12:12:06 +0100
committerRemi Collet <remi@remirepo.net>2018-12-28 12:12:06 +0100
commit2461185588291077fef81f6a81868a0f21f40574 (patch)
tree6780672bee8b1a8d6e3c999242b913d7c843bacb
parentbf95996dca9b743092547ef1424769529b03705c (diff)
v4.2.11
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION559
-rw-r--r--php-pecl-swoole4.spec6
3 files changed, 291 insertions, 276 deletions
diff --git a/PHPINFO b/PHPINFO
index 94c7d43..4d16042 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.2.10
+Version => 4.2.11
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace_log => enabled
diff --git a/REFLECTION b/REFLECTION
index 184664b..e6957bd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
+Extension [ <persistent> extension #149 swoole version 4.2.11 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,7 +21,14 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
}
}
- - Constants [247] {
+ - Constants [253] {
+ Constant [ string SWOOLE_VERSION ] { 4.2.11 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40211 }
+ Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
+ Constant [ integer SWOOLE_MINOR_VERSION ] { 2 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 11 }
+ Constant [ string SWOOLE_EXTRA_VERSION ] { }
+ Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
Constant [ integer SWOOLE_PROCESS ] { 2 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
@@ -65,7 +72,6 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.2.10 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -528,9 +534,284 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_clear_dns_cache ] {
+
+ - Parameters [0] {
+ }
+ }
}
- Classes [51] {
+ Class [ <internal:swoole> class Swoole\Timer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:swoole> static public method tick ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method after ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method clear ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Event ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [8] {
+ Method [ <internal:swoole> static public method add ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $read_callback ]
+ Parameter #2 [ <optional> $write_callback ]
+ Parameter #3 [ <optional> $events ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method del ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method set ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <optional> $read_callback ]
+ Parameter #2 [ <optional> $write_callback ]
+ Parameter #3 [ <optional> $events ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method exit ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> static public method write ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method wait ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> static public method defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method cycle ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <optional> $before ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Async ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [8] {
+ Method [ <internal:swoole> static public method read ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $chunk_size ]
+ Parameter #3 [ <optional> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method write ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $offset ]
+ Parameter #3 [ <optional> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method readFile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method writeFile ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $callback ]
+ Parameter #3 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method dnsLookup ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $hostname ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method dnsLookupCoro ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $settings ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method exec ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $command ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Exception extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Server ] {
- Constants [0] {
@@ -885,219 +1166,6 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
}
}
- Class [ <internal:swoole> class Swoole\Timer ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [4] {
- Method [ <internal:swoole> static public method tick ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ms ]
- Parameter #1 [ <required> $callback ]
- }
- }
-
- Method [ <internal:swoole> static public method after ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $ms ]
- Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $param ]
- }
- }
-
- Method [ <internal:swoole> static public method exists ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $timer_id ]
- }
- }
-
- Method [ <internal:swoole> static public method clear ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $timer_id ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
- Class [ <internal:swoole> class Swoole\Event ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [8] {
- Method [ <internal:swoole> static public method add ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $read_callback ]
- Parameter #2 [ <optional> $write_callback ]
- Parameter #3 [ <optional> $events ]
- }
- }
-
- Method [ <internal:swoole> static public method del ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $fd ]
- }
- }
-
- Method [ <internal:swoole> static public method set ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <optional> $read_callback ]
- Parameter #2 [ <optional> $write_callback ]
- Parameter #3 [ <optional> $events ]
- }
- }
-
- Method [ <internal:swoole> static public method exit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> static public method write ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $data ]
- }
- }
-
- Method [ <internal:swoole> static public method wait ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> static public method defer ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $callback ]
- }
- }
-
- Method [ <internal:swoole> static public method cycle ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> $before ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
- Class [ <internal:swoole> class Swoole\Async ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [8] {
- Method [ <internal:swoole> static public method read ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $chunk_size ]
- Parameter #3 [ <optional> $offset ]
- }
- }
-
- Method [ <internal:swoole> static public method write ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $content ]
- Parameter #2 [ <optional> $offset ]
- Parameter #3 [ <optional> $callback ]
- }
- }
-
- Method [ <internal:swoole> static public method readFile ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $callback ]
- }
- }
-
- Method [ <internal:swoole> static public method writeFile ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $content ]
- Parameter #2 [ <optional> $callback ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:swoole> static public method dnsLookup ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $hostname ]
- Parameter #1 [ <required> $callback ]
- }
- }
-
- Method [ <internal:swoole> static public method dnsLookupCoro ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $domain_name ]
- Parameter #1 [ <optional> $timeout ]
- }
- }
-
- Method [ <internal:swoole> static public method set ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $settings ]
- }
- }
-
- Method [ <internal:swoole> static public method exec ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $command ]
- Parameter #1 [ <required> $callback ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
Class [ <internal:swoole> <iterateable> class Swoole\Connection\Iterator implements Iterator, Traversable, ArrayAccess, Countable ] {
- Constants [0] {
@@ -1186,63 +1254,6 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
}
}
- Class [ <internal:swoole> class Swoole\Exception extends Exception implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
Class [ <internal:swoole> class Swoole\Server\Port ] {
- Constants [0] {
@@ -1529,7 +1540,7 @@ Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
- Parameters [3] {
Parameter #0 [ <required> $domain ]
Parameter #1 [ <required> $type ]
- Parameter #2 [ <required> $protocol ]
+ Parameter #2 [ <optional> $protocol ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 0249ad6..13faaa0 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.10
+Version: 4.2.11
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -68,6 +68,7 @@ BuildRequires: postgresql-devel > 9.5
%if %{with_brotli}
BuildRequires: brotli-devel
%endif
+BuildRequires: c-ares-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -341,6 +342,9 @@ cd ../ZTS
%changelog
+* Fri Dec 28 2018 Remi Collet <remi@remirepo.net> - 4.2.11-1
+- update to 4.2.11
+
* Thu Dec 20 2018 Remi Collet <remi@remirepo.net> - 4.2.10-1
- update to 4.2.10