summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-06 07:50:28 +0100
committerRemi Collet <remi@remirepo.net>2021-01-06 07:50:28 +0100
commit708a590ec6e8b1d55cde315a5bbc64c22754e2be (patch)
tree4702531475191b212fbbd799ac7d894b4b88e628
parente153a1fc4b44864781ae529838fbfcc79833f601 (diff)
update to 4.6.0
enable curl support raise dependency on PHP 7.2
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION302
-rw-r--r--php-pecl-swoole4.spec16
3 files changed, 296 insertions, 28 deletions
diff --git a/PHPINFO b/PHPINFO
index a229e42..66fc51b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.10
-Built => Dec 23 2020 00:00:00
+Version => 4.6.0
+Built => Jan 6 2021 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -15,8 +15,10 @@ spinlock => enabled
rwlock => enabled
sockets => enabled
openssl => OpenSSL 1.1.1i FIPS 8 Dec 2020
+dtls => enabled
http2 => enabled
json => enabled
+curl-native => enabled
pcre => enabled
zlib => 1.2.11
brotli => E16777225/D16777225
diff --git a/REFLECTION b/REFLECTION
index 47ba931..982b499 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,10 @@
-Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
+Extension [ <persistent> extension #119 swoole version 4.6.0 ] {
- Dependencies {
Dependency [ json (Required) ]
Dependency [ mysqlnd (Required) ]
Dependency [ sockets (Required) ]
+ Dependency [ curl (Required) ]
}
- INI {
@@ -27,12 +28,12 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
- - Constants [359] {
- Constant [ string SWOOLE_VERSION ] { 4.5.10 }
- Constant [ int SWOOLE_VERSION_ID ] { 40510 }
+ - Constants [361] {
+ Constant [ string SWOOLE_VERSION ] { 4.6.0 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40600 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
- Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 10 }
+ Constant [ int SWOOLE_MINOR_VERSION ] { 6 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -262,9 +263,11 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
Constant [ int SWOOLE_HOOK_FILE ] { 256 }
Constant [ int SWOOLE_HOOK_SLEEP ] { 512 }
Constant [ int SWOOLE_HOOK_PROC ] { 1024 }
- Constant [ int SWOOLE_HOOK_CURL ] { 268435456 }
- Constant [ int SWOOLE_HOOK_BLOCKING_FUNCTION ] { 1073741824 }
- Constant [ int SWOOLE_HOOK_ALL ] { 2147483647 }
+ Constant [ int SWOOLE_HOOK_CURL ] { 2048 }
+ Constant [ int SWOOLE_HOOK_NATIVE_CURL ] { 4096 }
+ Constant [ int SWOOLE_HOOK_BLOCKING_FUNCTION ] { 8192 }
+ Constant [ int SWOOLE_HOOK_SOCKETS ] { 16384 }
+ Constant [ int SWOOLE_HOOK_ALL ] { 2147481599 }
Constant [ int SOCKET_ECANCELED ] { 125 }
Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_CONNECT_FAILED ] { -1 }
Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_REQUEST_TIMEOUT ] { -2 }
@@ -431,6 +434,21 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
Parameter #0 [ <required> callable $callback ]
}
}
+ Function [ <internal:swoole> function swoole_coroutine_socketpair ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $domain ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $protocol ]
+ }
+ }
+ Function [ <internal:swoole> function swoole_test_kernel_coroutine ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $count ]
+ Parameter #1 [ <optional> $sleep_time ]
+ }
+ }
Function [ <internal:swoole> function swoole_client_select ] {
- Parameters [4] {
@@ -477,6 +495,11 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_clear_error ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:swoole> function swoole_error_log ] {
- Parameters [2] {
@@ -697,7 +720,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
- - Classes [47] {
+ - Classes [53] {
Class [ <internal:swoole> class Swoole\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -1177,7 +1200,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
- Method [ <internal:swoole> static public method setaffinity ] {
+ Method [ <internal:swoole> static public method setAffinity ] {
- Parameters [1] {
Parameter #0 [ <required> array $cpu_settings ]
@@ -1194,7 +1217,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
Property [ <default> private $callback ]
}
- - Methods [18] {
+ - Methods [20] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -1211,6 +1234,21 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Method [ <internal:swoole> public method setPriority ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $which ]
+ Parameter #1 [ <required> $priority ]
+ }
+ }
+
+ Method [ <internal:swoole> public method getPriority ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $which ]
+ }
+ }
+
Method [ <internal:swoole> public method set ] {
- Parameters [1] {
@@ -1661,7 +1699,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
- Static methods [9] {
- Method [ <internal:swoole> static public method set ] {
+ Method [ <internal, deprecated:swoole> static public method set ] {
- Parameters [1] {
Parameter #0 [ <required> array $settings ]
@@ -1936,7 +1974,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Static properties [0] {
}
- - Static methods [33] {
+ - Static methods [35] {
Method [ <internal:swoole> static public method create ] {
- Parameters [2] {
@@ -1959,6 +1997,12 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Method [ <internal:swoole> static public method getOptions ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method exists ] {
- Parameters [1] {
@@ -2026,6 +2070,15 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Method [ <internal:swoole> static public method printBackTrace ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $cid ]
+ Parameter #1 [ <optional> $options ]
+ Parameter #2 [ <optional> $limit ]
+ }
+ }
+
Method [ <internal:swoole> static public method getElapsed ] {
- Parameters [1] {
@@ -2793,7 +2846,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:swoole> public method add ] {
- Parameters [2] {
@@ -2818,6 +2871,12 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Method [ <internal:swoole> public method getOptions ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method start ] {
- Parameters [0] {
@@ -2935,6 +2994,63 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Coroutine\Curl\Exception extends Swoole\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Coroutine\Socket ] {
- Constants [0] {
@@ -2946,8 +3062,11 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [6] {
Property [ <default> public $fd ]
+ Property [ <default> public $domain ]
+ Property [ <default> public $type ]
+ Property [ <default> public $protocol ]
Property [ <default> public $errCode ]
Property [ <default> public $errMsg ]
}
@@ -5493,7 +5612,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Parameters [3] {
Parameter #0 [ <required> $host ]
Parameter #1 [ <optional> $port ]
- Parameter #2 [ <optional> $ssl ]
+ Parameter #2 [ <optional> $open_ssl ]
}
}
@@ -6101,8 +6220,9 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> public $data ]
+ Property [ <default> public $dispatch_time ]
Property [ <default> public $id ]
Property [ <default> public $worker_id ]
Property [ <default> public $flags ]
@@ -6118,6 +6238,117 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Server\Event ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $reactor_id ]
+ Property [ <default> public $fd ]
+ Property [ <default> public $dispatch_time ]
+ Property [ <default> public $data ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Server\Packet ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> public $server_socket ]
+ Property [ <default> public $server_port ]
+ Property [ <default> public $dispatch_time ]
+ Property [ <default> public $address ]
+ Property [ <default> public $port ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Server\PipeMessage ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $source_worker_id ]
+ Property [ <default> public $dispatch_time ]
+ Property [ <default> public $data ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Server\StatusInfo ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $worker_pid ]
+ Property [ <default> public $status ]
+ Property [ <default> public $exit_code ]
+ Property [ <default> public $signal ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Server\TaskResult ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $task_id ]
+ Property [ <default> public $task_worker_id ]
+ Property [ <default> public $dispatch_time ]
+ Property [ <default> public $data ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> <iterateable> class Swoole\Connection\Iterator implements Iterator, Traversable, ArrayAccess, Countable ] {
- Constants [0] {
@@ -6293,7 +6524,13 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:swoole> static public method create ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $options ]
+ }
+ }
}
- Properties [9] {
@@ -6308,7 +6545,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
Property [ <default> public $tmpfiles ]
}
- - Methods [4] {
+ - Methods [6] {
Method [ <internal:swoole> public method rawContent ] {
- Parameters [0] {
@@ -6327,6 +6564,19 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
}
}
+ Method [ <internal:swoole> public method parse ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole> public method isCompleted ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -6361,13 +6611,19 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
Property [ <default> public $trailer ]
}
- - Methods [21] {
+ - Methods [22] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
}
}
+ Method [ <internal:swoole> public method isWritable ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method cookie ] {
- Parameters [9] {
@@ -6434,7 +6690,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Parameters [3] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $ucwords ]
+ Parameter #2 [ <optional> $format ]
}
}
@@ -6443,7 +6699,7 @@ Extension [ <persistent> extension #118 swoole version 4.5.10 ] {
- Parameters [3] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $ucwords ]
+ Parameter #2 [ <optional> $format ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index a5d5710..74c4023 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.10
+%global upstream_version 4.6.0
#global upstream_prever RC2
@@ -44,20 +44,23 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
+BuildRequires: libcurl-devel
%if %{with_brotli}
BuildRequires: brotli-devel
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-curl%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-sockets%{?_isa}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
@@ -196,6 +199,7 @@ peclbuild() {
--enable-http2 \
--enable-mysqlnd \
--enable-swoole-json \
+ --enable-swoole-curl \
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -267,6 +271,7 @@ fi
%check
OPT="--no-php-ini"
+[ -f %{php_extdir}/curl.so ] && OPT="$OPT -d extension=curl.so"
[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
@@ -318,6 +323,11 @@ cd ../ZTS
%changelog
+* Wed Jan 6 2021 Remi Collet <remi@remirepo.net> - 4.6.0-1
+- update to 4.6.0
+- enable curl support
+- raise dependency on PHP 7.2
+
* Wed Dec 23 2020 Remi Collet <remi@remirepo.net> - 4.5.10-1
- update to 4.5.10