summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec16
1 files changed, 13 insertions, 3 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index a5d5710..74c4023 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.10
+%global upstream_version 4.6.0
#global upstream_prever RC2
@@ -44,20 +44,23 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
+BuildRequires: libcurl-devel
%if %{with_brotli}
BuildRequires: brotli-devel
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-curl%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-sockets%{?_isa}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
@@ -196,6 +199,7 @@ peclbuild() {
--enable-http2 \
--enable-mysqlnd \
--enable-swoole-json \
+ --enable-swoole-curl \
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -267,6 +271,7 @@ fi
%check
OPT="--no-php-ini"
+[ -f %{php_extdir}/curl.so ] && OPT="$OPT -d extension=curl.so"
[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
@@ -318,6 +323,11 @@ cd ../ZTS
%changelog
+* Wed Jan 6 2021 Remi Collet <remi@remirepo.net> - 4.6.0-1
+- update to 4.6.0
+- enable curl support
+- raise dependency on PHP 7.2
+
* Wed Dec 23 2020 Remi Collet <remi@remirepo.net> - 4.5.10-1
- update to 4.5.10