summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-04 07:56:33 +0100
committerRemi Collet <remi@remirepo.net>2019-02-04 07:56:33 +0100
commit373e518682623e9c729ad62161540c64c3aa2690 (patch)
treec6d9e268d36a6854df7aae648fd8864b01827c21
parent8b9dea12f10e1437835b59c0b76332833ce5451c (diff)
v4.2.13
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION189
-rw-r--r--php-pecl-swoole4.spec8
3 files changed, 153 insertions, 50 deletions
diff --git a/PHPINFO b/PHPINFO
index 5d42aad..43ef7f4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.2.12
-Built => Jan 6 2019 08:07:24
+Version => 4.2.13
+Built => Feb 4 2019 06:46:52
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1 FIPS 11 Sep 2018
+openssl => OpenSSL 1.1.1a FIPS 20 Nov 2018
http2 => 1.34.0
pcre => enabled
zlib => enabled
diff --git a/REFLECTION b/REFLECTION
index 45236db..2188ff3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
+Extension [ <persistent> extension #152 swoole version 4.2.13 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -18,12 +18,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
- - Constants [253] {
- Constant [ string SWOOLE_VERSION ] { 4.2.12 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40212 }
+ - Constants [257] {
+ Constant [ string SWOOLE_VERSION ] { 4.2.13 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40213 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 2 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 12 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 13 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -69,6 +69,10 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
+ Constant [ integer SWOOLE_STRERROR_SYSTEM ] { 0 }
+ Constant [ integer SWOOLE_STRERROR_GAI ] { 1 }
+ Constant [ integer SWOOLE_STRERROR_DNS ] { 2 }
+ Constant [ integer SWOOLE_STRERROR_SWOOLE ] { 9 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -128,7 +132,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Constant [ integer SWOOLE_ERROR_SERVER_ONLY_START_ONE ] { 9008 }
Constant [ integer SWOOLE_ERROR_SERVER_SEND_IN_MASTER ] { 9009 }
Constant [ integer SWOOLE_ERROR_SERVER_INVALID_REQUEST ] { 9010 }
- Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9011 }
+ Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9012 }
Constant [ integer SWOOLE_ERROR_CO_OUT_OF_COROUTINE ] { 10001 }
Constant [ integer SWOOLE_ERROR_CO_HAS_BEEN_BOUND ] { 10002 }
Constant [ integer SWOOLE_ERROR_CO_MUTEX_DOUBLE_UNLOCK ] { 10003 }
@@ -361,14 +365,15 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $param ]
+ Parameter #2 [ <optional> ...$params ]
}
}
Function [ <internal:swoole> function swoole_timer_tick ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> ...$params ]
}
}
Function [ <internal:swoole> function swoole_timer_exists ] {
@@ -550,9 +555,10 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Static methods [4] {
Method [ <internal:swoole> static public method tick ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> ...$params ]
}
}
@@ -561,7 +567,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $param ]
+ Parameter #2 [ <optional> ...$params ]
}
}
@@ -820,13 +826,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Static methods [0] {
}
- - Properties [29] {
- Property [ <default> private $onConnect ]
- Property [ <default> private $onReceive ]
- Property [ <default> private $onClose ]
- Property [ <default> private $onPacket ]
- Property [ <default> private $onBufferFull ]
- Property [ <default> private $onBufferEmpty ]
+ - Properties [23] {
Property [ <default> private $onStart ]
Property [ <default> private $onShutdown ]
Property [ <default> private $onWorkerStart ]
@@ -852,7 +852,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [40] {
+ - Methods [41] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -935,6 +935,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole> public method exist ] {
- Parameters [1] {
@@ -1291,16 +1298,16 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
- Properties [16] {
- Property [ <default> public $onConnect ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onPacket ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onRequest ]
- Property [ <default> public $onHandShake ]
- Property [ <default> public $onMessage ]
- Property [ <default> public $onOpen ]
+ Property [ <default> private $onConnect ]
+ Property [ <default> private $onReceive ]
+ Property [ <default> private $onClose ]
+ Property [ <default> private $onPacket ]
+ Property [ <default> private $onBufferFull ]
+ Property [ <default> private $onBufferEmpty ]
+ Property [ <default> private $onRequest ]
+ Property [ <default> private $onHandShake ]
+ Property [ <default> private $onMessage ]
+ Property [ <default> private $onOpen ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -1559,7 +1566,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $errCode ]
}
- - Methods [13] {
+ - Methods [14] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -1633,25 +1640,32 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
- Method [ <internal:swoole> public method getpeername ] {
+ Method [ <internal:swoole> public method shutdown ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $how ]
+ }
+ }
+
+ Method [ <internal:swoole> public method close ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole> public method getsockname ] {
+ Method [ <internal:swoole> public method getpeername ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole> public method getSocket ] {
+ Method [ <internal:swoole> public method getsockname ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole> public method close ] {
+ Method [ <internal:swoole> public method getSocket ] {
- Parameters [0] {
}
@@ -1890,7 +1904,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $errMsg ]
}
- - Methods [157] {
+ - Methods [161] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1913,6 +1927,18 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> public method getAuth ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method getDBNum ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method getOptions ] {
- Parameters [0] {
@@ -1926,13 +1952,23 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
- Method [ <internal:swoole> public method setDefer ] {
+ Method [ <internal:swoole> public method getDefer ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method getDefer ] {
+ Method [ <internal:swoole> public method setDefer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $defer ]
+ }
}
Method [ <internal:swoole> public method recv ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole> public method request ] {
@@ -3087,6 +3123,20 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> public method unsubscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $channels ]
+ }
+ }
+
+ Method [ <internal:swoole> public method pUnSubscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $patterns ]
+ }
+ }
+
Method [ <internal:swoole> public method multi ] {
- Parameters [0] {
@@ -3672,7 +3722,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Static properties [0] {
}
- - Static methods [21] {
+ - Static methods [24] {
Method [ <internal:swoole> static public method create ] {
- Parameters [2] {
@@ -3711,6 +3761,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> static public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cid ]
+ }
+ }
+
Method [ <internal:swoole> static public method yield ] {
- Parameters [0] {
@@ -3726,7 +3783,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Method [ <internal:swoole> static public method resume ] {
- Parameters [1] {
- Parameter #0 [ <required> $uid ]
+ Parameter #0 [ <required> $cid ]
}
}
@@ -3748,6 +3805,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> static public method getPcid ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method sleep ] {
- Parameters [1] {
@@ -3816,12 +3879,18 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Method [ <internal:swoole> static public method getBackTrace ] {
- Parameters [3] {
- Parameter #0 [ <required> $cid ]
+ Parameter #0 [ <optional> $cid ]
Parameter #1 [ <optional> $options ]
Parameter #2 [ <optional> $limit ]
}
}
+ Method [ <internal:swoole> static public method list ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method listCoroutines ] {
- Parameters [0] {
@@ -4166,8 +4235,9 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Method [ <internal:swoole> static public method alarm ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $usec ]
+ Parameter #1 [ <optional> $type ]
}
}
@@ -4404,7 +4474,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
- Properties [0] {
}
- - Methods [21] {
+ - Methods [22] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -4463,6 +4533,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole> public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:swoole> public method exist ] {
- Parameters [1] {
@@ -4880,7 +4957,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $setting ]
}
- - Methods [40] {
+ - Methods [41] {
Method [ <internal:swoole, inherits Swoole\Server, ctor> public method __construct ] {
- Parameters [4] {
@@ -4963,6 +5040,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method exist ] {
- Parameters [1] {
@@ -5502,7 +5586,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $setting ]
}
- - Methods [43] {
+ - Methods [44] {
Method [ <internal:swoole> public method push ] {
- Parameters [4] {
@@ -5522,6 +5606,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method exist ] {
- Parameters [1] {
@@ -6199,8 +6290,9 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Method [ <internal:swoole> public method push ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $timeout ]
}
}
@@ -6761,7 +6853,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [41] {
+ - Methods [42] {
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method start ] {
- Parameters [0] {
@@ -6854,6 +6946,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.12 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method exist ] {
- Parameters [1] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index bc46fe8..c8a7fbd 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.12
+Version: 4.2.13
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -59,7 +59,7 @@ BuildRequires: openssl-devel
BuildRequires: libnghttp2-devel
%endif
%if %{with_pgsql}
-%if 0%{?fedora} >= 30
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
BuildRequires: libpq-devel > 9.5
%else
BuildRequires: postgresql-devel > 9.5
@@ -334,6 +334,7 @@ cd ../ZTS
%doc %{pecl_docdir}/%{pecl_name}/include
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/travis
+%doc %{pecl_docdir}/%{pecl_name}/src
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -342,6 +343,9 @@ cd ../ZTS
%changelog
+* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 4.2.13-1
+- update to 4.2.13
+
* Sun Jan 6 2019 Remi Collet <remi@remirepo.net> - 4.2.12-1
- update to 4.2.12
- use --enable-cares build option