summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-17 10:15:45 +0100
committerRemi Collet <remi@php.net>2023-02-17 10:15:45 +0100
commit10524984cdc4c499d8fc73ca966419ace9c8472a (patch)
treea361c941cbbb88a6f9eb342b94021e4efecc63f6
parent8ed1fc9a47c105c8a9f18fcc813dd4e4919de9ef (diff)
fix GCC 13 build using patch from
https://github.com/swoole/swoole-src/pull/4985
-rw-r--r--php-pecl-swoole4.spec18
-rw-r--r--swoole-gcc13.patch21
2 files changed, 33 insertions, 6 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 63b9c71..7259691 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -34,15 +34,16 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-# Extension is ASL 2.0
-# Hiredis is BSD
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+# Extension is Apache-2.0
+# Hiredis is BSD-3-Clause
# nlohmann/json is MIT
-License: ASL 2.0 and BSD and MIT
+License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
Patch0: %{pecl_name}-build.patch
+Patch1: %{pecl_name}-gcc13.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -140,6 +141,7 @@ sed \
cd NTS
%patch0 -p1
+%patch1 -p1
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -310,6 +312,10 @@ cd ../ZTS
%changelog
+* Fri Feb 17 2023 Remi Collet <remi@remirepo.net> - 4.8.12-2
+- fix GCC 13 build using patch from
+ https://github.com/swoole/swoole-src/pull/4985
+
* Wed Sep 21 2022 Remi Collet <remi@remirepo.net> - 4.8.12-1
- update to 4.8.12
diff --git a/swoole-gcc13.patch b/swoole-gcc13.patch
new file mode 100644
index 0000000..30be7dc
--- /dev/null
+++ b/swoole-gcc13.patch
@@ -0,0 +1,21 @@
+From 3191406bcb6a9f6a076c423417e921a313bdccf9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 17 Feb 2023 09:54:15 +0100
+Subject: [PATCH] Fix #4983 Add missing header for GCC 13
+
+---
+ include/swoole_proxy.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/swoole_proxy.h b/include/swoole_proxy.h
+index 7a0a955a7a..9f403b50cd 100644
+--- a/include/swoole_proxy.h
++++ b/include/swoole_proxy.h
+@@ -17,6 +17,7 @@
+ #pragma once
+
+ #include <string>
++#include <cstdint>
+
+ #define SW_SOCKS5_VERSION_CODE 0x05
+