summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-21 17:53:27 +0200
committerRemi Collet <remi@php.net>2022-09-21 17:53:27 +0200
commit8ed1fc9a47c105c8a9f18fcc813dd4e4919de9ef (patch)
treedf4205b761eadcd7b56d8681dd46c77adaf34196
parent91575bf9da01a7ed208650806344b6e5c8b0eea9 (diff)
update to 4.8.12
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION146
-rw-r--r--php-pecl-swoole4.spec17
3 files changed, 123 insertions, 46 deletions
diff --git a/PHPINFO b/PHPINFO
index 4c94a61..0b7c169 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.8.11
-Built => Jul 12 2022 00:00:00
+Version => 4.8.12
+Built => Sep 21 2022 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1o FIPS 3 May 2022
+openssl => OpenSSL 1.1.1q FIPS 5 Jul 2022
dtls => enabled
http2 => enabled
json => enabled
diff --git a/REFLECTION b/REFLECTION
index 5576ab6..233156a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
+Extension [ <persistent> extension #108 swoole version 4.8.12 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
}
}
- - Constants [395] {
- Constant [ string SWOOLE_VERSION ] { 4.8.11 }
- Constant [ int SWOOLE_VERSION_ID ] { 40811 }
+ - Constants [396] {
+ Constant [ string SWOOLE_VERSION ] { 4.8.12 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40812 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 11 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 12 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -111,6 +111,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
Constant [ int SWOOLE_ERROR_BAD_IPV6_ADDRESS ] { 720 }
Constant [ int SWOOLE_ERROR_UNREGISTERED_SIGNAL ] { 721 }
Constant [ int SWOOLE_ERROR_EVENT_SOCKET_REMOVED ] { 800 }
+ Constant [ int SWOOLE_ERROR_EVENT_SOCKET_INVALID ] { 801 }
Constant [ int SWOOLE_ERROR_SESSION_CLOSED_BY_SERVER ] { 1001 }
Constant [ int SWOOLE_ERROR_SESSION_CLOSED_BY_CLIENT ] { 1002 }
Constant [ int SWOOLE_ERROR_SESSION_CLOSING ] { 1003 }
@@ -1195,8 +1196,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1213,6 +1214,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1286,8 +1288,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1304,6 +1306,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2240,7 +2243,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
}
}
- Class [ <internal:swoole> <iterateable> class Swoole\Timer\Iterator extends ArrayIterator implements Countable, Serializable, SeekableIterator, ArrayAccess, Traversable, Iterator ] {
+ Class [ <internal:swoole> <iterateable> class Swoole\Timer\Iterator extends ArrayIterator implements Countable, Serializable, ArrayAccess, Iterator, Traversable, SeekableIterator ] {
- Constants [2] {
Constant [ public int STD_PROP_LIST ] { 1 }
@@ -2270,6 +2273,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetGet ] {
@@ -2277,6 +2281,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetSet ] {
@@ -2285,6 +2290,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
Parameter #0 [ <required> mixed $key ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetUnset ] {
@@ -2292,6 +2298,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method append ] {
@@ -2299,24 +2306,28 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method getArrayCopy ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method getFlags ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method setFlags ] {
@@ -2324,6 +2335,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method asort ] {
@@ -2331,6 +2343,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method ksort ] {
@@ -2338,6 +2351,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uasort ] {
@@ -2345,6 +2359,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uksort ] {
@@ -2352,18 +2367,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natsort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natcasesort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method unserialize ] {
@@ -2371,18 +2389,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> string $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method serialize ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __serialize ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __unserialize ] {
@@ -2390,36 +2411,42 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ string|int|null ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype SeekableIterator> public method seek ] {
@@ -2427,12 +2454,14 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __debugInfo ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
}
}
@@ -2741,7 +2770,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
}
}
- Class [ <internal:swoole> <iterateable> class Swoole\Coroutine\Iterator extends ArrayIterator implements Countable, Serializable, SeekableIterator, ArrayAccess, Traversable, Iterator ] {
+ Class [ <internal:swoole> <iterateable> class Swoole\Coroutine\Iterator extends ArrayIterator implements Countable, Serializable, ArrayAccess, Iterator, Traversable, SeekableIterator ] {
- Constants [2] {
Constant [ public int STD_PROP_LIST ] { 1 }
@@ -2771,6 +2800,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetGet ] {
@@ -2778,6 +2808,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetSet ] {
@@ -2786,6 +2817,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
Parameter #0 [ <required> mixed $key ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype ArrayAccess> public method offsetUnset ] {
@@ -2793,6 +2825,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method append ] {
@@ -2800,24 +2833,28 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method getArrayCopy ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method getFlags ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method setFlags ] {
@@ -2825,6 +2862,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method asort ] {
@@ -2832,6 +2870,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method ksort ] {
@@ -2839,6 +2878,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uasort ] {
@@ -2846,6 +2886,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uksort ] {
@@ -2853,18 +2894,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natsort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natcasesort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method unserialize ] {
@@ -2872,18 +2916,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> string $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method serialize ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __serialize ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __unserialize ] {
@@ -2891,36 +2938,42 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ string|int|null ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype SeekableIterator> public method seek ] {
@@ -2928,12 +2981,14 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method __debugInfo ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
}
}
@@ -2969,6 +3024,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetGet ] {
@@ -2976,6 +3032,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetSet ] {
@@ -2984,6 +3041,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
Parameter #0 [ <required> mixed $key ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetUnset ] {
@@ -2991,6 +3049,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $key ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject> public method append ] {
@@ -2998,24 +3057,28 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject> public method getArrayCopy ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayObject> public method getFlags ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:SPL, inherits ArrayObject> public method setFlags ] {
@@ -3023,6 +3086,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject> public method asort ] {
@@ -3030,6 +3094,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject> public method ksort ] {
@@ -3037,6 +3102,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject> public method uasort ] {
@@ -3044,6 +3110,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject> public method uksort ] {
@@ -3051,18 +3118,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject> public method natsort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject> public method natcasesort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method unserialize ] {
@@ -3070,18 +3140,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> string $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method serialize ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:SPL, inherits ArrayObject> public method __serialize ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayObject> public method __unserialize ] {
@@ -3089,12 +3162,14 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype IteratorAggregate> public method getIterator ] {
- Parameters [0] {
}
+ - Tentative return [ Iterator ]
}
Method [ <internal:SPL, inherits ArrayObject> public method exchangeArray ] {
@@ -3102,6 +3177,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> object|array $array ]
}
+ - Tentative return [ array ]
}
Method [ <internal:SPL, inherits ArrayObject> public method setIteratorClass ] {
@@ -3109,18 +3185,21 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [1] {
Parameter #0 [ <required> string $iteratorClass ]
}
+ - Tentative return [ void ]
}
Method [ <internal:SPL, inherits ArrayObject> public method getIteratorClass ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:SPL, inherits ArrayObject> public method __debugInfo ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
}
}
@@ -3139,8 +3218,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [6] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ private $flags = 0 ]
Property [ private $status = 0 ]
}
@@ -3171,6 +3250,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3547,8 +3627,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -3565,6 +3645,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3895,8 +3976,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -3913,6 +3994,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4139,8 +4221,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4157,6 +4239,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4620,8 +4703,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4638,6 +4721,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4908,8 +4992,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4926,6 +5010,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -6626,8 +6711,8 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -6644,6 +6729,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -7190,7 +7276,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [5] {
Property [ public $data = NULL ]
- Property [ public $dispatch_time = 0 ]
+ Property [ public $dispatch_time = 0.0 ]
Property [ public $id = -1 ]
Property [ public $worker_id = -1 ]
Property [ public $flags = 0 ]
@@ -7220,7 +7306,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ public $reactor_id = 0 ]
Property [ public $fd = 0 ]
- Property [ public $dispatch_time = 0 ]
+ Property [ public $dispatch_time = 0.0 ]
Property [ public $data = NULL ]
}
@@ -7242,7 +7328,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [5] {
Property [ public $server_socket = 0 ]
Property [ public $server_port = 0 ]
- Property [ public $dispatch_time = 0 ]
+ Property [ public $dispatch_time = 0.0 ]
Property [ public $address = NULL ]
Property [ public $port = 0 ]
}
@@ -7264,7 +7350,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [3] {
Property [ public $source_worker_id = 0 ]
- Property [ public $dispatch_time = 0 ]
+ Property [ public $dispatch_time = 0.0 ]
Property [ public $data = NULL ]
}
@@ -7309,7 +7395,7 @@ Extension [ <persistent> extension #88 swoole version 4.8.11 ] {
- Properties [4] {
Property [ public $task_id = 0 ]
Property [ public $task_worker_id = 0 ]
- Property [ public $dispatch_time = 0 ]
+ Property [ public $dispatch_time = 0.0 ]
Property [ public $data = NULL ]
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9296752..63b9c71 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.11
+%global upstream_version 4.8.12
#global upstream_prever RC2
@@ -92,18 +92,6 @@ Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 4
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-openswoole
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
Event-driven asynchronous and concurrent networking engine with
@@ -322,6 +310,9 @@ cd ../ZTS
%changelog
+* Wed Sep 21 2022 Remi Collet <remi@remirepo.net> - 4.8.12-1
+- update to 4.8.12
+
* Tue Jul 12 2022 Remi Collet <remi@remirepo.net> - 4.8.11-1
- update to 4.8.11