summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-15 14:54:37 +0200
committerRemi Collet <remi@remirepo.net>2019-10-15 14:54:37 +0200
commit018bf6061ecf97b34c27406bc7aded5a3a4dd9c2 (patch)
treeabd45af122c4ee81ed9976e28583b0b1047ba765
parent01482944cc17c20af6ad0ec25c1f4094128f4ae6 (diff)
v4.4.8
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION113
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 48 insertions, 76 deletions
diff --git a/PHPINFO b/PHPINFO
index 7e23193..9f5e294 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.4.7
-Built => Sep 25 2019 10:28:57
+Version => 4.4.8
+Built => Oct 15 2019 14:49:10
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1c FIPS 28 May 2019
+openssl => OpenSSL 1.1.1d FIPS 10 Sep 2019
http2 => enabled
pcre => enabled
zlib => enabled
diff --git a/REFLECTION b/REFLECTION
index 1f5231e..e490b23 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
+Extension [ <persistent> extension #153 swoole version 4.4.8 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
- - Constants [315] {
- Constant [ string SWOOLE_VERSION ] { 4.4.7 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40407 }
+ - Constants [317] {
+ Constant [ string SWOOLE_VERSION ] { 4.4.8 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40408 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 4 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 7 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 8 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -38,14 +38,14 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Constant [ integer SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ integer SWOOLE_SOCK_UDP ] { 2 }
Constant [ integer SWOOLE_SOCK_UDP6 ] { 4 }
- Constant [ integer SWOOLE_SOCK_UNIX_DGRAM ] { 5 }
- Constant [ integer SWOOLE_SOCK_UNIX_STREAM ] { 6 }
+ Constant [ integer SWOOLE_SOCK_UNIX_DGRAM ] { 6 }
+ Constant [ integer SWOOLE_SOCK_UNIX_STREAM ] { 5 }
Constant [ integer SWOOLE_TCP ] { 1 }
Constant [ integer SWOOLE_TCP6 ] { 3 }
Constant [ integer SWOOLE_UDP ] { 2 }
Constant [ integer SWOOLE_UDP6 ] { 4 }
- Constant [ integer SWOOLE_UNIX_DGRAM ] { 5 }
- Constant [ integer SWOOLE_UNIX_STREAM ] { 6 }
+ Constant [ integer SWOOLE_UNIX_DGRAM ] { 6 }
+ Constant [ integer SWOOLE_UNIX_STREAM ] { 5 }
Constant [ boolean SWOOLE_SOCK_SYNC ] { }
Constant [ boolean SWOOLE_SOCK_ASYNC ] { 1 }
Constant [ integer SWOOLE_SYNC ] { 2048 }
@@ -99,12 +99,14 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Constant [ integer SWOOLE_ERROR_SESSION_INVALID_ID ] { 1006 }
Constant [ integer SWOOLE_ERROR_SESSION_DISCARD_TIMEOUT_DATA ] { 1007 }
Constant [ integer SWOOLE_ERROR_OUTPUT_BUFFER_OVERFLOW ] { 1008 }
- Constant [ integer SWOOLE_ERROR_SSL_NOT_READY ] { 1009 }
- Constant [ integer SWOOLE_ERROR_SSL_CANNOT_USE_SENFILE ] { 1010 }
- Constant [ integer SWOOLE_ERROR_SSL_EMPTY_PEER_CERTIFICATE ] { 1011 }
- Constant [ integer SWOOLE_ERROR_SSL_VEFIRY_FAILED ] { 1012 }
- Constant [ integer SWOOLE_ERROR_SSL_BAD_CLIENT ] { 1013 }
- Constant [ integer SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1014 }
+ Constant [ integer SWOOLE_ERROR_OUTPUT_SEND_YIELD ] { 1009 }
+ Constant [ integer SWOOLE_ERROR_SSL_NOT_READY ] { 1010 }
+ Constant [ integer SWOOLE_ERROR_SSL_CANNOT_USE_SENFILE ] { 1011 }
+ Constant [ integer SWOOLE_ERROR_SSL_EMPTY_PEER_CERTIFICATE ] { 1012 }
+ Constant [ integer SWOOLE_ERROR_SSL_VEFIRY_FAILED ] { 1013 }
+ Constant [ integer SWOOLE_ERROR_SSL_BAD_CLIENT ] { 1014 }
+ Constant [ integer SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1015 }
+ Constant [ integer SWOOLE_ERROR_SSL_RESET ] { 1016 }
Constant [ integer SWOOLE_ERROR_PACKAGE_LENGTH_TOO_LARGE ] { 1201 }
Constant [ integer SWOOLE_ERROR_PACKAGE_LENGTH_NOT_FOUND ] { 1202 }
Constant [ integer SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1203 }
@@ -1146,9 +1148,10 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Method [ <internal:swoole> static public method daemon ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <optional> $nochdir ]
Parameter #1 [ <optional> $noclose ]
+ Parameter #2 [ <optional> $pipes ]
}
}
@@ -3017,7 +3020,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
- Static methods [0] {
}
- - Properties [14] {
+ - Properties [7] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
@@ -3025,21 +3028,15 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Property [ <default> public $type ]
Property [ <default> public $id ]
Property [ <default> public $setting ]
- Property [ <default> private $onConnect ]
- Property [ <default> private $onError ]
- Property [ <default> private $onReceive ]
- Property [ <default> private $onClose ]
- Property [ <default> private $onBufferFull ]
- Property [ <default> private $onBufferEmpty ]
- Property [ <default> private $onSSLReady ]
}
- - Methods [23] {
+ - Methods [17] {
Method [ <internal:swoole, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $type ]
Parameter #1 [ <optional> $async ]
+ Parameter #2 [ <optional> $id ]
}
}
@@ -3082,13 +3079,6 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
- Method [ <internal:swoole> public method pipe ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $dst_socket ]
- }
- }
-
Method [ <internal:swoole> public method sendfile ] {
- Parameters [3] {
@@ -3107,30 +3097,6 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
- Method [ <internal:swoole> public method sleep ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method pause ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method resume ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:swoole> public method shutdown ] {
- Parameters [1] {
@@ -3140,8 +3106,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Method [ <internal:swoole> public method enableSSL ] {
- - Parameters [1] {
- Parameter #0 [ <optional> callable $callback ]
+ - Parameters [0] {
}
}
@@ -3182,14 +3147,6 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
- Method [ <internal:swoole> public method on ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $event_name ]
- Parameter #1 [ <required> callable $callback ]
- }
- }
-
Method [ <internal:swoole> public method getSocket ] {
- Parameters [0] {
@@ -5797,7 +5754,13 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:swoole> static public method pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
}
- Properties [4] {
@@ -6053,7 +6016,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Property [ <default> public $trailer ]
}
- - Methods [19] {
+ - Methods [20] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -6205,6 +6168,12 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
+ Method [ <internal:swoole> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -6224,7 +6193,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
- Static methods [0] {
}
- - Properties [14] {
+ - Properties [13] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6238,7 +6207,6 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
Property [ <default> private $onRequest ]
- Property [ <default> private $onHandshake ]
}
- Methods [42] {
@@ -6665,7 +6633,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
}
}
- - Properties [12] {
+ - Properties [13] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6678,6 +6646,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> private $onHandshake ]
}
- Methods [45] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 98badb0..33c918c 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.4.7
+Version: 4.4.8
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -332,6 +332,9 @@ cd ../ZTS
%changelog
+* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 4.4.8-1
+- update to 4.4.8
+
* Wed Sep 25 2019 Remi Collet <remi@remirepo.net> - 4.4.7-1
- update to 4.4.7