summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-25 10:33:05 +0200
committerRemi Collet <remi@remirepo.net>2019-09-25 10:33:05 +0200
commit01482944cc17c20af6ad0ec25c1f4094128f4ae6 (patch)
treef811aabdd045d649c9a187cf4979adabe34e30d8
parent8e5e9521e5d2ea31a04aee3c1aef70ef1c7c50ca (diff)
v4.4.7
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION36
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 26 insertions, 19 deletions
diff --git a/PHPINFO b/PHPINFO
index 25bd9d8..7e23193 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.4.6
-Built => Sep 19 2019 08:01:07
+Version => 4.4.7
+Built => Sep 25 2019 10:28:57
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index f73b5d8..1f5231e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 4.4.6 ] {
+Extension [ <persistent> extension #153 swoole version 4.4.7 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #153 swoole version 4.4.6 ] {
}
}
- - Constants [311] {
- Constant [ string SWOOLE_VERSION ] { 4.4.6 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40406 }
+ - Constants [315] {
+ Constant [ string SWOOLE_VERSION ] { 4.4.7 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40407 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 4 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 6 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 7 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -106,14 +106,17 @@ Extension [ <persistent> extension #153 swoole version 4.4.6 ] {
Constant [ integer SWOOLE_ERROR_SSL_BAD_CLIENT ] { 1013 }
Constant [ integer SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1014 }
Constant [ integer SWOOLE_ERROR_PACKAGE_LENGTH_TOO_LARGE ] { 1201 }
+ Constant [ integer SWOOLE_ERROR_PACKAGE_LENGTH_NOT_FOUND ] { 1202 }
Constant [ integer SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1203 }
Constant [ integer SWOOLE_ERROR_TASK_PACKAGE_TOO_BIG ] { 2001 }
Constant [ integer SWOOLE_ERROR_TASK_DISPATCH_FAIL ] { 2002 }
+ Constant [ integer SWOOLE_ERROR_TASK_TIMEOUT ] { 2003 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_ID_TOO_BIG ] { 3001 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
Constant [ integer SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
Constant [ integer SWOOLE_ERROR_AIO_CANCELED ] { 4002 }
+ Constant [ integer SWOOLE_ERROR_AIO_TIMEOUT ] { 4003 }
Constant [ integer SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
Constant [ integer SWOOLE_ERROR_SOCKET_CLOSED ] { 5002 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
@@ -140,17 +143,18 @@ Extension [ <persistent> extension #153 swoole version 4.4.6 ] {
Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9012 }
Constant [ integer SWOOLE_ERROR_CO_OUT_OF_COROUTINE ] { 10001 }
Constant [ integer SWOOLE_ERROR_CO_HAS_BEEN_BOUND ] { 10002 }
- Constant [ integer SWOOLE_ERROR_CO_MUTEX_DOUBLE_UNLOCK ] { 10003 }
- Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_LOCKED ] { 10004 }
- Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_WAITING ] { 10005 }
- Constant [ integer SWOOLE_ERROR_CO_YIELD_FAILED ] { 10006 }
- Constant [ integer SWOOLE_ERROR_CO_GETCONTEXT_FAILED ] { 10007 }
- Constant [ integer SWOOLE_ERROR_CO_SWAPCONTEXT_FAILED ] { 10008 }
- Constant [ integer SWOOLE_ERROR_CO_MAKECONTEXT_FAILED ] { 10009 }
- Constant [ integer SWOOLE_ERROR_CO_IOCPINIT_FAILED ] { 10010 }
- Constant [ integer SWOOLE_ERROR_CO_PROTECT_STACK_FAILED ] { 10011 }
- Constant [ integer SWOOLE_ERROR_CO_STD_THREAD_LINK_ERROR ] { 10012 }
- Constant [ integer SWOOLE_ERROR_CO_DISABLED_MULTI_THREAD ] { 10013 }
+ Constant [ integer SWOOLE_ERROR_CO_HAS_BEEN_DISCARDED ] { 10003 }
+ Constant [ integer SWOOLE_ERROR_CO_MUTEX_DOUBLE_UNLOCK ] { 10004 }
+ Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_LOCKED ] { 10005 }
+ Constant [ integer SWOOLE_ERROR_CO_BLOCK_OBJECT_WAITING ] { 10006 }
+ Constant [ integer SWOOLE_ERROR_CO_YIELD_FAILED ] { 10007 }
+ Constant [ integer SWOOLE_ERROR_CO_GETCONTEXT_FAILED ] { 10008 }
+ Constant [ integer SWOOLE_ERROR_CO_SWAPCONTEXT_FAILED ] { 10009 }
+ Constant [ integer SWOOLE_ERROR_CO_MAKECONTEXT_FAILED ] { 10010 }
+ Constant [ integer SWOOLE_ERROR_CO_IOCPINIT_FAILED ] { 10011 }
+ Constant [ integer SWOOLE_ERROR_CO_PROTECT_STACK_FAILED ] { 10012 }
+ Constant [ integer SWOOLE_ERROR_CO_STD_THREAD_LINK_ERROR ] { 10013 }
+ Constant [ integer SWOOLE_ERROR_CO_DISABLED_MULTI_THREAD ] { 10014 }
Constant [ integer SWOOLE_TRACE_SERVER ] { 2 }
Constant [ integer SWOOLE_TRACE_CLIENT ] { 4 }
Constant [ integer SWOOLE_TRACE_BUFFER ] { 8 }
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 5a52cee..98badb0 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.4.6
+Version: 4.4.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -332,6 +332,9 @@ cd ../ZTS
%changelog
+* Wed Sep 25 2019 Remi Collet <remi@remirepo.net> - 4.4.7-1
+- update to 4.4.7
+
* Thu Sep 19 2019 Remi Collet <remi@remirepo.net> - 4.4.6-1
- update to 4.4.6