summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-24 09:45:42 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-24 09:45:42 +0100
commitcbd9471fb2c072580a7f2e6a56f9b1bd838bfff9 (patch)
tree1a8d6325cb089901a79ef918578f7c5ec40ad36f
parentdbe6e3f0246014f2446fb0764b2605a9ecae57c9 (diff)
php-pecl-swoole: 1.9.6
-rw-r--r--REFLECTION73
-rw-r--r--REFLECTION-DEV2
-rw-r--r--php-pecl-swoole-dev.spec31
-rw-r--r--php-pecl-swoole.spec44
4 files changed, 110 insertions, 40 deletions
diff --git a/REFLECTION b/REFLECTION
index 6fcb24f..4ed19fb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.6 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -10,15 +10,15 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
Entry [ swoole.use_namespace <SYSTEM> ]
Current = 'Off'
}
- Entry [ swoole.message_queue_key <ALL> ]
- Current = '0'
+ Entry [ swoole.fast_serialize <ALL> ]
+ Current = 'Off'
}
Entry [ swoole.unixsock_buffer_size <ALL> ]
Current = '8388608'
}
}
- - Constants [59] {
+ - Constants [60] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.5 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.6 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -78,6 +78,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
Constant [ integer WEBSOCKET_STATUS_HANDSHAKE ] { 2 }
Constant [ integer WEBSOCKET_STATUS_FRAME ] { 3 }
Constant [ integer WEBSOCKET_STATUS_ACTIVE ] { 3 }
+ Constant [ integer SWOOLE_FAST_PACK ] { 1 }
}
- Functions {
@@ -261,7 +262,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
}
}
- - Classes [26] {
+ - Classes [27] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -2015,7 +2016,13 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
+ Method [ <internal:swoole> public method initHeader ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method cookie ] {
- Parameters [7] {
@@ -2579,7 +2586,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -2600,6 +2607,14 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
}
}
+ Method [ <internal:swoole> public method escape ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
+
Method [ <internal:swoole> public method query ] {
- Parameters [2] {
@@ -2695,14 +2710,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
- Properties [0] {
}
- - Methods [1] {
- Method [ <internal:swoole> public method __call ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $func ]
- Parameter #1 [ <required> $params ]
- }
- }
+ - Methods [0] {
}
}
@@ -2781,6 +2789,39 @@ Extension [ <persistent> extension #80 swoole version 1.9.5 ] {
}
}
+ Class [ <internal:swoole> class swoole_serialize ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:swoole> static public method pack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $flag ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method unpack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <optional> $args ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> class swoole_redis ] {
- Constants [0] {
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 564a26d..52d81e4 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #128 swoole version 2.0.6 ] {
+Extension [ <persistent> extension #131 swoole version 2.0.6 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
diff --git a/php-pecl-swoole-dev.spec b/php-pecl-swoole-dev.spec
index 96ce00a..494c4a0 100644
--- a/php-pecl-swoole-dev.spec
+++ b/php-pecl-swoole-dev.spec
@@ -31,7 +31,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.0.6
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -40,7 +40,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?scl_prefix}php-devel >= 5.5
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
-BuildRequires: %{?scl_prefix}php-mysqli
+BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
BuildRequires: openssl-devel
%if %{with_nghttpd2}
@@ -53,6 +53,7 @@ BuildRequires: hiredis-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-sockets%{?_isa}
+Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -165,15 +166,18 @@ EOF
peclbuild() {
%configure \
--with-swoole \
- --enable-openssl \
--enable-sockets \
- --enable-coroutine \
-%if %{with_nghttpd2}
- --enable-http2 \
-%endif
+ --enable-ringbuffer \
%if %{with_hiredis}
--enable-async-redis \
%endif
+ --enable-openssl \
+%if %{with_nghttpd2}
+ --enable-http2 \
+%endif
+ --enable-thread \
+ --enable-mysqlnd \
+ --enable-coroutine \
--with-php-config=$1
make %{?_smp_mflags}
@@ -236,20 +240,20 @@ fi
%check
-[ -f %{php_extdir}/sockets.so ] && modules="-d extension=sockets.so"
+OPT="--no-php-ini"
+[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
+[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
cd NTS
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- $modules \
+%{__php} $OPT \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- $modules \
+%{__ztsphp} $OPT \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
%endif
@@ -270,6 +274,9 @@ cd ../ZTS
%changelog
+* Fri Feb 24 2017 Remi Collet <remi@remirepo.net> - 2.0.6-2
+- use --enable-ringbuffer, --enable-thread and --enable-mysqlnd
+
* Tue Jan 24 2017 Remi Collet <remi@fedoraproject.org> - 2.0.6-1
- Update to 2.0.6 (beta)
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 6eb4154..1aff5e7 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -21,6 +21,13 @@
%global ini_name 40-%{pecl_name}.ini
%endif
+%if "%{php_version}" > "5.5"
+%global with_mysqlnd 1
+%else
+%global with_mysqlnd 0
+%endif
+
+
%if 0%{?fedora} >= 22 || 0%{?rhel} >= 6
%global with_nghttpd2 1
%else
@@ -30,7 +37,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.5
+Version: 1.9.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -40,7 +47,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
-BuildRequires: %{?scl_prefix}php-mysqli
+BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
BuildRequires: openssl-devel
%if %{with_nghttpd2}
@@ -53,6 +60,9 @@ BuildRequires: hiredis-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-sockets%{?_isa}
+%if %{with_mysqlnd}
+Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
+%endif
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -153,7 +163,7 @@ extension=%{pecl_name}.so
;swoole.aio_thread_num = 2
;swoole.display_errors = On
;swoole.use_namespace = Off
-;swoole.message_queue_key = 0
+;swoole.fast_serialize = Off
;swoole.unixsock_buffer_size = 8388608
EOF
@@ -164,13 +174,18 @@ EOF
peclbuild() {
%configure \
--with-swoole \
- --enable-openssl \
--enable-sockets \
+ --enable-ringbuffer \
+%if %{with_hiredis}
+ --enable-async-redis \
+%endif
+ --enable-openssl \
%if %{with_nghttpd2}
--enable-http2 \
%endif
-%if %{with_hiredis}
- --enable-async-redis \
+ --enable-thread \
+%if %{with_mysqlnd}
+ --enable-mysqlnd \
%endif
--with-php-config=$1
@@ -234,20 +249,22 @@ fi
%check
-[ -f %{php_extdir}/sockets.so ] && modules="-d extension=sockets.so"
+OPT="--no-php-ini"
+[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
+%if %{with_mysqlnd}
+[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
+%endif
cd NTS
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- $modules \
+%{__php} $OPT \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- $modules \
+%{__ztsphp} $OPT \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
%endif
@@ -268,6 +285,11 @@ cd ../ZTS
%changelog
+* Fri Feb 24 2017 Remi Collet <remi@remirepo.net> - 1.9.6-1
+- Update to 1.9.6 (stable)
+- add --enable-ringbuffer, --enable-thread build options
+- add --enable-mysqlnd build option (5.5+)
+
* Tue Jan 24 2017 Remi Collet <remi@fedoraproject.org> - 1.9.5-1
- Update to 1.9.5 (stable)