summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-24 08:04:53 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-24 08:04:53 +0100
commitdbe6e3f0246014f2446fb0764b2605a9ecae57c9 (patch)
tree20ac31d167f329602a1bb0ba5c5e52bb341f0495
parent96a3f4f794b4201ed4e5b352b131145bb63a9a6e (diff)
php-pecl-swoole: 2.0.6 (beta)
-rw-r--r--REFLECTION-DEV25
-rw-r--r--php-pecl-swoole-dev.spec12
-rw-r--r--swoole-pr992.patch23
3 files changed, 21 insertions, 39 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 84a6e51..564a26d 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
+Extension [ <persistent> extension #128 swoole version 2.0.6 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.0.5 }
+ Constant [ string SWOOLE_VERSION ] { 2.0.6 }
Constant [ integer SWOOLE_REDIS_MODE_MULTI ] { 0 }
Constant [ integer SWOOLE_REDIS_MODE_PIPELINE ] { 1 }
Constant [ integer SWOOLE_REDIS_TYPE_NOT_FOUND ] { 0 }
@@ -99,11 +99,6 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Parameters [0] {
}
}
- Function [ <internal:swoole> function swoole_clear_dns_cache ] {
-
- - Parameters [0] {
- }
- }
Function [ <internal:swoole> function swoole_last_error ] {
- Parameters [0] {
@@ -294,7 +289,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Parameters [4] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
@@ -2474,7 +2469,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Parameters [4] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
@@ -2888,7 +2883,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -2947,6 +2942,12 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
}
}
+ Method [ <internal:swoole> public method recycle ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method clear ] {
- Parameters [0] {
@@ -3021,7 +3022,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Parameters [4] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
@@ -3625,7 +3626,7 @@ Extension [ <persistent> extension #127 swoole version 2.0.5 ] {
- Parameters [4] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
diff --git a/php-pecl-swoole-dev.spec b/php-pecl-swoole-dev.spec
index 8992335..96ce00a 100644
--- a/php-pecl-swoole-dev.spec
+++ b/php-pecl-swoole-dev.spec
@@ -30,15 +30,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.5
+Version: 2.0.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-pr992.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 5.5
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
@@ -133,7 +131,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%patch0 -p1 -b .pr992
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -163,6 +160,8 @@ EOF
%build
+%{?dtsenable}
+
peclbuild() {
%configure \
--with-swoole \
@@ -192,6 +191,8 @@ peclbuild %{_bindir}/zts-php-config
%install
+%{?dtsenable}
+
make -C NTS \
install INSTALL_ROOT=%{buildroot}
@@ -269,6 +270,9 @@ cd ../ZTS
%changelog
+* Tue Jan 24 2017 Remi Collet <remi@fedoraproject.org> - 2.0.6-1
+- Update to 2.0.6 (beta)
+
* Fri Dec 30 2016 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
- Update to 2.0.5 (beta)
- raise dependency on PHP 5.5
diff --git a/swoole-pr992.patch b/swoole-pr992.patch
deleted file mode 100644
index a5788d3..0000000
--- a/swoole-pr992.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From dc26ffb786701033cb2fe7eae01ccb09a5f829b1 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 30 Dec 2016 19:32:47 +0100
-Subject: [PATCH] another fix for ZTS
-
----
- swoole_redis_coro.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/swoole_redis_coro.c b/swoole_redis_coro.c
-index a0a650e..28b907c 100755
---- a/swoole_redis_coro.c
-+++ b/swoole_redis_coro.c
-@@ -3732,6 +3732,9 @@ void swoole_redis_coro_onClose(const redisAsyncContext *c, int status)
-
- static int swoole_redis_onError(swReactor *reactor, swEvent *event)
- {
-+#if PHP_MAJOR_VERSION < 7
-+ TSRMLS_FETCH_FROM_CTX(sw_thread_ctx ? sw_thread_ctx : NULL);
-+#endif
- swRedisClient *redis = event->socket->object;
- redisAsyncContext *c = redis->context;
- zend_update_property_long(swoole_redis_coro_class_entry_ptr, redis->object, ZEND_STRL("errCode"), c->err TSRMLS_CC);