summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-25 08:27:56 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-25 08:27:56 +0200
commitc011c7457194b1ccdc41c81ae349b4dfb7f73062 (patch)
treea13559f0b8c30152a9d51a6af968e870d86cfca3
parent12388c5074f4c1a3c2cda80d6ca2d6007ee17361 (diff)
php-pecl-swoole: 1.8.13
-rw-r--r--REFLECTION23
-rw-r--r--php-pecl-swoole.spec17
2 files changed, 23 insertions, 17 deletions
diff --git a/REFLECTION b/REFLECTION
index 15062b5..2f73fb5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
+Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.12 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.13 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -198,18 +198,18 @@ Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
Function [ <internal:swoole> function swoole_client_select ] {
- Parameters [4] {
- Parameter #0 [ <required> $read_array ]
- Parameter #1 [ <required> $write_array ]
- Parameter #2 [ <required> $error_array ]
+ Parameter #0 [ <required> &$read_array ]
+ Parameter #1 [ <required> &$write_array ]
+ Parameter #2 [ <required> &$error_array ]
Parameter #3 [ <optional> $timeout ]
}
}
Function [ <internal:swoole> function swoole_select ] {
- Parameters [4] {
- Parameter #0 [ <required> $read_array ]
- Parameter #1 [ <required> $write_array ]
- Parameter #2 [ <required> $error_array ]
+ Parameter #0 [ <required> &$read_array ]
+ Parameter #1 [ <required> &$write_array ]
+ Parameter #2 [ <required> &$error_array ]
Parameter #3 [ <optional> $timeout ]
}
}
@@ -958,13 +958,16 @@ Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
- Static properties [0] {
}
- - Static methods [5] {
+ - Static methods [6] {
Method [ <internal:swoole> static public method wait ] {
}
Method [ <internal:swoole> static public method signal ] {
}
+ Method [ <internal:swoole> static public method alarm ] {
+ }
+
Method [ <internal:swoole> static public method kill ] {
}
@@ -2009,7 +2012,7 @@ Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 53a0a05..13dd5b3 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -34,8 +34,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.12
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.8.13
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -59,13 +59,13 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-sockets%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
@@ -268,6 +268,9 @@ cd ../ZTS
%changelog
+* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 1.8.13-1
+- Update to 1.8.13
+
* Fri Sep 30 2016 Remi Collet <remi@fedoraproject.org> - 1.8.12-1
- Update to 1.8.12