summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-30 08:24:50 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-30 08:24:50 +0200
commit12388c5074f4c1a3c2cda80d6ca2d6007ee17361 (patch)
tree76f5b4c26dcdf41edcce99c54218ee1fce2635bd
parent22487b845f687bd3724221bbfb697d000f6da3a1 (diff)
php-pecl-swoole: 1.8.12
-rw-r--r--REFLECTION79
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 78 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 4cacd51..15062b5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
+Extension [ <persistent> extension #123 swoole version 1.8.12 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -24,7 +24,7 @@ Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
Constant [ integer SWOOLE_PROCESS ] { 3 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
Constant [ integer SWOOLE_IPC_MSGQUEUE ] { 2 }
- Constant [ integer SWOOLE_IPC_CHANNEL ] { 3 }
+ Constant [ integer SWOOLE_IPC_PREEMPTIVE ] { 3 }
Constant [ integer SWOOLE_SOCK_TCP ] { 1 }
Constant [ integer SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ integer SWOOLE_SOCK_UDP ] { 2 }
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.11 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.12 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -239,7 +239,7 @@ Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
}
}
- - Classes [21] {
+ - Classes [22] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -642,6 +642,75 @@ Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
}
}
+ Class [ <internal:swoole> class swoole_async ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [6] {
+ Method [ <internal:swoole> static public method read ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $chunk_size ]
+ Parameter #3 [ <optional> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method write ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $offset ]
+ Parameter #3 [ <optional> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method readFile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method writeFile ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method dnsLookup ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <required> $content ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $settings ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> <iterateable> class swoole_connection_iterator implements Iterator, Traversable, Countable ] {
- Constants [0] {
@@ -1940,7 +2009,7 @@ Extension [ <persistent> extension #118 swoole version 1.8.11 ] {
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 114eb94..53a0a05 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -34,7 +34,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.11
+Version: 1.8.12
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -268,6 +268,9 @@ cd ../ZTS
%changelog
+* Fri Sep 30 2016 Remi Collet <remi@fedoraproject.org> - 1.8.12-1
+- Update to 1.8.12
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.8.11-2
- rebuild for PHP 7.1 new API version