summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-26 11:00:21 +0200
committerRemi Collet <remi@remirepo.net>2017-09-26 11:00:21 +0200
commit94627b3e6af2b540367e393de5c7117e6dbc99fa (patch)
tree8d45ee0f4d4917f9bbe6461e16a5cc4fd114b914
parent41431f181c9101db6f3328e2ceadb76a77ccd54a (diff)
v1.9.21
-rw-r--r--REFLECTION160
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 150 insertions, 15 deletions
diff --git a/REFLECTION b/REFLECTION
index 419a491..fd1902a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.21 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.20 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.21 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -265,7 +265,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
- - Classes [29] {
+ - Classes [30] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -309,7 +309,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [39] {
+ - Methods [41] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -609,6 +609,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Parameter #1 [ <required> $uid ]
}
}
+
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
}
}
@@ -969,7 +975,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $setting ]
}
- - Methods [5] {
+ - Methods [7] {
Method [ <internal:swoole, ctor> private method __construct ] {
- Parameters [0] {
@@ -997,6 +1003,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
+
Method [ <internal:swoole> public method getSocket ] {
- Parameters [0] {
@@ -1429,7 +1441,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $id ]
}
- - Methods [14] {
+ - Methods [15] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -1445,6 +1457,13 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole> public method setTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $seconds ]
+ }
+ }
+
Method [ <internal:swoole> public method useQueue ] {
- Parameters [2] {
@@ -1546,7 +1565,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
- Properties [0] {
}
- - Methods [21] {
+ - Methods [23] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1665,6 +1684,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
+
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -1838,7 +1863,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [10] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1894,6 +1919,77 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Parameter #1 [ <required> $new_value ]
}
}
+
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_atomic_long ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $add_value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $sub_value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method get ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method cmpset ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $cmp_value ]
+ Parameter #1 [ <required> $new_value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
}
}
@@ -1942,7 +2038,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $setting ]
}
- - Methods [39] {
+ - Methods [41] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1957,6 +2053,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method __wakeup ] {
+ }
+
Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
- Parameters [4] {
@@ -2263,7 +2365,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $trailer ]
}
- - Methods [11] {
+ - Methods [13] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -2351,6 +2453,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -2382,13 +2490,19 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $tmpfiles ]
}
- - Methods [2] {
+ - Methods [4] {
Method [ <internal:swoole> public method rawcontent ] {
- Parameters [0] {
}
}
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -2411,7 +2525,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [12] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -2481,6 +2595,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:swoole> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole> public method __wakeup ] {
+ }
}
}
@@ -2545,7 +2665,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $setting ]
}
- - Methods [40] {
+ - Methods [42] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -2577,6 +2697,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_http_server, prototype swoole_server> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_http_server, prototype swoole_server> public method __wakeup ] {
+ }
+
Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
- Parameters [4] {
@@ -3527,7 +3653,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [40] {
+ - Methods [42] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method start ] {
- Parameters [0] {
@@ -3837,6 +3963,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
Parameter #1 [ <required> $uid ]
}
}
+
+ Method [ <internal:swoole, inherits swoole_server> public method __sleep ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method __wakeup ] {
+ }
}
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 9a6a61d..08d8dfd 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,7 +32,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.20
+Version: 1.9.21
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -312,6 +312,9 @@ cd ../ZTS
%changelog
+* Tue Sep 26 2017 Remi Collet <remi@remirepo.net> - 1.9.21-1
+- Update to 1.9.21
+
* Tue Aug 29 2017 Remi Collet <remi@remirepo.net> - 1.9.20-1
- Update to 1.9.20