summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-29 15:18:41 +0200
committerRemi Collet <remi@remirepo.net>2017-08-29 15:18:41 +0200
commit41431f181c9101db6f3328e2ceadb76a77ccd54a (patch)
tree7544c841430c0d4960effaca4448bc2247c7b4e9
parentffcbe45fc755ae7ec8878aabcade5e97503cbd8f (diff)
v1.9.20
-rw-r--r--REFLECTION346
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 327 insertions, 24 deletions
diff --git a/REFLECTION b/REFLECTION
index f3c9901..419a491 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.20 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.18 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.20 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -265,7 +265,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
- - Classes [28] {
+ - Classes [29] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -277,7 +277,36 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [29] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
}
- Methods [39] {
@@ -922,7 +951,22 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [15] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandShake ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $onOpen ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $setting ]
}
- Methods [5] {
@@ -976,11 +1020,21 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [14] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
Property [ <default> public $reuseCount ]
+ Property [ <default> public $type ]
+ Property [ <default> public $id ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onSSLReady ]
}
- Methods [22] {
@@ -1151,9 +1205,26 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [19] {
+ Property [ <default> public $type ]
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
+ Property [ <default> public $statusCode ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $requestMethod ]
+ Property [ <default> public $requestHeaders ]
+ Property [ <default> public $requestBody ]
+ Property [ <default> public $uploadFiles ]
+ Property [ <default> public $set_cookie_headers ]
+ Property [ <default> public $downloadFile ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $cookies ]
+ Property [ <default> public $body ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $onClose ]
}
- Methods [17] {
@@ -1349,7 +1420,13 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
- - Properties [0] {
+ - Properties [6] {
+ Property [ <default> public $pipe ]
+ Property [ <default> public $callback ]
+ Property [ <default> public $msgQueueId ]
+ Property [ <default> public $msgQueueKey ]
+ Property [ <default> public $pid ]
+ Property [ <default> public $id ]
}
- Methods [14] {
@@ -1452,7 +1529,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
- Class [ <internal:swoole> <iterateable> class swoole_table implements Iterator, Traversable, Countable ] {
+ Class [ <internal:swoole> <iterateable> class swoole_table implements ArrayAccess, Iterator, Traversable, Countable ] {
- Constants [3] {
Constant [ integer TYPE_INT ] { 1 }
@@ -1469,11 +1546,12 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [21] {
Method [ <internal:swoole, ctor> public method __construct ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $table_size ]
+ Parameter #1 [ <optional> $conflict_proportion ]
}
}
@@ -1529,9 +1607,8 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
Method [ <internal:swoole> public method exist ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $field ]
}
}
@@ -1553,6 +1630,41 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
+ Method [ <internal:swoole> public method getMemorySize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -1585,6 +1697,60 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
+ Class [ <internal:swoole> class swoole_table_row implements ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $key ]
+ Property [ <default> public $value ]
+ }
+
+ - Methods [5] {
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_lock ] {
- Constants [5] {
@@ -1742,8 +1908,38 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ <default> private $global ]
+ - Properties [31] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandshake ]
+ Property [ <default> public $setting ]
}
- Methods [39] {
@@ -2060,7 +2256,11 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [4] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $header ]
+ Property [ <default> public $cookie ]
+ Property [ <default> public $trailer ]
}
- Methods [11] {
@@ -2170,7 +2370,16 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [9] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $header ]
+ Property [ <default> public $server ]
+ Property [ <default> public $request ]
+ Property [ <default> public $cookie ]
+ Property [ <default> public $get ]
+ Property [ <default> public $files ]
+ Property [ <default> public $post ]
+ Property [ <default> public $tmpfiles ]
}
- Methods [2] {
@@ -2302,7 +2511,38 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
- - Properties [0] {
+ - Properties [31] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandshake ]
+ Property [ <default> public $setting ]
}
- Methods [40] {
@@ -2653,11 +2893,18 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [11] {
+ Property [ <default> public $serverInfo ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $connected ]
Property [ <default> public $errno ]
Property [ <default> public $connect_errno ]
+ Property [ <default> public $error ]
+ Property [ <default> public $connect_error ]
Property [ <default> public $insert_id ]
Property [ <default> public $affected_rows ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onClose ]
}
- Methods [11] {
@@ -2887,11 +3134,23 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [16] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
Property [ <default> public $reuseCount ]
+ Property [ <default> public $type ]
+ Property [ <default> public $id ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onSSLReady ]
+ Property [ <default> public $requestHeaders ]
+ Property [ <default> public $cookies ]
}
- Methods [33] {
@@ -3087,7 +3346,10 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [3] {
+ Property [ <default> public $statusCode ]
+ Property [ <default> public $body ]
+ Property [ <default> public $streamId ]
}
- Methods [0] {
@@ -3143,7 +3405,16 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [9] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $errCode ]
+ Property [ <default> public $errMsg ]
}
- Methods [7] {
@@ -3224,7 +3495,36 @@ Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
}
}
- - Properties [0] {
+ - Properties [29] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
}
- Methods [40] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 0245851..9a6a61d 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,7 +32,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.19
+Version: 1.9.20
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -312,6 +312,9 @@ cd ../ZTS
%changelog
+* Tue Aug 29 2017 Remi Collet <remi@remirepo.net> - 1.9.20-1
+- Update to 1.9.20
+
* Tue Aug 29 2017 Remi Collet <remi@remirepo.net> - 1.9.19-1
- Update to 1.9.19
- open https://github.com/swoole/swoole-src/issues/1337