summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-22 09:42:23 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-22 09:42:23 +0100
commit193152977d08cc8eaa161d52d9abd1654cc362f3 (patch)
treebf3c3e961441028da92ea2eefc5eb828232e7d46
parentc011c7457194b1ccdc41c81ae349b4dfb7f73062 (diff)
php-pecl-swoole: 1.9.0
-rw-r--r--REFLECTION493
-rw-r--r--php-pecl-swoole.spec9
2 files changed, 481 insertions, 21 deletions
diff --git a/REFLECTION b/REFLECTION
index 2f73fb5..94e1e90 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
+Extension [ <persistent> extension #125 swoole version 1.9.0 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.13 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.0 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -81,8 +81,19 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Functions {
Function [ <internal:swoole> function swoole_version ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:swoole> function swoole_cpu_num ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:swoole> function swoole_clear_dns_cache ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:swoole> function swoole_event_add ] {
@@ -239,7 +250,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
}
}
- - Classes [22] {
+ - Classes [26] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -309,7 +320,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $from_id ]
+ Parameter #2 [ <optional> $reactor_id ]
}
}
@@ -440,7 +451,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Method [ <internal:swoole> public method heartbeat ] {
- Parameters [1] {
- Parameter #0 [ <required> $from_id ]
+ Parameter #0 [ <required> $reactor_id ]
}
}
@@ -448,7 +459,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -464,7 +475,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -764,6 +775,63 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
}
}
+ Class [ <internal:swoole> class swoole_exception extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_server_port ] {
- Constants [0] {
@@ -817,7 +885,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Property [ <default> public $reuse ]
}
- - Methods [21] {
+ - Methods [22] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -836,6 +904,9 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Method [ <internal:swoole> public method send ] {
}
+ Method [ <internal:swoole> public method pipe ] {
+ }
+
Method [ <internal:swoole> public method sendfile ] {
}
@@ -1297,7 +1368,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $from_id ]
+ Parameter #2 [ <optional> $reactor_id ]
}
}
@@ -1428,7 +1499,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
- Parameter #0 [ <required> $from_id ]
+ Parameter #0 [ <required> $reactor_id ]
}
}
@@ -1436,7 +1507,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -1452,7 +1523,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -1727,7 +1798,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [3] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
- Parameter #2 [ <optional> $from_id ]
+ Parameter #2 [ <optional> $reactor_id ]
}
}
@@ -1851,7 +1922,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
- Parameter #0 [ <required> $from_id ]
+ Parameter #0 [ <required> $reactor_id ]
}
}
@@ -1859,7 +1930,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -1875,7 +1946,7 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
- Parameters [2] {
Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $from_id ]
+ Parameter #1 [ <required> $reactor_id ]
}
}
@@ -2075,6 +2146,83 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
}
}
+ Class [ <internal:swoole> class swoole_mmap ] {
+
+ - Constants [2] {
+ Constant [ integer MAP_SHARED ] { 1 }
+ Constant [ integer MAP_PRIVATE ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:swoole> static public method open ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <optional> $size ]
+ Parameter #2 [ <optional> $offset ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_channel ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $size ]
+ }
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole> public method pop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method stats ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_redis ] {
- Constants [0] {
@@ -2125,6 +2273,319 @@ Extension [ <persistent> extension #122 swoole version 1.8.13 ] {
}
}
}
+
+ Class [ <internal:swoole> class swoole_redis_server extends swoole_server ] {
+
+ - Constants [7] {
+ Constant [ integer NIL ] { 1 }
+ Constant [ integer ERROR ] { 0 }
+ Constant [ integer STATUS ] { 2 }
+ Constant [ integer INT ] { 3 }
+ Constant [ integer STRING ] { 4 }
+ Constant [ integer SET ] { 5 }
+ Constant [ integer MAP ] { 6 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:swoole> static public method format ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $type ]
+ Parameter #1 [ <optional> $value ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [39] {
+ Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method start ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method setHandler ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $command ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $number_of_string_param ]
+ Parameter #3 [ <optional> $type_of_array_param ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <optional> $mode ]
+ Parameter #3 [ <optional> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method on ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $cb ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $zset ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $send_data ]
+ Parameter #2 [ <optional> $reactor_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method sendto ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $ip ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <optional> $send_data ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method sendwait ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <required> $send_data ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method exist ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method protect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <optional> $is_protected ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <required> $filename ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method confirm ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method pause ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method resume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method task ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <required> $worker_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method taskwait ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $timeout ]
+ Parameter #2 [ <optional> $worker_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method taskWaitMulti ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tasks ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method finish ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method reload ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method shutdown ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method getLastError ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $reactor_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $reactor_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method connection_list ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $start_fd ]
+ Parameter #1 [ <required> $find_count ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method getClientInfo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $reactor_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method getClientList ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $start_fd ]
+ Parameter #1 [ <required> $find_count ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method after ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method tick ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method clearTimer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method sendMessage ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addProcess ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method stats ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method getSocket ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method bind ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $uid ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 13dd5b3..272e721 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -7,11 +7,7 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-swoole
%endif
@@ -34,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.13
+Version: 1.9.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -268,6 +264,9 @@ cd ../ZTS
%changelog
+* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 1.9.0-1
+- Update to 1.9.0
+
* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 1.8.13-1
- Update to 1.8.13