summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-04 10:04:13 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-04 10:04:13 +0100
commit13f0408c5a77d83821c32fd447de719f19d57a02 (patch)
treebd120c4a9bf033135d8007e295f8c03dc12d099a
parent3c23f3d805486704c3af0e5d4db9b07edbea4c74 (diff)
php-pecl-swoole: 1.8.1
-rw-r--r--REFLECTION55
-rw-r--r--php-pecl-swoole.spec6
2 files changed, 56 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 74aa820..26f6ee2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
+Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -7,6 +7,9 @@ Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
Entry [ swoole.display_errors <ALL> ]
Current = 'On'
}
+ Entry [ swoole.use_namespace <SYSTEM> ]
+ Current = 'Off'
+ }
Entry [ swoole.message_queue_key <ALL> ]
Current = '0'
}
@@ -42,7 +45,7 @@ Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
Constant [ integer SWOOLE_KEEP ] { 4096 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.0 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.1 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -220,7 +223,7 @@ Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
}
}
- - Classes [14] {
+ - Classes [15] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -469,6 +472,47 @@ Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
}
}
+ Class [ <internal:swoole> class swoole_timer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:swoole> static public method tick ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method after ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method clear ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> <iterateable> class swoole_connection_iterator implements Iterator, Traversable, Countable ] {
- Constants [0] {
@@ -536,7 +580,10 @@ Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
+ Method [ <internal:swoole, ctor> private method __construct ] {
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index af942ca..f98c995 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -31,7 +31,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.0
+Version: 1.8.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -141,6 +141,7 @@ extension=%{pecl_name}.so
; Configuration
;swoole.aio_thread_num = 2
;swoole.display_errors = On
+;swoole.use_namespace = Off
;swoole.message_queue_key = 0
;swoole.unixsock_buffer_size = 8388608
EOF
@@ -256,6 +257,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 1.8.1-1
+- Update to 1.8.1 (stable)
+
* Wed Jan 27 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-1
- Update to 1.8.0 (stable)