summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-27 10:21:07 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-27 10:21:07 +0100
commit3c23f3d805486704c3af0e5d4db9b07edbea4c74 (patch)
treed2bab4e3c89113969a82e88bbb5c9d4b480b5ada
parente44202279b4c7785ddf0e7d90c2a4320a444e7a0 (diff)
php-pecl-swoole: 1.8.0
-rw-r--r--REFLECTION554
-rw-r--r--php-pecl-swoole.spec16
-rw-r--r--swoole-pr462.patch25
3 files changed, 268 insertions, 327 deletions
diff --git a/REFLECTION b/REFLECTION
index 8340c23..74aa820 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
+Extension [ <persistent> extension #167 swoole version 1.8.0 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
Constant [ integer SWOOLE_KEEP ] { 4096 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.22 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.0 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -68,217 +68,141 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
Function [ <internal:swoole> function swoole_cpu_num ] {
}
- Function [ <internal:swoole> function swoole_server_create ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $serv_host ]
- Parameter #1 [ <required> $serv_port ]
- Parameter #2 [ <optional> $serv_mode ]
- Parameter #3 [ <optional> $sock_type ]
- }
- }
- Function [ <internal:swoole> function swoole_server_set ] {
+ Function [ <internal:swoole> function swoole_event_add ] {
- Parameters [2] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $zset ]
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $cb ]
}
}
- Function [ <internal:swoole> function swoole_server_start ] {
+ Function [ <internal:swoole> function swoole_event_set ] {
+ }
+ Function [ <internal:swoole> function swoole_event_del ] {
- Parameters [1] {
- Parameter #0 [ <required> swoole_server $zobject ]
+ Parameter #0 [ <required> $fd ]
}
}
- Function [ <internal:swoole> function swoole_server_send ] {
+ Function [ <internal:swoole> function swoole_event_exit ] {
- - Parameters [4] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $conn_fd ]
- Parameter #2 [ <required> $send_data ]
- Parameter #3 [ <optional> $from_id ]
+ - Parameters [0] {
}
}
- Function [ <internal:swoole> function swoole_server_sendfile ] {
+ Function [ <internal:swoole> function swoole_event_wait ] {
- - Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $conn_fd ]
- Parameter #2 [ <required> $filename ]
+ - Parameters [0] {
}
}
- Function [ <internal:swoole> function swoole_server_close ] {
+ Function [ <internal:swoole> function swoole_event_write ] {
- Parameters [2] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $fd ]
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $data ]
}
}
- Function [ <internal:swoole> function swoole_server_handler ] {
+ Function [ <internal:swoole> function swoole_event_defer ] {
- - Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $ha_name ]
- Parameter #2 [ <required> $cb ]
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
}
}
- Function [ <internal:swoole> function swoole_server_on ] {
+ Function [ <internal:swoole> function swoole_timer_after ] {
- Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $ha_name ]
- Parameter #2 [ <required> $cb ]
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
- Function [ <internal:swoole> function swoole_server_addlisten ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $host ]
- Parameter #2 [ <required> $port ]
- Parameter #3 [ <required> $sock_type ]
- }
- }
- Function [ <internal:swoole> function swoole_server_addtimer ] {
+ Function [ <internal:swoole> function swoole_timer_tick ] {
- Parameters [2] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $interval ]
- }
- }
- Function [ <internal:swoole> function swoole_server_gettimer ] {
- }
- Function [ <internal:swoole> function swoole_server_task ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $worker_id ]
- }
- }
- Function [ <internal:swoole> function swoole_server_taskwait ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $timeout ]
- Parameter #3 [ <optional> $worker_id ]
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
}
}
- Function [ <internal:swoole> function swoole_server_finish ] {
+ Function [ <internal:swoole> function swoole_timer_clear ] {
- - Parameters [2] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $data ]
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
}
}
- Function [ <internal:swoole> function swoole_server_reload ] {
+ Function [ <internal:swoole> function swoole_async_set ] {
- Parameters [1] {
- Parameter #0 [ <required> swoole_server $zobject ]
+ Parameter #0 [ <required> $settings ]
}
}
- Function [ <internal:swoole> function swoole_server_shutdown ] {
+ Function [ <internal:swoole> function swoole_async_read ] {
- - Parameters [1] {
- Parameter #0 [ <required> swoole_server $zobject ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $chunk_size ]
+ Parameter #3 [ <optional> $offset ]
}
}
- Function [ <internal:swoole> function swoole_server_heartbeat ] {
+ Function [ <internal:swoole> function swoole_async_write ] {
- - Parameters [2] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $from_id ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $offset ]
+ Parameter #3 [ <optional> $callback ]
}
}
- Function [ <internal:swoole> function swoole_connection_info ] {
+ Function [ <internal:swoole> function swoole_async_readfile ] {
- - Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $fd ]
- Parameter #2 [ <optional> $from_id ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $callback ]
}
}
- Function [ <internal:swoole> function swoole_connection_list ] {
+ Function [ <internal:swoole> function swoole_async_writefile ] {
- Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $start_fd ]
- Parameter #2 [ <required> $find_count ]
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $content ]
+ Parameter #2 [ <optional> $callback ]
}
}
- Function [ <internal:swoole> function swoole_event_add ] {
+ Function [ <internal:swoole> function swoole_async_dns_lookup ] {
- Parameters [2] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $cb ]
+ Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <required> $content ]
}
}
- Function [ <internal:swoole> function swoole_event_set ] {
- }
- Function [ <internal:swoole> function swoole_event_del ] {
+ Function [ <internal:swoole> function swoole_client_select ] {
- - Parameters [1] {
- Parameter #0 [ <required> $fd ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $read_array ]
+ Parameter #1 [ <required> $write_array ]
+ Parameter #2 [ <required> $error_array ]
+ Parameter #3 [ <optional> $timeout ]
}
}
- Function [ <internal:swoole> function swoole_event_exit ] {
+ Function [ <internal:swoole> function swoole_set_process_name ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $process_name ]
}
}
- Function [ <internal:swoole> function swoole_event_wait ] {
+ Function [ <internal:swoole> function swoole_get_local_ip ] {
- Parameters [0] {
}
}
- Function [ <internal:swoole> function swoole_event_write ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $data ]
- }
- }
- Function [ <internal:swoole> function swoole_timer_add ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $interval ]
- Parameter #1 [ <required> $cb ]
- }
- }
- Function [ <internal:swoole> function swoole_timer_del ] {
+ Function [ <internal:swoole> function swoole_strerror ] {
- Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ Parameter #0 [ <required> $errno ]
}
}
- Function [ <internal:swoole> function swoole_timer_after ] {
- }
- Function [ <internal:swoole> function swoole_timer_tick ] {
- }
- Function [ <internal:swoole> function swoole_timer_clear ] {
- }
- Function [ <internal:swoole> function swoole_async_set ] {
- }
- Function [ <internal:swoole> function swoole_async_read ] {
- }
- Function [ <internal:swoole> function swoole_async_write ] {
- }
- Function [ <internal:swoole> function swoole_async_readfile ] {
- }
- Function [ <internal:swoole> function swoole_async_writefile ] {
- }
- Function [ <internal:swoole> function swoole_async_dns_lookup ] {
- }
- Function [ <internal:swoole> function swoole_client_select ] {
- }
- Function [ <internal:swoole> function swoole_set_process_name ] {
- }
- Function [ <internal:swoole> function swoole_get_local_ip ] {
- }
- Function [ <internal:swoole> function swoole_strerror ] {
- }
Function [ <internal:swoole> function swoole_errno ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:swoole> function swoole_mysql_query ] {
@@ -296,7 +220,7 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- - Classes [13] {
+ - Classes [14] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -311,7 +235,7 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
- Properties [0] {
}
- - Methods [35] {
+ - Methods [32] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -322,6 +246,32 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole> public method addlistener ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole> public method on ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $cb ]
+ }
+ }
+
Method [ <internal:swoole> public method set ] {
- Parameters [1] {
@@ -368,6 +318,14 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole> public method protect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <optional> $is_protected ]
+ }
+ }
+
Method [ <internal:swoole> public method sendfile ] {
- Parameters [2] {
@@ -407,24 +365,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole> public method addlistener ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
- Method [ <internal:swoole> public method listen ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
Method [ <internal:swoole> public method reload ] {
- Parameters [0] {
@@ -437,13 +377,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole> public method hbcheck ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $from_id ]
- }
- }
-
Method [ <internal:swoole> public method heartbeat ] {
- Parameters [1] {
@@ -451,22 +384,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole> public method handler ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ha_name ]
- Parameter #1 [ <required> $cb ]
- }
- }
-
- Method [ <internal:swoole> public method on ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ha_name ]
- Parameter #1 [ <required> $cb ]
- }
- }
-
Method [ <internal:swoole> public method connection_info ] {
- Parameters [2] {
@@ -499,30 +416,35 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole> public method addtimer ] {
+ Method [ <internal:swoole> public method after ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
- Method [ <internal:swoole> public method deltimer ] {
+ Method [ <internal:swoole> public method tick ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
}
}
- Method [ <internal:swoole> public method gettimer ] {
- }
+ Method [ <internal:swoole> public method clearTimer ] {
- Method [ <internal:swoole> public method after ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
}
- Method [ <internal:swoole> public method tick ] {
- }
+ Method [ <internal:swoole> public method defer ] {
- Method [ <internal:swoole> public method clearTimer ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
}
Method [ <internal:swoole> public method sendmessage ] {
@@ -600,6 +522,32 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Class [ <internal:swoole> class swoole_server_port ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method set ] {
+ }
+
+ Method [ <internal:swoole> public method on ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_client ] {
- Constants [4] {
@@ -615,9 +563,10 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
+ Property [ <default> public $reuse ]
}
- Methods [16] {
@@ -699,7 +648,7 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -709,6 +658,9 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
Method [ <internal:swoole> public method useQueue ] {
}
+ Method [ <internal:swoole> public method freeQueue ] {
+ }
+
Method [ <internal:swoole> public method start ] {
}
@@ -969,7 +921,7 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
Property [ <default> private $global ]
}
- - Methods [36] {
+ - Methods [33] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -994,6 +946,24 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method set ] {
- Parameters [1] {
@@ -1034,6 +1004,14 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method protect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <optional> $is_protected ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
- Parameters [2] {
@@ -1073,24 +1051,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
- Method [ <internal:swoole, inherits swoole_server> public method listen ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method reload ] {
- Parameters [0] {
@@ -1103,13 +1063,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method hbcheck ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $from_id ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
@@ -1117,14 +1070,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method handler ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ha_name ]
- Parameter #1 [ <required> $cb ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
- Parameters [2] {
@@ -1157,30 +1102,35 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method addtimer ] {
+ Method [ <internal:swoole, inherits swoole_server> public method after ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
- Method [ <internal:swoole, inherits swoole_server> public method deltimer ] {
+ Method [ <internal:swoole, inherits swoole_server> public method tick ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
}
}
- Method [ <internal:swoole, inherits swoole_server> public method gettimer ] {
- }
+ Method [ <internal:swoole, inherits swoole_server> public method clearTimer ] {
- Method [ <internal:swoole, inherits swoole_server> public method after ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
}
- Method [ <internal:swoole, inherits swoole_server> public method tick ] {
- }
+ Method [ <internal:swoole, inherits swoole_server> public method defer ] {
- Method [ <internal:swoole, inherits swoole_server> public method clearTimer ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
}
Method [ <internal:swoole, inherits swoole_server> public method sendmessage ] {
@@ -1315,13 +1265,29 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [2] {
+ Method [ <internal:swoole> static public method pack ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $opcode ]
+ Parameter #2 [ <optional> $finish ]
+ Parameter #3 [ <optional> $mask ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
}
- Properties [0] {
}
- - Methods [37] {
+ - Methods [34] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1363,6 +1329,24 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method set ] {
- Parameters [1] {
@@ -1396,6 +1380,14 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method protect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <optional> $is_protected ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
- Parameters [2] {
@@ -1435,24 +1427,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
- Method [ <internal:swoole, inherits swoole_server> public method listen ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $sock_type ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method reload ] {
- Parameters [0] {
@@ -1465,13 +1439,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method hbcheck ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $from_id ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
@@ -1479,14 +1446,6 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method handler ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ha_name ]
- Parameter #1 [ <required> $cb ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
- Parameters [2] {
@@ -1519,30 +1478,35 @@ Extension [ <persistent> extension #166 swoole version 1.7.22 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method addtimer ] {
+ Method [ <internal:swoole, inherits swoole_server> public method after ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [3] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
- Method [ <internal:swoole, inherits swoole_server> public method deltimer ] {
+ Method [ <internal:swoole, inherits swoole_server> public method tick ] {
- - Parameters [1] {
- Parameter #0 [ <required> $interval ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $ms ]
+ Parameter #1 [ <required> $callback ]
}
}
- Method [ <internal:swoole, inherits swoole_server> public method gettimer ] {
- }
+ Method [ <internal:swoole, inherits swoole_server> public method clearTimer ] {
- Method [ <internal:swoole, inherits swoole_server> public method after ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
}
- Method [ <internal:swoole, inherits swoole_server> public method tick ] {
- }
+ Method [ <internal:swoole, inherits swoole_server> public method defer ] {
- Method [ <internal:swoole, inherits swoole_server> public method clearTimer ] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
}
Method [ <internal:swoole, inherits swoole_server> public method sendmessage ] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 02cc8b7..af942ca 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -31,16 +31,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.7.22
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.8.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# see https://github.com/swoole/swoole-src/pull/462
-Patch0: %{pecl_name}-pr462.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
@@ -63,6 +60,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -115,11 +114,11 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests, install examples as doc
sed -e 's/role="test"/role="src"/' \
-e '/examples/s/role="src"/role="doc"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr462
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -141,7 +140,7 @@ extension=%{pecl_name}.so
; Configuration
;swoole.aio_thread_num = 2
-;swoole.display_errors = 2
+;swoole.display_errors = On
;swoole.message_queue_key = 0
;swoole.unixsock_buffer_size = 8388608
EOF
@@ -257,6 +256,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 27 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-1
+- Update to 1.8.0 (stable)
+
* Thu Dec 31 2015 Remi Collet <remi@fedoraproject.org> - 1.7.22-2
- Update to 1.7.22 (new sources)
diff --git a/swoole-pr462.patch b/swoole-pr462.patch
deleted file mode 100644
index b6b52f9..0000000
--- a/swoole-pr462.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2a506ab42328dc8d9d1ad7ecb9cec23f1c04e2a2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 31 Dec 2015 09:11:21 +0100
-Subject: [PATCH] Use concat_function with PHP 7, fix #461
-
----
- swoole_http_client.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/swoole_http_client.c b/swoole_http_client.c
-index 8197d56..a6b358f 100644
---- a/swoole_http_client.c
-+++ b/swoole_http_client.c
-@@ -1024,7 +1024,11 @@ static int http_client_parser_on_body(php_http_parser *parser, const char *at, s
- zval *tmp;
- SW_MAKE_STD_ZVAL(tmp);
- SW_ZVAL_STRINGL(tmp, at, length, 1);
-+#if PHP_MAJOR_VERSION < 7
- add_string_to_string(body, body, tmp);
-+#else
-+ concat_function(body, body, tmp);
-+#endif
- sw_zval_ptr_dtor(&tmp);
-
- return 0;