summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-13 09:14:34 +0200
committerRemi Collet <remi@remirepo.net>2017-07-13 09:14:34 +0200
commit0d04dd098e5de6f89df11e112fb59f7cb328d9ee (patch)
tree445d50615676496600c0cdfea8adcaadcedce362
parent87e78ec4ebdaf96509a6a5743077c0e70693631a (diff)
v1.9.16
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-swoole.spec6
2 files changed, 14 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 39f622e..7b343f1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.15 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.16 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.15 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.15 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.16 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -1588,7 +1588,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.15 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [8] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1609,6 +1609,13 @@ Extension [ <persistent> extension #80 swoole version 1.9.15 ] {
}
}
+ Method [ <internal:swoole> public method lockwait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> public method trylock ] {
- Parameters [0] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 8835aa4..f30573a 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,7 +32,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.15
+Version: 1.9.16
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -189,7 +189,6 @@ peclbuild() {
%configure \
--with-swoole \
--enable-sockets \
- --enable-ringbuffer \
%if %{with_hiredis}
--enable-async-redis \
%endif
@@ -307,6 +306,9 @@ cd ../ZTS
%changelog
+* Thu Jul 13 2017 Remi Collet <remi@remirepo.net> - 1.9.16-1
+- Update to 1.9.16
+
* Tue Jul 4 2017 Remi Collet <remi@remirepo.net> - 1.9.15-1
- Update to 1.9.15