summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-04 11:07:49 +0200
committerRemi Collet <remi@remirepo.net>2017-07-04 11:07:49 +0200
commit87e78ec4ebdaf96509a6a5743077c0e70693631a (patch)
treefb3e5e9fd8c726aab7349658b9160d282d001baa
parent8887a3e87950fee82f501102ee8db384e6cf0ea4 (diff)
v1.9.15
-rw-r--r--REFLECTION49
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 48 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index d1707dd..39f622e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.15 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.14 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.15 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -1649,7 +1649,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [8] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1684,6 +1684,20 @@ Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
}
}
+ Method [ <internal:swoole> public method wait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method wakeup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $count ]
+ }
+ }
+
Method [ <internal:swoole> public method cmpset ] {
- Parameters [2] {
@@ -2589,10 +2603,14 @@ Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [4] {
+ Property [ <default> public $errno ]
+ Property [ <default> public $connect_errno ]
+ Property [ <default> public $insert_id ]
+ Property [ <default> public $affected_rows ]
}
- - Methods [7] {
+ - Methods [10] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -2613,6 +2631,27 @@ Extension [ <persistent> extension #80 swoole version 1.9.14 ] {
}
}
+ Method [ <internal:swoole> public method begin ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> public method commit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> public method rollback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
Method [ <internal:swoole> public method escape ] {
- Parameters [2] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 7e9319a..8835aa4 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,7 +32,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.14
+Version: 1.9.15
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -307,6 +307,9 @@ cd ../ZTS
%changelog
+* Tue Jul 4 2017 Remi Collet <remi@remirepo.net> - 1.9.15-1
+- Update to 1.9.15
+
* Wed Jun 21 2017 Remi Collet <remi@remirepo.net> - 1.9.14-1
- Update to 1.9.14