summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-02 10:14:33 +0100
committerRemi Collet <remi@php.net>2023-02-02 10:14:33 +0100
commitb8e5e47e812e8292bbf4e3a5202f33dc07a92048 (patch)
tree76adc4a36f8c8017c91dd4cff581b73025aaa271
parent3d3cfdafc4621736731477cffb65bcd698fbc748 (diff)
update to 0.3.0
-rw-r--r--PHPINFO20
-rw-r--r--REFLECTION42
-rw-r--r--php-pecl-skywalking-agent.spec32
3 files changed, 69 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index d47c41a..44e9aa9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,14 +1,22 @@
skywalking_agent
-version => 0.2.0
+version => 0.3.0
authors => Apache Software Foundation:jmjoy <jmjoy@apache.org>:Yanlong He <heyanlong@apache.org>
Directive => Local Value => Master Value
-skywalking_agent.server_addr => http://127.0.0.1:11800 => http://127.0.0.1:11800
-skywalking_agent.enable => false => false
-skywalking_agent.log_file => /tmp/skywalking-agent.log => /tmp/skywalking-agent.log
-skywalking_agent.log_level => OFF => OFF
+skywalking_agent.enable => 0 => 0
skywalking_agent.skywalking_version => 8 => 8
-skywalking_agent.worker_threads => 0 => 0
+skywalking_agent.server_addr => 127.0.0.1:11800 => 127.0.0.1:11800
skywalking_agent.service_name => hello-skywalking => hello-skywalking
+skywalking_agent.worker_threads => 0 => 0
+skywalking_agent.log_level => OFF => OFF
+skywalking_agent.log_file => /tmp/skywalking-agent.log => /tmp/skywalking-agent.log
+skywalking_agent.runtime_dir => /tmp/skywalking-agent => /tmp/skywalking-agent
+skywalking_agent.authentication => no value => no value
+skywalking_agent.enable_tls => 0 => 0
+skywalking_agent.ssl_trusted_ca_path => no value => no value
+skywalking_agent.ssl_key_path => no value => no value
+skywalking_agent.ssl_cert_chain_path => no value => no value
+skywalking_agent.heartbeat_period => 30 => 30
+skywalking_agent.properties_report_period_factor => 10 => 10
diff --git a/REFLECTION b/REFLECTION
index 1326eb2..45b299d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,15 @@
-Extension [ <persistent> extension #122 skywalking_agent version <no_version> ] {
+Extension [ <persistent> extension #98 skywalking_agent version 0.3.0 ] {
- INI {
+ Entry [ skywalking_agent.enable <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ skywalking_agent.skywalking_version <SYSTEM> ]
+ Current = '8'
+ }
+ Entry [ skywalking_agent.server_addr <SYSTEM> ]
+ Current = '127.0.0.1:11800'
+ }
Entry [ skywalking_agent.service_name <SYSTEM> ]
Current = 'hello-skywalking'
}
@@ -10,17 +19,32 @@ Extension [ <persistent> extension #122 skywalking_agent version <no_version> ]
Entry [ skywalking_agent.log_level <SYSTEM> ]
Current = 'OFF'
}
- Entry [ skywalking_agent.skywalking_version <SYSTEM> ]
- Current = '8'
+ Entry [ skywalking_agent.log_file <SYSTEM> ]
+ Current = '/tmp/skywalking-agent.log'
}
- Entry [ skywalking_agent.enable <SYSTEM> ]
- Current = 'false'
+ Entry [ skywalking_agent.runtime_dir <SYSTEM> ]
+ Current = '/tmp/skywalking-agent'
}
- Entry [ skywalking_agent.server_addr <SYSTEM> ]
- Current = 'http://127.0.0.1:11800'
+ Entry [ skywalking_agent.authentication <SYSTEM> ]
+ Current = ''
}
- Entry [ skywalking_agent.log_file <SYSTEM> ]
- Current = '/tmp/skywalking-agent.log'
+ Entry [ skywalking_agent.enable_tls <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ skywalking_agent.ssl_trusted_ca_path <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ skywalking_agent.ssl_key_path <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ skywalking_agent.ssl_cert_chain_path <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ skywalking_agent.heartbeat_period <SYSTEM> ]
+ Current = '30'
+ }
+ Entry [ skywalking_agent.properties_report_period_factor <SYSTEM> ]
+ Current = '10'
}
}
diff --git a/php-pecl-skywalking-agent.spec b/php-pecl-skywalking-agent.spec
index e51fb13..5dce605 100644
--- a/php-pecl-skywalking-agent.spec
+++ b/php-pecl-skywalking-agent.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-skywalking-agent
#
-# Copyright (c) 2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2022-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -17,6 +17,7 @@
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
+## BUILD: Fedora and EL-9 using --enablerepo=stream
## TODO: issues
# bad role for documentation (role="src" instead of role="doc")
@@ -30,9 +31,9 @@
Summary: Apache SkyWalking PHP Agent
Name: %{?scl_prefix}php-pecl-skywalking-agent
-Version: 0.2.0
+Version: 0.3.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: ASL 2.0
+License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -125,17 +126,25 @@ cat > %{ini_name} << 'EOF'
extension=%{pecl_name}.so
; Configuration
-;skywalking_agent.server_addr = "http://127.0.0.1:11800"
-;skywalking_agent.enable = false
-;skywalking_agent.log_file = "/tmp/skywalking-agent.log"
-;skywalking_agent.log_level = OFF
+;skywalking_agent.enable = 0
;skywalking_agent.skywalking_version = 8
+;skywalking_agent.server_addr = 127.0.0.1:11800
+;skywalking_agent.service_name = hello-skywalking
;skywalking_agent.worker_threads = 0
-;skywalking_agent.service_name = "hello-skywalking"
+;skywalking_agent.log_level = OFF
+;skywalking_agent.log_file = /tmp/skywalking-agent.log
+;skywalking_agent.runtime_dir = /tmp/skywalking-agent
+;skywalking_agent.authentication =
+;skywalking_agent.enable_tls = 0
+;skywalking_agent.ssl_trusted_ca_path =
+;skywalking_agent.ssl_key_path =
+;skywalking_agent.ssl_cert_chain_path =
+;skywalking_agent.heartbeat_period = 30
+;skywalking_agent.properties_report_period_factor = 10
EOF
: Required rust version
-grep -h rust-version mycargo/*/Cargo.toml NTS/Cargo.toml | sort -u | tail -n 4
+grep -h rust-version mycargo/*/Cargo.toml NTS/Cargo.toml | sort -u | tail -n 8
%build
@@ -236,6 +245,9 @@ OPT="-n -d extension=curl.so -d extension=json.so"
%changelog
+* Thu Feb 2 2023 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+
* Mon Nov 28 2022 Remi Collet <remi@remirepo.net> - 0.2.0-1
- update to 0.2.0