summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-28 13:59:01 +0100
committerRemi Collet <remi@php.net>2022-11-28 13:59:01 +0100
commit3d3cfdafc4621736731477cffb65bcd698fbc748 (patch)
treea27fddb39f620df6f8b88c4dd82c09c20bfd0f74
parent8c8bf315198fcb3a3e921aa6c98599f6eb2fc011 (diff)
update to 0.2.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-skywalking-agent.spec21
3 files changed, 31 insertions, 24 deletions
diff --git a/PHPINFO b/PHPINFO
index c1ae5c6..d47c41a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,14 +1,14 @@
skywalking_agent
-version => 0.1.0
+version => 0.2.0
authors => Apache Software Foundation:jmjoy <jmjoy@apache.org>:Yanlong He <heyanlong@apache.org>
Directive => Local Value => Master Value
skywalking_agent.server_addr => http://127.0.0.1:11800 => http://127.0.0.1:11800
-skywalking_agent.skywalking_version => 8 => 8
-skywalking_agent.worker_threads => 0 => 0
+skywalking_agent.enable => false => false
skywalking_agent.log_file => /tmp/skywalking-agent.log => /tmp/skywalking-agent.log
skywalking_agent.log_level => OFF => OFF
+skywalking_agent.skywalking_version => 8 => 8
+skywalking_agent.worker_threads => 0 => 0
skywalking_agent.service_name => hello-skywalking => hello-skywalking
-skywalking_agent.enable => false => false
diff --git a/REFLECTION b/REFLECTION
index 3570ce4..1326eb2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,26 +1,34 @@
-Extension [ <persistent> extension #99 skywalking_agent version <no_version> ] {
+Extension [ <persistent> extension #122 skywalking_agent version <no_version> ] {
- INI {
- Entry [ skywalking_agent.skywalking_version <SYSTEM> ]
- Current = '8'
+ Entry [ skywalking_agent.service_name <SYSTEM> ]
+ Current = 'hello-skywalking'
}
Entry [ skywalking_agent.worker_threads <SYSTEM> ]
Current = '0'
}
- Entry [ skywalking_agent.service_name <SYSTEM> ]
- Current = 'hello-skywalking'
+ Entry [ skywalking_agent.log_level <SYSTEM> ]
+ Current = 'OFF'
}
- Entry [ skywalking_agent.server_addr <SYSTEM> ]
- Current = 'http://127.0.0.1:11800'
+ Entry [ skywalking_agent.skywalking_version <SYSTEM> ]
+ Current = '8'
}
Entry [ skywalking_agent.enable <SYSTEM> ]
Current = 'false'
}
+ Entry [ skywalking_agent.server_addr <SYSTEM> ]
+ Current = 'http://127.0.0.1:11800'
+ }
Entry [ skywalking_agent.log_file <SYSTEM> ]
Current = '/tmp/skywalking-agent.log'
}
- Entry [ skywalking_agent.log_level <SYSTEM> ]
- Current = 'OFF'
+ }
+
+ - Functions {
+ Function [ <internal:skywalking_agent> function skywalking_hack_swoole_on_request_please_do_not_use ] {
+
+ - Parameters [0] {
+ }
}
}
}
diff --git a/php-pecl-skywalking-agent.spec b/php-pecl-skywalking-agent.spec
index 946b9be..e51fb13 100644
--- a/php-pecl-skywalking-agent.spec
+++ b/php-pecl-skywalking-agent.spec
@@ -23,15 +23,14 @@
#=> fixed in prep
# no PHP 8.2 support
# broken build with new GCC 12 (Fedora 36+)
-# broken build with rust 1.58 (RHEL-8 and RHEL-9)
-# => 1.62 on 6.7 and 9.1
+# broken build with rust 1.62 (RHEL-8 and RHEL-9)
# no support for offline build
# => workaround with "cargo vendor"
Summary: Apache SkyWalking PHP Agent
Name: %{?scl_prefix}php-pecl-skywalking-agent
-Version: 0.1.0
+Version: 0.2.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
@@ -50,9 +49,9 @@ BuildRequires: devtoolset-6-toolchain
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: cargo >= 1.60
+BuildRequires: cargo >= 1.65
BuildRequires: rustfmt
BuildRequires: protobuf-compiler
BuildRequires: clang-devel
@@ -85,8 +84,6 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- -e '/"NOTICE"/s/role="src"/role="doc"/' \
- -e '/"README.md"/s/role="src"/role="doc"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
@@ -128,14 +125,13 @@ cat > %{ini_name} << 'EOF'
extension=%{pecl_name}.so
; Configuration
-;skywalking_agent.worker_threads = 0
-;skywalking_agent.service_name = "hello-skywalking"
;skywalking_agent.server_addr = "http://127.0.0.1:11800"
-;skywalking_agent.skywalking_version = 8
;skywalking_agent.enable = false
;skywalking_agent.log_file = "/tmp/skywalking-agent.log"
;skywalking_agent.log_level = OFF
-
+;skywalking_agent.skywalking_version = 8
+;skywalking_agent.worker_threads = 0
+;skywalking_agent.service_name = "hello-skywalking"
EOF
: Required rust version
@@ -240,6 +236,9 @@ OPT="-n -d extension=curl.so -d extension=json.so"
%changelog
+* Mon Nov 28 2022 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0
+
* Mon Oct 10 2022 Remi Collet <remi@remirepo.net> - 0.1.0-1
- initial package
- open https://github.com/apache/skywalking/pull/9754 Add PHP component