summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-13 07:58:07 +0200
committerRemi Collet <remi@remirepo.net>2021-04-13 07:58:07 +0200
commit0e1a7520db55334507eadf5c4ac86c49c9eba553 (patch)
treeca7cce76a369942fc4cb19a1c62b4a9221e02ec4
parent612c5f548cf85ca4cc68f5ee97f0c2d3254e2d5e (diff)
update to 0.1.2
drop patches merged upstream
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-simple-kafka-client.spec14
-rw-r--r--simple_kafka_client-skip.patch23
-rw-r--r--simple_kafka_client-version.patch22
5 files changed, 9 insertions, 56 deletions
diff --git a/PHPINFO b/PHPINFO
index b522e7a..dafb823 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
simple_kafka_client
kafka support => enabled
-version => 0.1.1
-build date => Jan 27 2021 00:00:00
+version => 0.1.2
+build date => Apr 13 2021 00:00:00
librdkafka version (runtime) => 1.6.1
librdkafka version (build) => 1.6.1.255
diff --git a/REFLECTION b/REFLECTION
index 917efb0..e78f8fb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #101 simple_kafka_client version 0.1.1 ] {
+Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Functions {
Function [ <internal:simple_kafka_client> function kafka_get_err_descs ] {
diff --git a/php-pecl-simple-kafka-client.spec b/php-pecl-simple-kafka-client.spec
index 5566001..ea55831 100644
--- a/php-pecl-simple-kafka-client.spec
+++ b/php-pecl-simple-kafka-client.spec
@@ -20,15 +20,12 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-simple-kafka-client
-Version: 0.1.1
+Version: 0.1.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-version.patch
-Patch1: %{pecl_name}-skip.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: librdkafka1php-devel >= 1.6
@@ -77,11 +74,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-%patch1 -p1
-
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_KAFKA_VERSION/{s/.* "//;s/".*$//;p}' php_simple_kafka_client_int.h)
+extver=$(sed -n '/#define PHP_SIMPLE_KAFKA_CLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_simple_kafka_client_int.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
@@ -201,6 +195,10 @@ cd ../ZTS
%changelog
+* Tue Apr 13 2021 Remi Collet <remi@remirepo.net> - 0.1.2-1
+- update to 0.1.2
+- drop patches merged upstream
+
* Mon Apr 12 2021 Remi Collet <remi@remirepo.net> - 0.1.1-1
- initial package, version 0.1.1 (stable)
- open https://github.com/php-kafka/php-simple-kafka-client/pull/35 - version
diff --git a/simple_kafka_client-skip.patch b/simple_kafka_client-skip.patch
deleted file mode 100644
index 2889ace..0000000
--- a/simple_kafka_client-skip.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From ae1937c762de19d1bee2fd7873668b09ffc6d7cc Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@famillecollet.com>
-Date: Mon, 12 Apr 2021 08:16:23 +0200
-Subject: [PATCH] Missing skip
-
----
- tests/init_transaction_not_configured.phpt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/tests/init_transaction_not_configured.phpt b/tests/init_transaction_not_configured.phpt
-index 0adfad3..513490d 100644
---- a/tests/init_transaction_not_configured.phpt
-+++ b/tests/init_transaction_not_configured.phpt
-@@ -1,5 +1,9 @@
- --TEST--
- initTransaction() not configured
-+--SKIPIF--
-+<?php
-+require __DIR__ . '/integration-tests-check.php';
-+?>
- --FILE--
- <?php
- require __DIR__ . '/integration-tests-check.php';
diff --git a/simple_kafka_client-version.patch b/simple_kafka_client-version.patch
deleted file mode 100644
index 0a863ae..0000000
--- a/simple_kafka_client-version.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 8efeb2c1e924bb9eb25832df00f0599fd2cb004d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@famillecollet.com>
-Date: Mon, 12 Apr 2021 08:15:12 +0200
-Subject: [PATCH] Fix version
-
----
- php_simple_kafka_client_int.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/php_simple_kafka_client_int.h b/php_simple_kafka_client_int.h
-index d34a19a..63b22c0 100644
---- a/php_simple_kafka_client_int.h
-+++ b/php_simple_kafka_client_int.h
-@@ -143,7 +143,7 @@ extern zend_object_handlers kafka_default_object_handlers;
-
- #define phpext_kafka_ptr &simple_kafka_client_module_entry
-
--#define PHP_KAFKA_VERSION "0.1.0"
-+#define PHP_KAFKA_VERSION "0.1.1"
-
-
- static inline void kafka_call_function(zend_fcall_info *fci, zend_fcall_info_cache *fci_cache, zval *retval, uint32_t param_count, zval params[])