summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-12 08:35:15 +0200
committerRemi Collet <remi@remirepo.net>2021-04-12 08:35:15 +0200
commit612c5f548cf85ca4cc68f5ee97f0c2d3254e2d5e (patch)
tree9c6457f02bfccf8d317f0d92b57d280823ee3031
New package
-rw-r--r--.gitignore9
-rw-r--r--Makefile3
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION1055
-rw-r--r--php-pecl-simple-kafka-client.spec207
-rw-r--r--simple_kafka_client-skip.patch23
-rw-r--r--simple_kafka_client-version.patch22
7 files changed, 1327 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..b522e7a
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+simple_kafka_client
+
+kafka support => enabled
+version => 0.1.1
+build date => Jan 27 2021 00:00:00
+librdkafka version (runtime) => 1.6.1
+librdkafka version (build) => 1.6.1.255
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..917efb0
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,1055 @@
+Extension [ <persistent> extension #101 simple_kafka_client version 0.1.1 ] {
+
+ - Functions {
+ Function [ <internal:simple_kafka_client> function kafka_get_err_descs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ Function [ <internal:simple_kafka_client> function kafka_err2str ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $errorCode ]
+ }
+ - Return [ string ]
+ }
+ Function [ <internal:simple_kafka_client> function kafka_thread_cnt ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+ Function [ <internal:simple_kafka_client> function kafka_offset_tail ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ int ]
+ }
+ Function [ <internal:simple_kafka_client> function kafka_err2name ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $errorCode ]
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Classes [16] {
+ Class [ <internal:simple_kafka_client> abstract class SimpleKafkaClient ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:simple_kafka_client> public method getMetadata ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> bool $allTopics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ Parameter #2 [ <required> SimpleKafkaClient\Topic $topic ]
+ }
+ - Return [ SimpleKafkaClient\Metadata ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getOutQLen ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method poll ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method queryWatermarkOffsets ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> string $topic ]
+ Parameter #1 [ <required> int $partition ]
+ Parameter #2 [ <required> int &$low ]
+ Parameter #3 [ <required> int &$high ]
+ Parameter #4 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method offsetsForTimes ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topicPartitions ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Producer extends SimpleKafkaClient ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [13] {
+ Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SimpleKafkaClient\Configuration $configuration ]
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method initTransactions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method beginTransaction ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method commitTransaction ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method abortTransaction ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method flush ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method purge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $purgeFlags ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getTopicHandle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $topic ]
+ }
+ - Return [ SimpleKafkaClient\ProducerTopic ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method getMetadata ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> bool $allTopics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ Parameter #2 [ <required> SimpleKafkaClient\Topic $topic ]
+ }
+ - Return [ SimpleKafkaClient\Metadata ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method getOutQLen ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method poll ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method queryWatermarkOffsets ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> string $topic ]
+ Parameter #1 [ <required> int $partition ]
+ Parameter #2 [ <required> int &$low ]
+ Parameter #3 [ <required> int &$high ]
+ Parameter #4 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method offsetsForTimes ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topicPartitions ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Configuration ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method dump ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setErrorCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setDrMsgCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setStatsCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setRebalanceCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setOffsetCommitCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setLogCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Exception extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\KafkaErrorException extends SimpleKafkaClient\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [8] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> private $error_string ]
+ Property [ <default> private $isFatal ]
+ Property [ <default> private $isRetriable ]
+ Property [ <default> private $transactionRequiresAbort ]
+ }
+
+ - Methods [14] {
+ Method [ <internal:simple_kafka_client, overwrites Exception, ctor> public method __construct ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> string $message ]
+ Parameter #1 [ <required> int $code ]
+ Parameter #2 [ <required> string $error_string ]
+ Parameter #3 [ <required> bool $isFatal ]
+ Parameter #4 [ <required> bool $isRetriable ]
+ Parameter #5 [ <required> bool $transactionRequiresAbort ]
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method getErrorString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method isFatal ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method isRetriable ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method transactionRequiresAbort ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Consumer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [16] {
+ Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SimpleKafkaClient\Configuration $configuration ]
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method assign ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array or NULL $topics ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getAssignment ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method subscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $topics ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getSubscription ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method unsubscribe ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method consume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ SimpleKafkaClient\Message ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method commit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $messageOrOffsets ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method commitAsync ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $messageOrOffsets ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method close ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getMetadata ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> bool $allTopics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ Parameter #2 [ <required> SimpleKafkaClient\ConsumerTopic $topic ]
+ }
+ - Return [ SimpleKafkaClient\Metadata ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getTopicHandle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $topic ]
+ }
+ - Return [ SimpleKafkaClient\ConsumerTopic ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getCommittedOffsets ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getOffsetPositions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $topics ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method offsetsForTimes ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topicPartitions ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method queryWatermarkOffsets ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> string $topic ]
+ Parameter #1 [ <required> int $partition ]
+ Parameter #2 [ <required> int &$low ]
+ Parameter #3 [ <required> int &$high ]
+ Parameter #4 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Message ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [9] {
+ Property [ <default> public $err ]
+ Property [ <default> public $topic_name ]
+ Property [ <default> public $timestamp ]
+ Property [ <default> public $partition ]
+ Property [ <default> public $payload ]
+ Property [ <default> public $len ]
+ Property [ <default> public $key ]
+ Property [ <default> public $offset ]
+ Property [ <default> public $headers ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:simple_kafka_client> public method getErrorString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Metadata ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:simple_kafka_client> public method getOrigBrokerId ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getOrigBrokerName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getBrokers ] {
+
+ - Parameters [0] {
+ }
+ - Return [ SimpleKafkaClient\Metadata\Collection ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getTopics ] {
+
+ - Parameters [0] {
+ }
+ - Return [ SimpleKafkaClient\Metadata\Collection ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Metadata\Topic ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:simple_kafka_client> public method getName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getErrorCode ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getPartitions ] {
+
+ - Parameters [0] {
+ }
+ - Return [ SimpleKafkaClient\Metadata\Collection ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Metadata\Broker ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:simple_kafka_client> public method getId ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getHost ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getPort ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Metadata\Partition ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:simple_kafka_client> public method getId ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getErrorCode ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getLeader ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getReplicas ] {
+
+ - Parameters [0] {
+ }
+ - Return [ SimpleKafkaClient\Metadata\Collection ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getIsrs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ SimpleKafkaClient\Metadata\Collection ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> <iterateable> class SimpleKafkaClient\Metadata\Collection implements Countable, Iterator, Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:simple_kafka_client, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:simple_kafka_client, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:simple_kafka_client, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\TopicPartition ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $topicName ]
+ Parameter #1 [ <required> int $partition ]
+ Parameter #2 [ <optional> $offset ]
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method getTopicName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setTopicName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $topicName ]
+ }
+ - Return [ SimpleKafkaClient\TopicPartition ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getPartition ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setPartition ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $partition ]
+ }
+ - Return [ SimpleKafkaClient\TopicPartition ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getOffset ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setOffset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ SimpleKafkaClient\TopicPartition ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> abstract class SimpleKafkaClient\Topic ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:simple_kafka_client> public method getName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\ConsumerTopic extends SimpleKafkaClient\Topic ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:simple_kafka_client, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient\Topic> public method getName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\ProducerTopic extends SimpleKafkaClient\Topic ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:simple_kafka_client, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method produce ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> int $partition ]
+ Parameter #1 [ <required> int $msgFlags ]
+ Parameter #2 [ <optional> $payload ]
+ Parameter #3 [ <optional> $key ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method producev ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> int $partition ]
+ Parameter #1 [ <required> int $msgFlags ]
+ Parameter #2 [ <optional> $payload ]
+ Parameter #3 [ <optional> $key ]
+ Parameter #4 [ <optional> $headers ]
+ Parameter #5 [ <optional> $timestampMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient\Topic> public method getName ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-simple-kafka-client.spec b/php-pecl-simple-kafka-client.spec
new file mode 100644
index 0000000..5566001
--- /dev/null
+++ b/php-pecl-simple-kafka-client.spec
@@ -0,0 +1,207 @@
+# remirepo/fedora spec file for php-pecl-simple-kafka-client
+#
+# Copyright (c) 2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-rdkafka
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name simple_kafka_client
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%global ini_name 40-%{pecl_name}.ini
+
+%global buildver %(pkg-config --silence-errors --modversion rdkafka 2>/dev/null || echo 65536)
+
+Summary: Kafka client based on librdkafka
+Name: %{?sub_prefix}php-pecl-simple-kafka-client
+Version: 0.1.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+Patch0: %{pecl_name}-version.patch
+Patch1: %{pecl_name}-skip.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: librdkafka1php-devel >= 1.6
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+Requires: librdkafka1php%{?_isa} >= %{buildver}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+
+%description
+This extension is a librdkafka binding providing a working client for Kafka.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+%patch0 -p1
+%patch1 -p1
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_KAFKA_VERSION/{s/.* "//;s/".*$//;p}' php_simple_kafka_client_int.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+ --with-simple-kafka-client
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+ --with-simple-kafka-client
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Apr 12 2021 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- initial package, version 0.1.1 (stable)
+- open https://github.com/php-kafka/php-simple-kafka-client/pull/35 - version
+- open https://github.com/php-kafka/php-simple-kafka-client/pull/36 - skipif
diff --git a/simple_kafka_client-skip.patch b/simple_kafka_client-skip.patch
new file mode 100644
index 0000000..2889ace
--- /dev/null
+++ b/simple_kafka_client-skip.patch
@@ -0,0 +1,23 @@
+From ae1937c762de19d1bee2fd7873668b09ffc6d7cc Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@famillecollet.com>
+Date: Mon, 12 Apr 2021 08:16:23 +0200
+Subject: [PATCH] Missing skip
+
+---
+ tests/init_transaction_not_configured.phpt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/tests/init_transaction_not_configured.phpt b/tests/init_transaction_not_configured.phpt
+index 0adfad3..513490d 100644
+--- a/tests/init_transaction_not_configured.phpt
++++ b/tests/init_transaction_not_configured.phpt
+@@ -1,5 +1,9 @@
+ --TEST--
+ initTransaction() not configured
++--SKIPIF--
++<?php
++require __DIR__ . '/integration-tests-check.php';
++?>
+ --FILE--
+ <?php
+ require __DIR__ . '/integration-tests-check.php';
diff --git a/simple_kafka_client-version.patch b/simple_kafka_client-version.patch
new file mode 100644
index 0000000..0a863ae
--- /dev/null
+++ b/simple_kafka_client-version.patch
@@ -0,0 +1,22 @@
+From 8efeb2c1e924bb9eb25832df00f0599fd2cb004d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@famillecollet.com>
+Date: Mon, 12 Apr 2021 08:15:12 +0200
+Subject: [PATCH] Fix version
+
+---
+ php_simple_kafka_client_int.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/php_simple_kafka_client_int.h b/php_simple_kafka_client_int.h
+index d34a19a..63b22c0 100644
+--- a/php_simple_kafka_client_int.h
++++ b/php_simple_kafka_client_int.h
+@@ -143,7 +143,7 @@ extern zend_object_handlers kafka_default_object_handlers;
+
+ #define phpext_kafka_ptr &simple_kafka_client_module_entry
+
+-#define PHP_KAFKA_VERSION "0.1.0"
++#define PHP_KAFKA_VERSION "0.1.1"
+
+
+ static inline void kafka_call_function(zend_fcall_info *fci, zend_fcall_info_cache *fci_cache, zval *retval, uint32_t param_count, zval params[])