summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 15:50:38 +0200
committerRemi Collet <remi@php.net>2022-10-17 15:50:38 +0200
commite75a77dc5d00465f2fd1f33e14b641c10dbd4243 (patch)
tree084a58fbe7516947df0acd25c4eb12f2e72d4709
parent488e5ecdf664b264e0a6225a71f3a3661b0664a1 (diff)
update to 3.0.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION111
-rw-r--r--php-pecl-simdjson.spec7
3 files changed, 108 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index c422093..42df20e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
simdjson
simdjson support => enabled
-Version => 2.1.0
+Version => 3.0.0
Support => https://github.com/crazyxman/simdjson_php
Implementation => Intel/AMD AVX2
diff --git a/REFLECTION b/REFLECTION
index 6e82e70..d401e4b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,9 @@
-Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
+Extension [ <persistent> extension #118 simdjson version 3.0.0 ] {
- Dependencies {
}
- - Constants [30] {
+ - Constants [31] {
Constant [ int SIMDJSON_ERR_CAPACITY ] { 1 }
Constant [ int SIMDJSON_ERR_TAPE_ERROR ] { 3 }
Constant [ int SIMDJSON_ERR_DEPTH_ERROR ] { 4 }
@@ -33,6 +33,7 @@ Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
Constant [ int SIMDJSON_ERR_SCALAR_DOCUMENT_AS_VALUE ] { 28 }
Constant [ int SIMDJSON_ERR_OUT_OF_BOUNDS ] { 29 }
Constant [ int SIMDJSON_ERR_TRAILING_CONTENT ] { 30 }
+ Constant [ int SIMDJSON_ERR_KEY_COUNT_NOT_COUNTABLE ] { 254 }
Constant [ int SIMDJSON_ERR_INVALID_PROPERTY ] { 255 }
}
@@ -43,13 +44,13 @@ Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
Parameter #0 [ <required> string $json ]
Parameter #1 [ <optional> int $depth = <default> ]
}
- - Return [ ?bool ]
+ - Return [ bool ]
}
Function [ <internal:simdjson> function simdjson_decode ] {
- Parameters [3] {
Parameter #0 [ <required> string $json ]
- Parameter #1 [ <optional> bool $assoc = <default> ]
+ Parameter #1 [ <optional> bool $associative = <default> ]
Parameter #2 [ <optional> int $depth = <default> ]
}
}
@@ -58,7 +59,7 @@ Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
- Parameters [4] {
Parameter #0 [ <required> string $json ]
Parameter #1 [ <required> string $key ]
- Parameter #2 [ <optional> bool $assoc = <default> ]
+ Parameter #2 [ <optional> bool $associative = <default> ]
Parameter #3 [ <optional> int $depth = <default> ]
}
}
@@ -69,20 +70,21 @@ Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
Parameter #1 [ <required> string $key ]
Parameter #2 [ <optional> int $depth = <default> ]
}
- - Return [ ?bool ]
+ - Return [ bool ]
}
Function [ <internal:simdjson> function simdjson_key_count ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> string $json ]
Parameter #1 [ <required> string $key ]
Parameter #2 [ <optional> int $depth = <default> ]
+ Parameter #3 [ <optional> bool $throw_if_uncountable = <default> ]
}
- - Return [ ?int ]
+ - Return [ int ]
}
}
- - Classes [1] {
+ - Classes [2] {
Class [ <internal:simdjson> class SimdJsonException extends RuntimeException implements Stringable, Throwable ] {
- Constants [0] {
@@ -173,6 +175,97 @@ Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
}
}
}
+
+ Class [ <internal:simdjson> class SimdJsonValueError extends ValueError implements Stringable, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Error, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Error> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Error, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
}
}
diff --git a/php-pecl-simdjson.spec b/php-pecl-simdjson.spec
index d90c40f..6d55f20 100644
--- a/php-pecl-simdjson.spec
+++ b/php-pecl-simdjson.spec
@@ -19,7 +19,7 @@
Summary: Provides faster json decoding through simdjson bindings for PHP
Name: %{?scl_prefix}php-pecl-simdjson
-Version: 2.1.0
+Version: 3.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -72,7 +72,7 @@ mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_SIMDJSON_VERSION/{s/.* "//;s/".*$//;p}' php_simdjson.h)
+extver=$(sed -n '/#define PHP_SIMDJSON_VERSION /{s/.* "//;s/".*$//;p}' php_simdjson.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
@@ -204,6 +204,9 @@ cd ../ZTS
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+
* Fri Oct 14 2022 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0