summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-14 07:45:57 +0200
committerRemi Collet <remi@php.net>2022-10-14 07:45:57 +0200
commit488e5ecdf664b264e0a6225a71f3a3661b0664a1 (patch)
treeecf196a23f6d8664220f06761ab29bd4c969a3cb
parent8617dadb22ae332ac488fcf0fad45c6b10e51b95 (diff)
update to 2.1.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION128
-rw-r--r--php-pecl-simdjson.spec5
3 files changed, 132 insertions, 3 deletions
diff --git a/PHPINFO b/PHPINFO
index 28dac4a..c422093 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
simdjson
simdjson support => enabled
-Version => 2.0.5
+Version => 2.1.0
Support => https://github.com/crazyxman/simdjson_php
Implementation => Intel/AMD AVX2
diff --git a/REFLECTION b/REFLECTION
index d310cff..6e82e70 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,8 +1,41 @@
-Extension [ <persistent> extension #118 simdjson version 2.0.5 ] {
+Extension [ <persistent> extension #118 simdjson version 2.1.0 ] {
- Dependencies {
}
+ - Constants [30] {
+ Constant [ int SIMDJSON_ERR_CAPACITY ] { 1 }
+ Constant [ int SIMDJSON_ERR_TAPE_ERROR ] { 3 }
+ Constant [ int SIMDJSON_ERR_DEPTH_ERROR ] { 4 }
+ Constant [ int SIMDJSON_ERR_STRING_ERROR ] { 5 }
+ Constant [ int SIMDJSON_ERR_T_ATOM_ERROR ] { 6 }
+ Constant [ int SIMDJSON_ERR_F_ATOM_ERROR ] { 7 }
+ Constant [ int SIMDJSON_ERR_N_ATOM_ERROR ] { 8 }
+ Constant [ int SIMDJSON_ERR_NUMBER_ERROR ] { 9 }
+ Constant [ int SIMDJSON_ERR_UTF8_ERROR ] { 10 }
+ Constant [ int SIMDJSON_ERR_UNINITIALIZED ] { 11 }
+ Constant [ int SIMDJSON_ERR_EMPTY ] { 12 }
+ Constant [ int SIMDJSON_ERR_UNESCAPED_CHARS ] { 13 }
+ Constant [ int SIMDJSON_ERR_UNCLOSED_STRING ] { 14 }
+ Constant [ int SIMDJSON_ERR_UNSUPPORTED_ARCHITECTURE ] { 15 }
+ Constant [ int SIMDJSON_ERR_INCORRECT_TYPE ] { 16 }
+ Constant [ int SIMDJSON_ERR_NUMBER_OUT_OF_RANGE ] { 17 }
+ Constant [ int SIMDJSON_ERR_INDEX_OUT_OF_BOUNDS ] { 18 }
+ Constant [ int SIMDJSON_ERR_NO_SUCH_FIELD ] { 19 }
+ Constant [ int SIMDJSON_ERR_IO_ERROR ] { 20 }
+ Constant [ int SIMDJSON_ERR_INVALID_JSON_POINTER ] { 21 }
+ Constant [ int SIMDJSON_ERR_INVALID_URI_FRAGMENT ] { 22 }
+ Constant [ int SIMDJSON_ERR_UNEXPECTED_ERROR ] { 23 }
+ Constant [ int SIMDJSON_ERR_PARSER_IN_USE ] { 24 }
+ Constant [ int SIMDJSON_ERR_OUT_OF_ORDER_ITERATION ] { 25 }
+ Constant [ int SIMDJSON_ERR_INSUFFICIENT_PADDING ] { 26 }
+ Constant [ int SIMDJSON_ERR_INCOMPLETE_ARRAY_OR_OBJECT ] { 27 }
+ Constant [ int SIMDJSON_ERR_SCALAR_DOCUMENT_AS_VALUE ] { 28 }
+ Constant [ int SIMDJSON_ERR_OUT_OF_BOUNDS ] { 29 }
+ Constant [ int SIMDJSON_ERR_TRAILING_CONTENT ] { 30 }
+ Constant [ int SIMDJSON_ERR_INVALID_PROPERTY ] { 255 }
+ }
+
- Functions {
Function [ <internal:simdjson> function simdjson_is_valid ] {
@@ -48,5 +81,98 @@ Extension [ <persistent> extension #118 simdjson version 2.0.5 ] {
- Return [ ?int ]
}
}
+
+ - Classes [1] {
+ Class [ <internal:simdjson> class SimdJsonException extends RuntimeException implements Stringable, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+ }
}
diff --git a/php-pecl-simdjson.spec b/php-pecl-simdjson.spec
index 89f8575..d90c40f 100644
--- a/php-pecl-simdjson.spec
+++ b/php-pecl-simdjson.spec
@@ -19,7 +19,7 @@
Summary: Provides faster json decoding through simdjson bindings for PHP
Name: %{?scl_prefix}php-pecl-simdjson
-Version: 2.0.5
+Version: 2.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -204,6 +204,9 @@ cd ../ZTS
%changelog
+* Fri Oct 14 2022 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+
* Thu Oct 13 2022 Remi Collet <remi@remirepo.net> - 2.0.5-1
- update to 2.0.5