summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-25 07:57:48 +0200
committerRemi Collet <remi@php.net>2022-07-25 07:57:48 +0200
commit184ca2e43098bcd209415f23d8cba26c7ac24679 (patch)
tree37977fa8c900e919a889840be3a5319272617bd1
initial package
open https://github.com/Ponup/php-sdl-ttf/pull/1 fix dependencies
-rw-r--r--.gitignore9
-rw-r--r--Makefile8
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION66
-rw-r--r--php-pecl-sdl-ttf.spec191
5 files changed, 280 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..9e525a3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,8 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
+refl:
+ php -d extension=sdl -d extension=sdl_mixer --re sdl_mixer >REFLECTION
+ php -d extension=sdl -d extension=sdl_mixer --ri sdl_mixer >PHPINFO
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..a6765c9
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+sdl_ttf
+
+SDL_ttf support => enabled
+SDL_ttf PHP extension version => 0.2.0
+SDL_ttf linked version => 2.0.15
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..ca4a4f9
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,66 @@
+Extension [ <persistent> extension #121 sdl_ttf version 0.2.0 ] {
+
+ - Dependencies {
+ Dependency [ sdl (Required) ]
+ }
+
+ - Functions {
+ Function [ <internal:sdl_ttf> function TTF_Init ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+ Function [ <internal:sdl_ttf> function TTF_Quit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+ Function [ <internal:sdl_ttf> function TTF_OpenFont ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> int $size ]
+ }
+ - Return [ TTF_Font ]
+ }
+ Function [ <internal:sdl_ttf> function TTF_CloseFont ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> TTF_Font $font ]
+ }
+ - Return [ int ]
+ }
+ Function [ <internal:sdl_ttf> function TTF_RenderText_Solid ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> TTF_Font $font ]
+ Parameter #1 [ <required> string $text ]
+ Parameter #2 [ <required> SDL_Color $color ]
+ }
+ - Return [ SDL_Surface ]
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:sdl_ttf> final class TTF_Font ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-sdl-ttf.spec b/php-pecl-sdl-ttf.spec
new file mode 100644
index 0000000..0f978ff
--- /dev/null
+++ b/php-pecl-sdl-ttf.spec
@@ -0,0 +1,191 @@
+# remirepo spec file for php-pecl-sdl-ttf
+#
+# Copyright (c) 2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%scl_package php-pecl-sdl-ttf
+%endif
+
+%bcond_with tests
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name sdl_ttf
+# no ini file (loaded by phpsdl helper)
+
+%global upstream_version 0.2.0
+#global upstream_prever RC1
+
+Summary: SDL_ttf bindings for PHP
+Name: %{?scl_prefix}php-pecl-sdl-ttf
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: zlib
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-sdl >= 2.3.0
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: SDL2_ttf-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-sdl%{?_isa} >= 2.5.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Supplements: %{?scl_prefix}php-sdl%{?_isa}
+%endif
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Notice pecl_name != name
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+
+%description
+SDL_ttf bindings for the PHP language.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+# Check version as upstream often forget to update this
+extver=$(sed -n '/define PHP_SDL_TTF_VERSION/{s/.* "//;s/".*$//;p}' php_sdl_ttf.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
+ : Error: Upstream version is ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --enable-sdl_ttf \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=sdl \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep -i '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=sdl \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep -i '^%{pecl_name}$'
+
+%endif
+
+%if %{with tests}
+cd NTS
+: Run upstream test suite
+# ignore deprecated (in SDL 2.5.0)
+TEST_PHP_ARGS="-n -d error_reporting=24575 -d extension=sdl -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+#doc %%{pecl_docdir}/%%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Jul 25 2022 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- initial package
+- open https://github.com/Ponup/php-sdl-ttf/pull/1 fix dependencies