summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-08 15:21:24 +0200
committerRemi Collet <remi@remirepo.net>2020-10-08 15:21:24 +0200
commit68081c06cc48c815009f9844c6520da25afc1066 (patch)
tree2d6c4ec66503d0bc2589963aaf0d84aecb1e4e93
parentbcca276d66d158f01412f2b2908f3f9d49e2d0fe (diff)
update to 4.0.0a2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-runkit7.spec9
-rw-r--r--runkit7_arginfo.h173
4 files changed, 6 insertions, 180 deletions
diff --git a/PHPINFO b/PHPINFO
index 812ec23..9097c83 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
runkit7
runkit7 support => enabled
-version => 4.0.0a1
+version => 4.0.0a2
Custom Superglobal support => enabled
Runtime Manipulation => enabled
diff --git a/REFLECTION b/REFLECTION
index 0867248..a9bba1f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 runkit7 version 4.0.0a1 ] {
+Extension [ <persistent> extension #117 runkit7 version 4.0.0a2 ] {
- INI {
Entry [ runkit.superglobal <PERDIR,SYSTEM> ]
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
index f60a4d7..aeb74d1 100644
--- a/php-pecl-runkit7.spec
+++ b/php-pecl-runkit7.spec
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 4.0.0
-%global upstream_prever a1
+%global upstream_prever a2
Name: %{?sub_prefix}php-pecl-%{proj_name}
Summary: For all those things you... shouldn't have been doing anyway... but surely do!
@@ -32,8 +32,6 @@ URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
-Source1: https://raw.githubusercontent.com/runkit7/runkit7/master/runkit7_arginfo.h
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
@@ -92,8 +90,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} .
-
extver=$(sed -n '/#define PHP_RUNKIT7_VERSION/{s/.*\t"//;s/".*$//;p}' runkit.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream RUNKIT version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -238,6 +234,9 @@ fi
%endif
%changelog
+* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.0~a2-1
+- update to 4.0.0a2
+
* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.0~a1-1
- update to 4.0.0a1
- raise dependency on PHP 7.2
diff --git a/runkit7_arginfo.h b/runkit7_arginfo.h
deleted file mode 100644
index 2b4adda..0000000
--- a/runkit7_arginfo.h
+++ /dev/null
@@ -1,173 +0,0 @@
-/* This is a generated file, edit the .stub.php file instead.
- * Stub hash: 4ed3bde43667f15f3395fc2c4f6cce57626fb6d2 */
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_add, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
- ZEND_ARG_INFO(0, value)
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 0, "RUNKIT7_ACC_PUBLIC")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_redefine, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
- ZEND_ARG_INFO(0, value)
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 1, "null")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_remove, 0, 1, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_add, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, function_name, IS_STRING, 0)
- ZEND_ARG_INFO(0, argument_list_or_closure)
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, code_or_doc_comment, IS_STRING, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_by_reference, _IS_BOOL, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, doc_comment, IS_STRING, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_type, IS_STRING, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, is_strict, _IS_BOOL, 1, "null")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_copy, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, source_name, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, target_name, IS_STRING, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit7_function_redefine arginfo_runkit7_function_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_remove, 0, 1, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, function_name, IS_STRING, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit7_function_rename arginfo_runkit7_function_copy
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_add, 0, 3, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, method_name, IS_STRING, 0)
- ZEND_ARG_INFO(0, argument_list_or_closure)
- ZEND_ARG_INFO_WITH_DEFAULT_VALUE(0, code_or_flags, "null")
- ZEND_ARG_INFO_WITH_DEFAULT_VALUE(0, flags_or_doc_comment, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, doc_comment, IS_STRING, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_type, IS_STRING, 1, "null")
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, is_strict, _IS_BOOL, 1, "null")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_copy, 0, 3, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, destination_class, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, destination_method, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, source_class, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, source_method, IS_STRING, 1, "null")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit7_method_redefine arginfo_runkit7_method_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_remove, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, method_name, IS_STRING, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_rename, 0, 3, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, source_method_name, IS_STRING, 0)
- ZEND_ARG_TYPE_INFO(0, source_target_name, IS_STRING, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_zval_inspect, 0, 1, IS_ARRAY, 0)
- ZEND_ARG_INFO(0, value)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit_constant_add, 0, 2, _IS_BOOL, 0)
- ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
- ZEND_ARG_INFO(0, value)
- ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 1, "RUNKIT7_ACC_PUBLIC")
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_constant_redefine arginfo_runkit7_constant_redefine
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_constant_remove arginfo_runkit7_constant_remove
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_function_add arginfo_runkit7_function_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_function_copy arginfo_runkit7_function_copy
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_function_redefine arginfo_runkit7_function_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_function_remove arginfo_runkit7_function_remove
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_function_rename arginfo_runkit7_function_copy
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_method_add arginfo_runkit7_method_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_method_copy arginfo_runkit7_method_copy
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_method_redefine arginfo_runkit7_method_add
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_method_remove arginfo_runkit7_method_remove
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_method_rename arginfo_runkit7_method_rename
-#endif
-
-#if defined(PHP_RUNKIT_MANIPULATION)
-#define arginfo_runkit_zval_inspect arginfo_runkit7_zval_inspect
-#endif
-
-#if defined(PHP_RUNKIT_SUPERGLOBALS)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_superglobals, 0, 0, IS_ARRAY, 0)
-ZEND_END_ARG_INFO()
-#endif
-
-#if defined(PHP_RUNKIT_SUPERGLOBALS)
-#define arginfo_runkit_superglobals arginfo_runkit7_superglobals
-#endif