summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-08 08:01:29 +0200
committerRemi Collet <remi@remirepo.net>2020-10-08 08:01:29 +0200
commitbcca276d66d158f01412f2b2908f3f9d49e2d0fe (patch)
treee1fa38b7f7f870fb7005a14b42d18b426185cccc
parent80e1652dcbcc1289951c5fdff2b570e414b2e1f3 (diff)
update to 4.0.0a1
raise dependency on PHP 7.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION286
-rw-r--r--php-pecl-runkit7.spec44
-rw-r--r--runkit7_arginfo.h173
4 files changed, 338 insertions, 169 deletions
diff --git a/PHPINFO b/PHPINFO
index 28e8e4a..812ec23 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,11 +2,9 @@
runkit7
runkit7 support => enabled
-version => 3.1.0a1
+version => 4.0.0a1
Custom Superglobal support => enabled
-Sandbox Support => disable or unavailable
Runtime Manipulation => enabled
-spl_object_id alias support => unnecessary in php 7.2+
Directive => Local Value => Master Value
runkit.superglobal => no value => no value
diff --git a/REFLECTION b/REFLECTION
index a4188bb..0867248 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 runkit7 version 3.1.0a1 ] {
+Extension [ <persistent> extension #117 runkit7 version 4.0.0a1 ] {
- INI {
Entry [ runkit.superglobal <PERDIR,SYSTEM> ]
@@ -9,21 +9,7 @@ Extension [ <persistent> extension #108 runkit7 version 3.1.0a1 ] {
}
}
- - Constants [32] {
- Constant [ int RUNKIT_IMPORT_FUNCTIONS ] { 1 }
- Constant [ int RUNKIT7_IMPORT_FUNCTIONS ] { 1 }
- Constant [ int RUNKIT_IMPORT_CLASS_METHODS ] { 2 }
- Constant [ int RUNKIT7_IMPORT_CLASS_METHODS ] { 2 }
- Constant [ int RUNKIT_IMPORT_CLASS_CONSTS ] { 4 }
- Constant [ int RUNKIT7_IMPORT_CLASS_CONSTS ] { 4 }
- Constant [ int RUNKIT_IMPORT_CLASS_PROPS ] { 8 }
- Constant [ int RUNKIT7_IMPORT_CLASS_PROPS ] { 8 }
- Constant [ int RUNKIT_IMPORT_CLASS_STATIC_PROPS ] { 16 }
- Constant [ int RUNKIT7_IMPORT_CLASS_STATIC_PROPS ] { 16 }
- Constant [ int RUNKIT_IMPORT_CLASSES ] { 30 }
- Constant [ int RUNKIT7_IMPORT_CLASSES ] { 30 }
- Constant [ int RUNKIT_IMPORT_OVERRIDE ] { 32 }
- Constant [ int RUNKIT7_IMPORT_OVERRIDE ] { 32 }
+ - Constants [16] {
Constant [ int RUNKIT_ACC_RETURN_REFERENCE ] { 67108864 }
Constant [ int RUNKIT7_ACC_RETURN_REFERENCE ] { 67108864 }
Constant [ int RUNKIT_ACC_PUBLIC ] { 256 }
@@ -40,8 +26,6 @@ Extension [ <persistent> extension #108 runkit7 version 3.1.0a1 ] {
Constant [ int RUNKIT7_FEATURE_MANIPULATION ] { 1 }
Constant [ int RUNKIT_FEATURE_SUPERGLOBALS ] { 1 }
Constant [ int RUNKIT7_FEATURE_SUPERGLOBALS ] { 1 }
- Constant [ int RUNKIT_FEATURE_SANDBOX ] { 0 }
- Constant [ int RUNKIT7_FEATURE_SANDBOX ] { 0 }
}
- Functions {
@@ -50,280 +34,284 @@ Extension [ <persistent> extension #108 runkit7 version 3.1.0a1 ] {
- Parameters [1] {
Parameter #0 [ <required> $value ]
}
+ - Return [ array ]
}
- Function [ <internal:runkit7> function runkit_zval_inspect ] {
+ Function [ <internal, deprecated:runkit7> function runkit_zval_inspect ] {
- Parameters [1] {
Parameter #0 [ <required> $value ]
}
- }
- Function [ <internal:runkit7> function runkit7_object_id ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $obj ]
- }
- }
- Function [ <internal:runkit7> function runkit_object_id ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $obj ]
- }
+ - Return [ array ]
}
Function [ <internal:runkit7> function runkit7_superglobals ] {
- Parameters [0] {
}
+ - Return [ array ]
}
- Function [ <internal:runkit7> function runkit_superglobals ] {
+ Function [ <internal, deprecated:runkit7> function runkit_superglobals ] {
- Parameters [0] {
}
- }
- Function [ <internal:runkit7> function runkit7_import ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $flags ]
- }
- }
- Function [ <internal:runkit7> function runkit_import ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $flags ]
- }
+ - Return [ array ]
}
Function [ <internal:runkit7> function runkit7_function_add ] {
- Parameters [7] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $arglist_or_closure ]
- Parameter #2 [ <optional> $code_or_doc_comment ]
- Parameter #3 [ <optional> $return_by_reference ]
- Parameter #4 [ <optional> $doc_comment ]
- Parameter #5 [ <optional> $return_type ]
- Parameter #6 [ <optional> $is_strict ]
+ Parameter #0 [ <required> string $function_name ]
+ Parameter #1 [ <required> $argument_list_or_closure ]
+ Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
+ Parameter #3 [ <optional> bool or NULL $return_by_reference ]
+ Parameter #4 [ <optional> string or NULL $doc_comment ]
+ Parameter #5 [ <optional> string or NULL $return_type ]
+ Parameter #6 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_function_add ] {
+ Function [ <internal, deprecated:runkit7> function runkit_function_add ] {
- Parameters [7] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $arglist_or_closure ]
- Parameter #2 [ <optional> $code_or_doc_comment ]
- Parameter #3 [ <optional> $return_by_reference ]
- Parameter #4 [ <optional> $doc_comment ]
- Parameter #5 [ <optional> $return_type ]
- Parameter #6 [ <optional> $is_strict ]
+ Parameter #0 [ <required> string $function_name ]
+ Parameter #1 [ <required> $argument_list_or_closure ]
+ Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
+ Parameter #3 [ <optional> bool or NULL $return_by_reference ]
+ Parameter #4 [ <optional> string or NULL $doc_comment ]
+ Parameter #5 [ <optional> string or NULL $return_type ]
+ Parameter #6 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_function_remove ] {
- Parameters [1] {
- Parameter #0 [ <required> $funcname ]
+ Parameter #0 [ <required> string $function_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_function_remove ] {
+ Function [ <internal, deprecated:runkit7> function runkit_function_remove ] {
- Parameters [1] {
- Parameter #0 [ <required> $funcname ]
+ Parameter #0 [ <required> string $function_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_function_rename ] {
- Parameters [2] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $newname ]
+ Parameter #0 [ <required> string $source_name ]
+ Parameter #1 [ <required> string $target_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_function_rename ] {
+ Function [ <internal, deprecated:runkit7> function runkit_function_rename ] {
- Parameters [2] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $newname ]
+ Parameter #0 [ <required> string $source_name ]
+ Parameter #1 [ <required> string $target_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_function_redefine ] {
- Parameters [7] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $arglist_or_closure ]
- Parameter #2 [ <required> $code_or_doc_comment ]
- Parameter #3 [ <optional> $return_by_reference ]
- Parameter #4 [ <optional> $doc_comment ]
- Parameter #5 [ <optional> $return_type ]
- Parameter #6 [ <optional> $is_strict ]
+ Parameter #0 [ <required> string $function_name ]
+ Parameter #1 [ <required> $argument_list_or_closure ]
+ Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
+ Parameter #3 [ <optional> bool or NULL $return_by_reference ]
+ Parameter #4 [ <optional> string or NULL $doc_comment ]
+ Parameter #5 [ <optional> string or NULL $return_type ]
+ Parameter #6 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_function_redefine ] {
+ Function [ <internal, deprecated:runkit7> function runkit_function_redefine ] {
- Parameters [7] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $arglist_or_closure ]
- Parameter #2 [ <required> $code_or_doc_comment ]
- Parameter #3 [ <optional> $return_by_reference ]
- Parameter #4 [ <optional> $doc_comment ]
- Parameter #5 [ <optional> $return_type ]
- Parameter #6 [ <optional> $is_strict ]
+ Parameter #0 [ <required> string $function_name ]
+ Parameter #1 [ <required> $argument_list_or_closure ]
+ Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
+ Parameter #3 [ <optional> bool or NULL $return_by_reference ]
+ Parameter #4 [ <optional> string or NULL $doc_comment ]
+ Parameter #5 [ <optional> string or NULL $return_type ]
+ Parameter #6 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_function_copy ] {
- Parameters [2] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $targetname ]
+ Parameter #0 [ <required> string $source_name ]
+ Parameter #1 [ <required> string $target_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_function_copy ] {
+ Function [ <internal, deprecated:runkit7> function runkit_function_copy ] {
- Parameters [2] {
- Parameter #0 [ <required> $funcname ]
- Parameter #1 [ <required> $targetname ]
+ Parameter #0 [ <required> string $source_name ]
+ Parameter #1 [ <required> string $target_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_method_add ] {
- Parameters [8] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
+ Parameter #2 [ <required> $argument_list_or_closure ]
Parameter #3 [ <optional> $code_or_flags ]
Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> $doc_comment ]
- Parameter #6 [ <optional> $return_type ]
- Parameter #7 [ <optional> $is_strict ]
+ Parameter #5 [ <optional> string or NULL $doc_comment ]
+ Parameter #6 [ <optional> string or NULL $return_type ]
+ Parameter #7 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_method_add ] {
+ Function [ <internal, deprecated:runkit7> function runkit_method_add ] {
- Parameters [8] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
+ Parameter #2 [ <required> $argument_list_or_closure ]
Parameter #3 [ <optional> $code_or_flags ]
Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> $doc_comment ]
- Parameter #6 [ <optional> $return_type ]
- Parameter #7 [ <optional> $is_strict ]
+ Parameter #5 [ <optional> string or NULL $doc_comment ]
+ Parameter #6 [ <optional> string or NULL $return_type ]
+ Parameter #7 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_method_redefine ] {
- Parameters [8] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
+ Parameter #2 [ <required> $argument_list_or_closure ]
Parameter #3 [ <optional> $code_or_flags ]
Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> $doc_comment ]
- Parameter #6 [ <optional> $return_type ]
- Parameter #7 [ <optional> $is_strict ]
+ Parameter #5 [ <optional> string or NULL $doc_comment ]
+ Parameter #6 [ <optional> string or NULL $return_type ]
+ Parameter #7 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_method_redefine ] {
+ Function [ <internal, deprecated:runkit7> function runkit_method_redefine ] {
- Parameters [8] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
+ Parameter #2 [ <required> $argument_list_or_closure ]
Parameter #3 [ <optional> $code_or_flags ]
Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> $doc_comment ]
- Parameter #6 [ <optional> $return_type ]
- Parameter #7 [ <optional> $is_strict ]
+ Parameter #5 [ <optional> string or NULL $doc_comment ]
+ Parameter #6 [ <optional> string or NULL $return_type ]
+ Parameter #7 [ <optional> bool or NULL $is_strict ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_method_remove ] {
- Parameters [2] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_method_remove ] {
+ Function [ <internal, deprecated:runkit7> function runkit_method_remove ] {
- Parameters [2] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $method_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_method_rename ] {
- Parameters [3] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $newname ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $source_method_name ]
+ Parameter #2 [ <required> string $source_target_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_method_rename ] {
+ Function [ <internal, deprecated:runkit7> function runkit_method_rename ] {
- Parameters [3] {
- Parameter #0 [ <required> $classname ]
- Parameter #1 [ <required> $methodname ]
- Parameter #2 [ <required> $newname ]
+ Parameter #0 [ <required> string $class_name ]
+ Parameter #1 [ <required> string $source_method_name ]
+ Parameter #2 [ <required> string $source_target_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_method_copy ] {
- Parameters [4] {
- Parameter #0 [ <required> $dClass ]
- Parameter #1 [ <required> $dMethod ]
- Parameter #2 [ <required> $sClass ]
- Parameter #3 [ <optional> $sMethod ]
+ Parameter #0 [ <required> string $destination_class ]
+ Parameter #1 [ <required> string $destination_method ]
+ Parameter #2 [ <required> string $source_class ]
+ Parameter #3 [ <optional> string or NULL $source_method ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_method_copy ] {
+ Function [ <internal, deprecated:runkit7> function runkit_method_copy ] {
- Parameters [4] {
- Parameter #0 [ <required> $dClass ]
- Parameter #1 [ <required> $dMethod ]
- Parameter #2 [ <required> $sClass ]
- Parameter #3 [ <optional> $sMethod ]
+ Parameter #0 [ <required> string $destination_class ]
+ Parameter #1 [ <required> string $destination_method ]
+ Parameter #2 [ <required> string $source_class ]
+ Parameter #3 [ <optional> string or NULL $source_method ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_constant_redefine ] {
- Parameters [3] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $newVisibility ]
+ Parameter #2 [ <optional> int or NULL $new_visibility ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_constant_redefine ] {
+ Function [ <internal, deprecated:runkit7> function runkit_constant_redefine ] {
- Parameters [3] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $newVisibility ]
+ Parameter #2 [ <optional> int or NULL $new_visibility ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_constant_remove ] {
- Parameters [1] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_constant_remove ] {
+ Function [ <internal, deprecated:runkit7> function runkit_constant_remove ] {
- Parameters [1] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
}
+ - Return [ bool ]
}
Function [ <internal:runkit7> function runkit7_constant_add ] {
- Parameters [3] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $newVisibility ]
+ Parameter #2 [ <optional> int or NULL $new_visibility ]
}
+ - Return [ bool ]
}
- Function [ <internal:runkit7> function runkit_constant_add ] {
+ Function [ <internal, deprecated:runkit7> function runkit_constant_add ] {
- Parameters [3] {
- Parameter #0 [ <required> $constname ]
+ Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $newVisibility ]
+ Parameter #2 [ <optional> int $new_visibility ]
}
+ - Return [ bool ]
}
}
}
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
index 6b4b334..f60a4d7 100644
--- a/php-pecl-runkit7.spec
+++ b/php-pecl-runkit7.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-runkit7
#
-# Copyright (c) 2019 Remi Collet
+# Copyright (c) 2019-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,8 +20,8 @@
%global ini_name 40-%{pecl_name}.ini
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 3.0.0
-#global upstream_prever RC1
+%global upstream_version 4.0.0
+%global upstream_prever a1
Name: %{?sub_prefix}php-pecl-%{proj_name}
Summary: For all those things you... shouldn't have been doing anyway... but surely do!
@@ -32,8 +32,10 @@ URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source1: https://raw.githubusercontent.com/runkit7/runkit7/master/runkit7_arginfo.h
+
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
#BuildRequires: gdb
#BuildRequires: php-cli-debuginfo
@@ -53,21 +55,16 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php71u-pecl-%{proj_name} <= %{version}
-Obsoletes: php71w-pecl-%{proj_name} <= %{version}
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{proj_name} <= %{version}
-Obsoletes: php72w-pecl-%{proj_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{proj_name} <= %{version}
-Obsoletes: php73w-pecl-%{proj_name} <= %{version}
+Obsoletes: php73-pecl-%{proj_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{proj_name} <= %{version}
-Obsoletes: php74w-pecl-%{proj_name} <= %{version}
+Obsoletes: php74-pecl-%{proj_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{proj_name} <= %{version}
%endif
%endif
@@ -95,6 +92,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+cp %{SOURCE1} .
+
extver=$(sed -n '/#define PHP_RUNKIT7_VERSION/{s/.*\t"//;s/".*$//;p}' runkit.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream RUNKIT version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -175,8 +174,12 @@ export REPORT_EXIT_STATUS=1
%if %{with_tests}
# ignore FPM tests because of systemd monitoring changing output
rm ?TS/tests/runkit_fpm*
-# segfault on 32-bit see https://github.com/runkit7/runkit7/issues/185
-rm ?TS/tests/runkit_import_class_extend.phpt
+%if "%{php_version}" > "8.0"
+rm ?TS/tests/runkit_arginfo.phpt
+rm ?TS/tests/runkit_function_copy_8.phpt
+rm ?TS/tests/runkit_method_variadic_strict.phpt
+rm ?TS/tests/runkit_methods_returning_by_reference.phpt
+%endif
: Upstream test suite NTS extension
cd NTS
@@ -235,6 +238,13 @@ fi
%endif
%changelog
+* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.0~a1-1
+- update to 4.0.0a1
+- raise dependency on PHP 7.2
+
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 3.1.0~a1-1
+- update to 3.1.0a1
+
* Mon Jun 17 2019 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
diff --git a/runkit7_arginfo.h b/runkit7_arginfo.h
new file mode 100644
index 0000000..2b4adda
--- /dev/null
+++ b/runkit7_arginfo.h
@@ -0,0 +1,173 @@
+/* This is a generated file, edit the .stub.php file instead.
+ * Stub hash: 4ed3bde43667f15f3395fc2c4f6cce57626fb6d2 */
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_add, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
+ ZEND_ARG_INFO(0, value)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 0, "RUNKIT7_ACC_PUBLIC")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_redefine, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
+ ZEND_ARG_INFO(0, value)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 1, "null")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_constant_remove, 0, 1, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_add, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, function_name, IS_STRING, 0)
+ ZEND_ARG_INFO(0, argument_list_or_closure)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, code_or_doc_comment, IS_STRING, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_by_reference, _IS_BOOL, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, doc_comment, IS_STRING, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_type, IS_STRING, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, is_strict, _IS_BOOL, 1, "null")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_copy, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, source_name, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, target_name, IS_STRING, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit7_function_redefine arginfo_runkit7_function_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_function_remove, 0, 1, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, function_name, IS_STRING, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit7_function_rename arginfo_runkit7_function_copy
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_add, 0, 3, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, method_name, IS_STRING, 0)
+ ZEND_ARG_INFO(0, argument_list_or_closure)
+ ZEND_ARG_INFO_WITH_DEFAULT_VALUE(0, code_or_flags, "null")
+ ZEND_ARG_INFO_WITH_DEFAULT_VALUE(0, flags_or_doc_comment, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, doc_comment, IS_STRING, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, return_type, IS_STRING, 1, "null")
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, is_strict, _IS_BOOL, 1, "null")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_copy, 0, 3, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, destination_class, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, destination_method, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, source_class, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, source_method, IS_STRING, 1, "null")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit7_method_redefine arginfo_runkit7_method_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_remove, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, method_name, IS_STRING, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_method_rename, 0, 3, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, class_name, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, source_method_name, IS_STRING, 0)
+ ZEND_ARG_TYPE_INFO(0, source_target_name, IS_STRING, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_zval_inspect, 0, 1, IS_ARRAY, 0)
+ ZEND_ARG_INFO(0, value)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit_constant_add, 0, 2, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO(0, constant_name, IS_STRING, 0)
+ ZEND_ARG_INFO(0, value)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, new_visibility, IS_LONG, 1, "RUNKIT7_ACC_PUBLIC")
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_constant_redefine arginfo_runkit7_constant_redefine
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_constant_remove arginfo_runkit7_constant_remove
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_function_add arginfo_runkit7_function_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_function_copy arginfo_runkit7_function_copy
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_function_redefine arginfo_runkit7_function_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_function_remove arginfo_runkit7_function_remove
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_function_rename arginfo_runkit7_function_copy
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_method_add arginfo_runkit7_method_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_method_copy arginfo_runkit7_method_copy
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_method_redefine arginfo_runkit7_method_add
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_method_remove arginfo_runkit7_method_remove
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_method_rename arginfo_runkit7_method_rename
+#endif
+
+#if defined(PHP_RUNKIT_MANIPULATION)
+#define arginfo_runkit_zval_inspect arginfo_runkit7_zval_inspect
+#endif
+
+#if defined(PHP_RUNKIT_SUPERGLOBALS)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_runkit7_superglobals, 0, 0, IS_ARRAY, 0)
+ZEND_END_ARG_INFO()
+#endif
+
+#if defined(PHP_RUNKIT_SUPERGLOBALS)
+#define arginfo_runkit_superglobals arginfo_runkit7_superglobals
+#endif