summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-redis5.spec20
3 files changed, 29 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index e9b2975..9277255 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
redis
Redis Support => enabled
-Redis Version => 5.0.2
+Redis Version => 5.1.0RC1
Available serializers => php, json, igbinary, msgpack
-Available compression => lzf
+Available compression => lzf, zstd
Directive => Local Value => Master Value
redis.arrays.algorithm => no value => no value
diff --git a/REFLECTION b/REFLECTION
index cd58a1c..a662f12 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #197 redis version 5.0.2 ] {
+Extension [ <persistent> extension #196 redis version 5.1.0RC1 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -94,7 +94,7 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
- Classes [5] {
Class [ <internal:redis> class Redis ] {
- - Constants [28] {
+ - Constants [33] {
Constant [ public integer REDIS_NOT_FOUND ] { 0 }
Constant [ public integer REDIS_STRING ] { 1 }
Constant [ public integer REDIS_SET ] { 2 }
@@ -111,6 +111,7 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
Constant [ public integer OPT_TCP_KEEPALIVE ] { 6 }
Constant [ public integer OPT_COMPRESSION ] { 7 }
Constant [ public integer OPT_REPLY_LITERAL ] { 8 }
+ Constant [ public integer OPT_COMPRESSION_LEVEL ] { 9 }
Constant [ public integer SERIALIZER_NONE ] { 0 }
Constant [ public integer SERIALIZER_PHP ] { 1 }
Constant [ public integer SERIALIZER_IGBINARY ] { 2 }
@@ -118,6 +119,10 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
Constant [ public integer SERIALIZER_JSON ] { 4 }
Constant [ public integer COMPRESSION_NONE ] { 0 }
Constant [ public integer COMPRESSION_LZF ] { 1 }
+ Constant [ public integer COMPRESSION_ZSTD ] { 2 }
+ Constant [ public integer COMPRESSION_ZSTD_MIN ] { 1 }
+ Constant [ public integer COMPRESSION_ZSTD_DEFAULT ] { 3 }
+ Constant [ public integer COMPRESSION_ZSTD_MAX ] { 22 }
Constant [ public integer OPT_SCAN ] { 4 }
Constant [ public integer SCAN_RETRY ] { 1 }
Constant [ public integer SCAN_NORETRY ] { 0 }
@@ -2279,7 +2284,7 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
Class [ <internal:redis> class RedisCluster ] {
- - Constants [32] {
+ - Constants [37] {
Constant [ public integer REDIS_NOT_FOUND ] { 0 }
Constant [ public integer REDIS_STRING ] { 1 }
Constant [ public integer REDIS_SET ] { 2 }
@@ -2295,6 +2300,7 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
Constant [ public integer OPT_TCP_KEEPALIVE ] { 6 }
Constant [ public integer OPT_COMPRESSION ] { 7 }
Constant [ public integer OPT_REPLY_LITERAL ] { 8 }
+ Constant [ public integer OPT_COMPRESSION_LEVEL ] { 9 }
Constant [ public integer SERIALIZER_NONE ] { 0 }
Constant [ public integer SERIALIZER_PHP ] { 1 }
Constant [ public integer SERIALIZER_IGBINARY ] { 2 }
@@ -2302,6 +2308,10 @@ Extension [ <persistent> extension #197 redis version 5.0.2 ] {
Constant [ public integer SERIALIZER_JSON ] { 4 }
Constant [ public integer COMPRESSION_NONE ] { 0 }
Constant [ public integer COMPRESSION_LZF ] { 1 }
+ Constant [ public integer COMPRESSION_ZSTD ] { 2 }
+ Constant [ public integer COMPRESSION_ZSTD_MIN ] { 1 }
+ Constant [ public integer COMPRESSION_ZSTD_DEFAULT ] { 3 }
+ Constant [ public integer COMPRESSION_ZSTD_MAX ] { 22 }
Constant [ public integer OPT_SCAN ] { 4 }
Constant [ public integer SCAN_RETRY ] { 1 }
Constant [ public integer SCAN_NORETRY ] { 0 }
diff --git a/php-pecl-redis5.spec b/php-pecl-redis5.spec
index 81a13c3..5d10f84 100644
--- a/php-pecl-redis5.spec
+++ b/php-pecl-redis5.spec
@@ -24,17 +24,19 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 5.0.2
-#global upstream_prever RC2
+%global upstream_version 5.1.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
+Patch0: %{pecl_name}-info.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -46,6 +48,7 @@ BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-pecl-msgpack-devel >= 2.0.3
%endif
BuildRequires: liblzf-devel
+BuildRequires: libzstd-devel >= 1.3.0
# to run Test suite
%if %{with_tests}
BuildRequires: redis >= 3
@@ -133,6 +136,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Use system library
rm -r liblzf
+%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_REDIS_VERSION/{s/.* "//;s/".*$//;p}' php_redis.h)
@@ -209,6 +213,8 @@ cd NTS
%endif
--enable-redis-lzf \
--with-liblzf \
+ --enable-redis-zstd \
+ --with-libzstd \
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
@@ -290,9 +296,6 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--pidfile $pidfile
-# https://github.com/phpredis/phpredis/issues/1472
-#sed -e 's/testXClaim/skipXClaim/;s/testXAck/skipXAck/;s/testXReadGroup/skipXReadGroup/' -i RedisTest.php
-
: Run the test Suite
sed -e "s/6379/$port/" -i *.php
@@ -349,6 +352,11 @@ fi
%changelog
+* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 5.1.0~RC1-1
+- update to 5.1.0RC1
+- enable ZSTD compression support
+- open https://github.com/phpredis/phpredis/pull/1648
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 5.0.2-2
- rebuild for 7.4.0RC1