summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis5.spec')
-rw-r--r--php-pecl-redis5.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-redis5.spec b/php-pecl-redis5.spec
index 81a13c3..5d10f84 100644
--- a/php-pecl-redis5.spec
+++ b/php-pecl-redis5.spec
@@ -24,17 +24,19 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 5.0.2
-#global upstream_prever RC2
+%global upstream_version 5.1.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
+Patch0: %{pecl_name}-info.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -46,6 +48,7 @@ BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-pecl-msgpack-devel >= 2.0.3
%endif
BuildRequires: liblzf-devel
+BuildRequires: libzstd-devel >= 1.3.0
# to run Test suite
%if %{with_tests}
BuildRequires: redis >= 3
@@ -133,6 +136,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Use system library
rm -r liblzf
+%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_REDIS_VERSION/{s/.* "//;s/".*$//;p}' php_redis.h)
@@ -209,6 +213,8 @@ cd NTS
%endif
--enable-redis-lzf \
--with-liblzf \
+ --enable-redis-zstd \
+ --with-libzstd \
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
@@ -290,9 +296,6 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--pidfile $pidfile
-# https://github.com/phpredis/phpredis/issues/1472
-#sed -e 's/testXClaim/skipXClaim/;s/testXAck/skipXAck/;s/testXReadGroup/skipXReadGroup/' -i RedisTest.php
-
: Run the test Suite
sed -e "s/6379/$port/" -i *.php
@@ -349,6 +352,11 @@ fi
%changelog
+* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 5.1.0~RC1-1
+- update to 5.1.0RC1
+- enable ZSTD compression support
+- open https://github.com/phpredis/phpredis/pull/1648
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 5.0.2-2
- rebuild for 7.4.0RC1