summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-12 08:37:15 +0200
committerRemi Collet <remi@remirepo.net>2018-10-12 08:37:15 +0200
commit5ca504892cb610ceaec642f008020f4f1170a6fc (patch)
tree795a82eaf9478e241ff9c04778ea445622061b60 /php-pecl-redis4.spec
parentadd808c8153c64fe551047e71ac34da91b8aaac9 (diff)
v4.2.0RC1
Diffstat (limited to 'php-pecl-redis4.spec')
-rw-r--r--php-pecl-redis4.spec48
1 files changed, 27 insertions, 21 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 5638728..ff1763e 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -28,13 +28,13 @@
# after 40-igbinary
%global ini_name 50-%{pecl_name}.ini
%endif
-%global upstream_version 4.1.1
-#global upstream_prever RC3
+%global upstream_version 4.2.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
@@ -160,26 +160,26 @@ extension = %{pecl_name}.so
;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2"
; Configuration
-;redis.arrays.autorehash = ''
-;redis.arrays.connecttimeout = ''
+;redis.arrays.autorehash = 0
+;redis.arrays.connecttimeout = 0
;redis.arrays.distributor = ''
;redis.arrays.functions = ''
;redis.arrays.hosts = ''
-;redis.arrays.index = ''
-;redis.arrays.lazyconnect = ''
+;redis.arrays.index = 0
+;redis.arrays.lazyconnect = 0
;redis.arrays.names = ''
-;redis.arrays.pconnect = ''
+;redis.arrays.pconnect = 0
;redis.arrays.previous = ''
-;redis.arrays.readtimeout = ''
-;redis.arrays.retryinterval = ''
-;redis.clusters.persistent = ''
-;redis.clusters.read_timeout = ''
+;redis.arrays.readtimeout = 0
+;redis.arrays.retryinterval = 0
+;redis.clusters.persistent = 0
+;redis.clusters.read_timeout = 0
;redis.clusters.seeds = ''
-;redis.clusters.timeout = ''
-;redis.session.locking_enabled = ''
-;redis.session.lock_expire = ''
-;redis.session.lock_retries = ''
-;redis.session.lock_wait_time = ''
+;redis.clusters.timeout = 0
+;redis.session.locking_enabled = 0
+;redis.session.lock_expire = 0
+;redis.session.lock_retries = 10
+;redis.session.lock_wait_time = 2000
EOF
@@ -259,7 +259,7 @@ done
%if %{with_tests}
cd NTS/tests
-# Launch redis server
+: Launch redis server
mkdir -p data
pidfile=$PWD/redis.pid
port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE;')
@@ -271,19 +271,22 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--dir $PWD/data \
--pidfile $pidfile
+# see https://github.com/phpredis/phpredis/issues/1424
+#sed -e 's/testEval/SkipEval/' -i RedisTest.php
+
+: Run the test Suite
sed -e "s/6379/$port/" -i *.php
-# Run the test Suite
ret=0
export TEST_PHP_EXECUTABLE=%{__php}
-export TEST_PHP_ARGS="--no-php-ini \
+export TEST_PHP_ARGS=" --no-php-ini \
%if %{with_igbin}
--define extension=igbinary.so \
%endif
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS TestRedis.php || ret=1
-# Cleanup
+: Cleanup
if [ -f $pidfile ]; then
%{_root_bindir}/redis-cli -p $port shutdown
fi
@@ -330,6 +333,9 @@ fi
%changelog
+* Fri Oct 12 2018 Remi Collet <remi@remirepo.net> - 4.2.0~RC1-1
+- update to 4.2.0RC1 (alpha)
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 4.1.1-2
- rebuild for 7.3.0beta2 new ABI