summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-12 08:37:15 +0200
committerRemi Collet <remi@remirepo.net>2018-10-12 08:37:15 +0200
commit5ca504892cb610ceaec642f008020f4f1170a6fc (patch)
tree795a82eaf9478e241ff9c04778ea445622061b60
parentadd808c8153c64fe551047e71ac34da91b8aaac9 (diff)
v4.2.0RC1
-rw-r--r--PHPINFO24
-rw-r--r--REFLECTION291
-rw-r--r--php-pecl-redis4.spec48
3 files changed, 324 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index e67f82d..01423c7 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,28 @@
redis
Redis Support => enabled
-Redis Version => 4.1.1
+Redis Version => 4.2.0RC1
Available serializers => php, igbinary
Available compression => lzf
+
+Directive => Local Value => Master Value
+redis.arrays.autorehash => 0 => 0
+redis.arrays.connecttimeout => 0 => 0
+redis.arrays.distributor => no value => no value
+redis.arrays.functions => no value => no value
+redis.arrays.hosts => no value => no value
+redis.arrays.index => 0 => 0
+redis.arrays.lazyconnect => 0 => 0
+redis.arrays.names => no value => no value
+redis.arrays.pconnect => 0 => 0
+redis.arrays.previous => no value => no value
+redis.arrays.readtimeout => 0 => 0
+redis.arrays.retryinterval => 0 => 0
+redis.clusters.persistent => 0 => 0
+redis.clusters.read_timeout => 0 => 0
+redis.clusters.seeds => no value => no value
+redis.clusters.timeout => 0 => 0
+redis.session.locking_enabled => 0 => 0
+redis.session.lock_expire => 0 => 0
+redis.session.lock_retries => 10 => 10
+redis.session.lock_wait_time => 2000 => 2000
diff --git a/REFLECTION b/REFLECTION
index 372d93d..6179955 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,16 @@
-Extension [ <persistent> extension #192 redis version 4.1.1 ] {
+Extension [ <persistent> extension #192 redis version 4.2.0RC1 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
+ Dependency [ session (Required) ]
}
- INI {
Entry [ redis.arrays.autorehash <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.connecttimeout <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.distributor <ALL> ]
Current = ''
@@ -21,49 +22,49 @@ Extension [ <persistent> extension #192 redis version 4.1.1 ] {
Current = ''
}
Entry [ redis.arrays.index <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.lazyconnect <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.names <ALL> ]
Current = ''
}
Entry [ redis.arrays.pconnect <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.previous <ALL> ]
Current = ''
}
Entry [ redis.arrays.readtimeout <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.arrays.retryinterval <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.clusters.persistent <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.clusters.read_timeout <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.clusters.seeds <ALL> ]
Current = ''
}
Entry [ redis.clusters.timeout <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.session.locking_enabled <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.session.lock_expire <ALL> ]
- Current = ''
+ Current = '0'
}
Entry [ redis.session.lock_retries <ALL> ]
- Current = ''
+ Current = '10'
}
Entry [ redis.session.lock_wait_time <ALL> ]
- Current = ''
+ Current = '2000'
}
}
@@ -106,7 +107,7 @@ Extension [ <persistent> extension #192 redis version 4.1.1 ] {
- Properties [0] {
}
- - Methods [215] {
+ - Methods [228] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [0] {
@@ -1407,6 +1408,134 @@ Extension [ <persistent> extension #192 redis version 4.1.1 ] {
}
}
+ Method [ <internal:redis> public method xack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <required> array $arr_ids ]
+ }
+ }
+
+ Method [ <internal:redis> public method xadd ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_id ]
+ Parameter #2 [ <required> array $arr_fields ]
+ Parameter #3 [ <optional> $i_maxlen ]
+ Parameter #4 [ <optional> $boo_approximate ]
+ }
+ }
+
+ Method [ <internal:redis> public method xclaim ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <required> $str_consumer ]
+ Parameter #3 [ <required> $i_min_idle ]
+ Parameter #4 [ <required> array $arr_ids ]
+ Parameter #5 [ <optional> array $arr_opts ]
+ }
+ }
+
+ Method [ <internal:redis> public method xdel ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> array $arr_ids ]
+ }
+ }
+
+ Method [ <internal:redis> public method xgroup ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_operation ]
+ Parameter #1 [ <optional> $str_key ]
+ Parameter #2 [ <optional> $str_arg1 ]
+ Parameter #3 [ <optional> $str_arg2 ]
+ Parameter #4 [ <optional> $str_arg3 ]
+ }
+ }
+
+ Method [ <internal:redis> public method xinfo ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_cmd ]
+ Parameter #1 [ <optional> $str_key ]
+ Parameter #2 [ <optional> $str_group ]
+ }
+ }
+
+ Method [ <internal:redis> public method xlen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:redis> public method xpending ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <optional> $str_start ]
+ Parameter #3 [ <optional> $str_end ]
+ Parameter #4 [ <optional> $i_count ]
+ Parameter #5 [ <optional> $str_consumer ]
+ }
+ }
+
+ Method [ <internal:redis> public method xrange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_start ]
+ Parameter #2 [ <required> $str_end ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method xread ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> array $arr_streams ]
+ Parameter #1 [ <optional> $i_count ]
+ Parameter #2 [ <optional> $i_block ]
+ }
+ }
+
+ Method [ <internal:redis> public method xreadgroup ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_group ]
+ Parameter #1 [ <required> $str_consumer ]
+ Parameter #2 [ <required> array $arr_streams ]
+ Parameter #3 [ <optional> $i_count ]
+ Parameter #4 [ <optional> $i_block ]
+ }
+ }
+
+ Method [ <internal:redis> public method xrevrange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_start ]
+ Parameter #2 [ <required> $str_end ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method xtrim ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $i_maxlen ]
+ Parameter #2 [ <optional> $boo_approximate ]
+ }
+ }
+
Method [ <internal:redis> public method zAdd ] {
- Parameters [3] {
@@ -2097,7 +2226,7 @@ Extension [ <persistent> extension #192 redis version 4.1.1 ] {
- Properties [0] {
}
- - Methods [166] {
+ - Methods [179] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [5] {
@@ -3252,6 +3381,134 @@ Extension [ <persistent> extension #192 redis version 4.1.1 ] {
}
}
+ Method [ <internal:redis> public method xack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <required> array $arr_ids ]
+ }
+ }
+
+ Method [ <internal:redis> public method xadd ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_id ]
+ Parameter #2 [ <required> array $arr_fields ]
+ Parameter #3 [ <optional> $i_maxlen ]
+ Parameter #4 [ <optional> $boo_approximate ]
+ }
+ }
+
+ Method [ <internal:redis> public method xclaim ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <required> $str_consumer ]
+ Parameter #3 [ <required> $i_min_idle ]
+ Parameter #4 [ <required> array $arr_ids ]
+ Parameter #5 [ <optional> array $arr_opts ]
+ }
+ }
+
+ Method [ <internal:redis> public method xdel ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> array $arr_ids ]
+ }
+ }
+
+ Method [ <internal:redis> public method xgroup ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_operation ]
+ Parameter #1 [ <optional> $str_key ]
+ Parameter #2 [ <optional> $str_arg1 ]
+ Parameter #3 [ <optional> $str_arg2 ]
+ Parameter #4 [ <optional> $str_arg3 ]
+ }
+ }
+
+ Method [ <internal:redis> public method xinfo ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_cmd ]
+ Parameter #1 [ <optional> $str_key ]
+ Parameter #2 [ <optional> $str_group ]
+ }
+ }
+
+ Method [ <internal:redis> public method xlen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:redis> public method xpending ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_group ]
+ Parameter #2 [ <optional> $str_start ]
+ Parameter #3 [ <optional> $str_end ]
+ Parameter #4 [ <optional> $i_count ]
+ Parameter #5 [ <optional> $str_consumer ]
+ }
+ }
+
+ Method [ <internal:redis> public method xrange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_start ]
+ Parameter #2 [ <required> $str_end ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method xread ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> array $arr_streams ]
+ Parameter #1 [ <optional> $i_count ]
+ Parameter #2 [ <optional> $i_block ]
+ }
+ }
+
+ Method [ <internal:redis> public method xreadgroup ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $str_group ]
+ Parameter #1 [ <required> $str_consumer ]
+ Parameter #2 [ <required> array $arr_streams ]
+ Parameter #3 [ <optional> $i_count ]
+ Parameter #4 [ <optional> $i_block ]
+ }
+ }
+
+ Method [ <internal:redis> public method xrevrange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $str_start ]
+ Parameter #2 [ <required> $str_end ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method xtrim ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> $i_maxlen ]
+ Parameter #2 [ <optional> $boo_approximate ]
+ }
+ }
+
Method [ <internal:redis> public method zadd ] {
- Parameters [3] {
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 5638728..ff1763e 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -28,13 +28,13 @@
# after 40-igbinary
%global ini_name 50-%{pecl_name}.ini
%endif
-%global upstream_version 4.1.1
-#global upstream_prever RC3
+%global upstream_version 4.2.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
@@ -160,26 +160,26 @@ extension = %{pecl_name}.so
;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2"
; Configuration
-;redis.arrays.autorehash = ''
-;redis.arrays.connecttimeout = ''
+;redis.arrays.autorehash = 0
+;redis.arrays.connecttimeout = 0
;redis.arrays.distributor = ''
;redis.arrays.functions = ''
;redis.arrays.hosts = ''
-;redis.arrays.index = ''
-;redis.arrays.lazyconnect = ''
+;redis.arrays.index = 0
+;redis.arrays.lazyconnect = 0
;redis.arrays.names = ''
-;redis.arrays.pconnect = ''
+;redis.arrays.pconnect = 0
;redis.arrays.previous = ''
-;redis.arrays.readtimeout = ''
-;redis.arrays.retryinterval = ''
-;redis.clusters.persistent = ''
-;redis.clusters.read_timeout = ''
+;redis.arrays.readtimeout = 0
+;redis.arrays.retryinterval = 0
+;redis.clusters.persistent = 0
+;redis.clusters.read_timeout = 0
;redis.clusters.seeds = ''
-;redis.clusters.timeout = ''
-;redis.session.locking_enabled = ''
-;redis.session.lock_expire = ''
-;redis.session.lock_retries = ''
-;redis.session.lock_wait_time = ''
+;redis.clusters.timeout = 0
+;redis.session.locking_enabled = 0
+;redis.session.lock_expire = 0
+;redis.session.lock_retries = 10
+;redis.session.lock_wait_time = 2000
EOF
@@ -259,7 +259,7 @@ done
%if %{with_tests}
cd NTS/tests
-# Launch redis server
+: Launch redis server
mkdir -p data
pidfile=$PWD/redis.pid
port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE;')
@@ -271,19 +271,22 @@ port=$(%{__php} -r 'echo 9000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + P
--dir $PWD/data \
--pidfile $pidfile
+# see https://github.com/phpredis/phpredis/issues/1424
+#sed -e 's/testEval/SkipEval/' -i RedisTest.php
+
+: Run the test Suite
sed -e "s/6379/$port/" -i *.php
-# Run the test Suite
ret=0
export TEST_PHP_EXECUTABLE=%{__php}
-export TEST_PHP_ARGS="--no-php-ini \
+export TEST_PHP_ARGS=" --no-php-ini \
%if %{with_igbin}
--define extension=igbinary.so \
%endif
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS TestRedis.php || ret=1
-# Cleanup
+: Cleanup
if [ -f $pidfile ]; then
%{_root_bindir}/redis-cli -p $port shutdown
fi
@@ -330,6 +333,9 @@ fi
%changelog
+* Fri Oct 12 2018 Remi Collet <remi@remirepo.net> - 4.2.0~RC1-1
+- update to 4.2.0RC1 (alpha)
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 4.1.1-2
- rebuild for 7.3.0beta2 new ABI