summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-redis-dev.spec5
-rw-r--r--php-pecl-redis.spec5
2 files changed, 10 insertions, 0 deletions
diff --git a/php-pecl-redis-dev.spec b/php-pecl-redis-dev.spec
index f8b757a..116d7a1 100644
--- a/php-pecl-redis-dev.spec
+++ b/php-pecl-redis-dev.spec
@@ -143,6 +143,11 @@ ln -sf %{php_ztsextdir}/igbinary.so zts/modules/igbinary.so
%if %{with_test}
cd nts/tests
+# this test requires redis >= 2.6.9
+# https://github.com/nicolasff/phpredis/pull/333
+sed -e s/testClient/SKIP_testClient/ \
+ -i TestRedis.php
+
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -e "s:/var:$PWD:" \
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index d8b7799..94c85b8 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -151,6 +151,11 @@ ln -sf %{php_ztsextdir}/igbinary.so zts/modules/igbinary.so
%if %{with_test}
cd nts/tests
+# this test requires redis >= 2.6.9
+# https://github.com/nicolasff/phpredis/pull/333
+sed -e s/testClient/SKIP_testClient/ \
+ -i TestRedis.php
+
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -e "s:/var:$PWD:" \