summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-30 14:49:21 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-30 14:49:21 +0200
commit5ad9a308782fbc9f005e6f60cf6fa9c0156d13e5 (patch)
tree0f3ccdd18e9b670fa25afca7c661e6fcab2fd1e5
parent6a88a7e91f07d2d23652d31279f0f5ea265ee0a7 (diff)
fix build with redis < 2.6.9 (available in fedora repo)
-rw-r--r--php-pecl-redis-dev.spec5
-rw-r--r--php-pecl-redis.spec5
2 files changed, 10 insertions, 0 deletions
diff --git a/php-pecl-redis-dev.spec b/php-pecl-redis-dev.spec
index f8b757a..116d7a1 100644
--- a/php-pecl-redis-dev.spec
+++ b/php-pecl-redis-dev.spec
@@ -143,6 +143,11 @@ ln -sf %{php_ztsextdir}/igbinary.so zts/modules/igbinary.so
%if %{with_test}
cd nts/tests
+# this test requires redis >= 2.6.9
+# https://github.com/nicolasff/phpredis/pull/333
+sed -e s/testClient/SKIP_testClient/ \
+ -i TestRedis.php
+
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -e "s:/var:$PWD:" \
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index d8b7799..94c85b8 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -151,6 +151,11 @@ ln -sf %{php_ztsextdir}/igbinary.so zts/modules/igbinary.so
%if %{with_test}
cd nts/tests
+# this test requires redis >= 2.6.9
+# https://github.com/nicolasff/phpredis/pull/333
+sed -e s/testClient/SKIP_testClient/ \
+ -i TestRedis.php
+
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -e "s:/var:$PWD:" \