summaryrefslogtreecommitdiffstats
path: root/php-pecl-pinpoint.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-29 11:52:09 +0200
committerRemi Collet <remi@php.net>2024-07-29 11:52:09 +0200
commit4abc2157e0bcc3770c68bc13f6e42ed17ee7667e (patch)
treec56c721ffbae71228a56ab84b5b5a0d1fd2ccb48 /php-pecl-pinpoint.spec
initial package
open https://github.com/pinpoint-apm/pinpoint-c-agent/issues/656 license open https://github.com/pinpoint-apm/pinpoint-c-agent/pull/655 use cxx
Diffstat (limited to 'php-pecl-pinpoint.spec')
-rw-r--r--php-pecl-pinpoint.spec175
1 files changed, 175 insertions, 0 deletions
diff --git a/php-pecl-pinpoint.spec b/php-pecl-pinpoint.spec
new file mode 100644
index 0000000..f1efa29
--- /dev/null
+++ b/php-pecl-pinpoint.spec
@@ -0,0 +1,175 @@
+# remirepo spec file for php-pecl-pinpoint
+#
+# Copyright (c) 2024 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-pinpoint}
+
+%global pecl_name pinpoint_php
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global upstream_version 0.5.2
+#global upstream_prever RC2
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
+
+Summary: PHP extension for pinpoint-apm<
+Name: %{?scl_prefix}php-pecl-pinpoint
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: Apache-2.0
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+Patch0: %{pecl_name}-cxx.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+
+
+%description
+This extension provides an API pinpoint-apm and built-in function
+auto-injection.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd %{sources}
+sed -e 's/\r//' -i config.m4
+%patch -P0 -p1 -b .pr655
+
+# Sanity check, really often broken
+extver=$(sed -n '/PHP_PINPOINT_PHP_VERSION/{s/.* "//;s/".*$//;p}' php_pinpoint_php.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable "%{summary}" extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;pinpoint_php.SendSpanTimeOutMs =0
+;pinpoint_php.CollectorHost = unix:/tmp/collector.sock
+;pinpoint_php.UnitTest = no
+;pinpoint_php.TraceLimit = -1
+;pinpoint_php.DebugReport = no
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure \
+ --enable-pinpoint_php \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --enable-pinpoint_php \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{__php} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%files
+%license %{sources}/LICENSE
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Jul 29 2024 Remi Collet <remi@remirepo.net> - 0.5.2-1
+- initial package
+- open https://github.com/pinpoint-apm/pinpoint-c-agent/issues/656 license
+- open https://github.com/pinpoint-apm/pinpoint-c-agent/pull/655 use cxx